Blinking cursor after booting from hard drive in FOG menu, on Optiplex 5040s



  • Server
    • FOG Version: 1.3.4
    • OS: CentOS
    Client
    • Service Version:
    • OS:

    On our computers that are set to boot to network, the computer boots to FOG, is on the “boot from hard drive option” by default, and boots to the hard drive after the 15-second timeout.

    We put the same Windows 10 1511 image on both Optiplex 7010s and Optiplex 5040s. When the 7010s boot from hard drive in FOG, no issue. When the 5040s boot from hard drive in FOG, a black screen with a blinking white cursor appears. The screen never goes away until powering off the machine.

    These are all legacy/MBR.

    Both the 7010s and 5040s boot from the hard drive (not in FOG) just fine. We successfully image the 5040s with FOG just fine, too. As far as we can see, everything in FOG works fine with the 5040s except booting from the hard drive within the FOG menu.

    Any ideas?



  • For those who run into this, I am receiving new computers from Dell with SATA mode set to RAID. Changing this setting to AHCI solves this problem for me. I am using Fog version 1.4.0-RC-14.


  • Senior Developer

    Feel I might like to add on.

    A lot of work has gone into the resizing and uuid settings of the imaging process and I believe this is what was causing your “blinking cursor”. Would you mind updating to the latest RC (13 as of this writing) to see if your devices are now able to successfully boot?


  • Developer

    so, the 5040’s that you have imaged with fog boot fine if you set the bios to not boot to the network first, correct?
    this is most likely caused by the “exit type” being used not working correctly for that model.

    to change this setting globally, change the setting “Exit to Hard Drive Type” in “FOG Configuration > iPXE Boot Menu Configuration”

    to change this on a host by host basis, change “Host Bios Exit Type” on the host’s profile page in “Host Management”


  • Moderator

    While this “shouldn’t” matter. Do the 5040s have NVMe (M.2) drives or traditional SATA drives?

    If you deploy a Win7 image to to 5040s does it boot through fog correctly. Right now, in my mind its not clear if its the OS, FOG, or the hardware that is causing this boot failure.


  • Senior Developer

    Sorry processed faster than I read.

    Can you provide the 5040’s MBR file (in email if you need to) and the contents of d1.partitions and d1.minimum.partitions


  • Senior Developer

    @loosus456 Trying to understand the problem.

    5040’s are not getting through to iPXE at all (and booting to the OS which I’m guessing doesn’t exist?)


Log in to reply
 

328
Online

38724
Users

10553
Topics

99906
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.