Start on fog with windows 10



  • Server
    • FOG Version: 1.3.4
    • OS: ubuntu
    Client
    • Service Version:
    • OS: windows 10
    Description

    Hello,
    I have a problem to start on the NIC when windows starts.
    My computer is a Dell optiplex 3040MT with windows 10.
    My problem is when windows boots the pxe server does not start. Do you know if I have to modify anything in BIOS ?

    Thanks for your help.


  • Senior Developer

    @mimi1255 That only partially solves the problem. Now your network, as far as I can tell, is handing out boot files for UEFI machines. This will cause unexpected things whenever you get new systems in as most are now coming with default settings of UEFI enabled systems. While you are correct that you will need to turn off secure boot, this will not (at least I don’t think so) fix the problem you were seeing when you were UEFI booting the system.



  • @Tom-Elliott
    I solved my problem, in fact in the bios I have to disable the secure boot and I enabled ROM legacy.


  • Senior Developer

    Further reading, more questions come to mind. Do you have a Dell KACE server sitting around somewhere handing this system a UEFI PXE boot file?


  • Senior Developer

    Is the TFTP server sending ipxe.efi? What’s happening?

    “My problem is when windows boots the pxe server does not start.” What does this mean? Windows has no effect on the system in regards to PXE booting at all. Do you mean, when you boot the system, PXE isn’t working? Do you mean, the system isn’t even asking for PXE boot at all?


  • Moderator

    The pictures tell us how this device is setup, thank you.

    Now I need to ask you a few questions about your computing environment.

    1. Is this the first computer you try to pxe boot into FOG?
    2. What exactly do you have configured for dhcp option 66 {boot-server} and dhcp option 67 {boot-file}?
    3. When you look at the network cable as you boot this computer, is the link light on?
    4. Is the pxe booting computer on the same subnet (vlan) as the fog server and dhcp server?
    5. What device is your network using for dhcp services?


  • In fact the PC does not start on the PXE server. Below my screenshot.
    Thanks.

    0_1487316320884_IMG_1143.JPG

    0_1487316350274_IMG_1145.JPG

    0_1487316354499_IMG_1142.JPG


  • Moderator

    I’m sorry to say your post isn’t clear at all (I think I’m channeling Tom this afternoon).

    With the dells in uefi mode you need to go into the firmware and on the network adapter configuration you need to enable the network stack for uefi mode. If you do not there will not be an option to pxe boot when you press F12 for the boot menu.


  • Developer

    @mimi1255 if possible, use legacy, from your post history, that’s mostly likely what you’ve been using in the past. you can make both work at the same time, but let’s just verify it’s working first.



  • In fact I added the NIC option to start on the network. But when it starts in fact it is the diagnostic system of dell which starts. Maybe there is a link with the licensing ? UEFI or legacy ?


  • Developer

    @mimi1255 you have to set the computer to boot to network as it’s first boot priority in the bios


Log in to reply
 

436
Online

39000
Users

10717
Topics

101757
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.