Fog download image fails



  • Server
    • FOG Version: * OS: 1.3.4
    Client
    • Service Version:
    • OS: centos 7
    Description

    After recently upgrading to the latest stable release, our imaging services no longer work. The system attempts to image after host registration, and fails at downloading image. The error received is states a permissions error for /bin/fog.download, but the system was fully operational before the upgrade, and no credentials have changed.


  • Moderator

    @george1421 If this all proves out to work there are two last things you need to to.

    1. Edit the file /opt/fog/.fogsettings There is a line in there called listed as
    storageLocation='/images'
    

    You need to change it to:

    storageLocation='/storage1'
    

    Then run the installer program again (once your imaging is complete). That will just realign everything for you. When the update is done, reboot the fog server. When the fog server comes up reconfirm that showmount -e 127.0.0.1 still shows your /storage1 share as being shared.



  • @george1421 This has fixed the issue at hand. Thank you for your assistance.


  • Moderator

    @wlsnfmly Ah ok, just a suspected. You have your images on a different drive than where the OS is stored (that is a good thing).

    To fix your issue then: edit this file /etc/exports

    Change the 2 lines in there from /images to /storage1

    So your lines should look like this:

    /storage1 *(ro,sync,no_wdelay,no_subtree_check,insecure_locks,no_root_squash,insecure,fsid=0)
    /storage1/dev *(rw,async,no_wdelay,no_subtree_check,no_root_squash,insecure,fsid=1)
    

    Save the file then run this command: sudo exportfs -a
    Then confirm that the shares have been changed with: showmount -e 127.0.0.1

    The shares should have now changes from /images to /storage1

    If that is the case then restart imaging your target computer.




  • Moderator

    @george1421 Might I ask you to post the output of this command too?
    df -h I want to make sure that /storage1 share isn’t being used for something else.


  • Moderator

    @wlsnfmly Switching to chat, look at the little speech bubble up by the FOG tool tray at the top of the browser window.



  • @george1421 Here are two images to check. One shows why it is looking for those files, from the fog config page. The second is the one you have requested. 0_1487180296194_Capture.PNG 0_1487180345448_Capture.PNG


  • Moderator

    @wlsnfmly So you have a directory off the root of your fog server with /storage1 and /storage1/dev names?

    Could you post s screen shot of these commands?
    ls -la /
    ls -ls /storage1



  • @george1421 I didn’t personally make any changes during the upgrade. However, I did upgrade from 1.2.0 to 1.3.4, would that have caused the issue? is there a quick fix? the permissions on storage1 show 777 and images are the same


  • Moderator

    @wlsnfmly Ok then, please tell me why the client wants to connect to <fog_server_ip>:/storage1 but you only are sharing <fog_server_ip>:/images and <fog_server_ip>:/images/dev from your fog server?

    It sounds like you made a change to the fog server’s storage node settings. What were you trying to accomplish. (your answer will help us pick the best path for you).



  • @george1421 that is my fog servers ip address


  • Moderator

    @wlsnfmly Well that explains a bit more of what is going on.

    On your FOG server you have /images and /images/dev shared.

    But your error message says the client computer can’t connect to 10.1.20.127:/storage1 (you are trying to connect to the /storage1 share on the device 10.1.20.127)

    What is the host 10.1.20.127?



  • @george1421 It does show both directories. 0_1487178955240_Capture.PNG


  • Moderator

    @wlsnfmly In addition to what Tom posted. From the fog server I would run the following command to confirm the nfs shares are in place showmount -e 127.0.0.1 The output should show you both /images and /images/dev

    <edit>Based on your last post, I’m more interested in seeing the output of the showmount command than before</edit>



  • @Tom-Elliott Did that, no luck, here is a screen shot of the error we are receiving. 0_1487178729208_image2.png


  • Senior Developer

    @wlsnfmly The fog.* scripts exist in the init’s not on your physical fog server.

    He’s referring to your images directory though in regards to permissions.

    Please run (on the fog server):

    sudo touch /images/.mntcheck
    sudo touch /images/dev/.mntcheck
    sudo chmod -R 777 /images


  • @Jaymes-Driver The problem is that the file doesn’t exist. In checking the /bin folder for a file called fog.download, there is nothing there. nor is there a fog.upload folder either.



  • This post is deleted!

  • Developer

    Have you tried a chmod command to change the permissions on that folder?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.