1.3.3 to 1.3.4 - Delayed Tasks don't work anymore



  • Server
    • FOG Version: 1.3.4
    • OS: Ubuntu 14.04.1
    Client
    • Service Version: 11.9
    • OS: Windows 7 pro 64bits
    Description

    I have tried an update from 1.3.3 to 1.3.4 because cron tasks don’t work and kernel update page can’t pass trough proxy. The update work fine but delayed tasks don’t work any more and cron tasks still don’t work.



  • @Tom-Elliott
    Hello,
    Thanks for your answer, I will wait for 1.3.5 release.


  • Senior Developer

    This was also known about and fixed in 1.3.5-RC-1:

    From: https://news.fogproject.org/fog-1-3-5-rc-1/

    Fix missed variable for FOG Scheduler service.


  • Moderator

    Check to see if FOGScheduler.service is running, check it’s status. Give it a restart.

    Also, look at the logs. In the web interface it’s:
    Web Interface -> FOG Configuration -> Log Viewer -> Scheduler
    The local log file on the server is here:
    /opt/fog/log/fogscheduler.log

    Check the date and time on your server with the date command, make sure it’s right.
    Make sure your PHP timezone is set correctly, it’s here:
    Web Interface -> FOG Configuration -> FOG Settings -> General Settings -> FOG_TZ_INFO
    And just to be thorough, make sure your sleep time for the FOGScheduler isn’t set to something absurd, the setting is here and the default is 60 seconds:
    Web Interface -> FOG Configuration -> FOG Settings -> FOG Linux Sleep Times -> SCHEDULERSLEEPTIME

    Please go through all of the above and correct issues. Then setup some very simple tests that happen just 5 minutes after when you schedule them. Keep an eye on the logs during the 5 minutes. Let us know what you find.


Log in to reply
 

435
Online

39001
Users

10717
Topics

101758
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.