Wireless MAC Address - URGENT



  • Hi Guys

    Need urgent help with this one…

    I have fog 0.32 implemented and we are about to image 100+ lap tops. Obviously they will be wired to the switch through the LAN for imaging, however, with FOG agent installed, once they go wireless, how will I be able to send them snap-ins etc without having to connect them back to the switch via LAN?

    the wiki says nothing other than “this content is not complete”.

    I have thought about MAC spoofing the LAN address to the wireless, this is a whole can of worms… I have even though about manually changing the mysql database entries post imaging of the LAN Mac’s to the Wireless MAC’s.

    I know other imaging solutions handle this by looking for computer name rather than MAC address.
    PLEASE HELP…



  • Hi chad-bisd

    Thank you for your replies.

    It was me, I have been overlooking… I found it after check each laptop (30+) - it was active in 2 of them. It is a remote site and though they are instructed to connect to the local wifi after imaging, it looks like it has not happened. I should have checked instead of assuming…

    Now the laptops are roving and connecting in via Cisco VPN, (mostly via wireless) thus it does not register the MAC over the VPN…

    Ohh well, have to gather the MACs by some other method…

    Thanks again for your help.

    Steve


  • Moderator

    If you connect the laptop to wired network and boot it up, allowing the OS to connect to wireless also, the FOG client should register the wireless mac address to the host which it recognizes by the wired mac address. They both need to be connected at some point so they can be associated with each other. If you do this once, usually first boot after imaging, then the host should have a pending mac in it’s host general info page.

    I believe the next version of the FOG client changes the way it scans the system for mac addresses as the current way only keys on active connections and if the wired mac is not connected, it doesn’t see it to associate the wireless mac to it.



  • Hi chad-bisd

    Thanks for the reply.

    I have checked on a laptop that is connected via wireless, but the MAC is not shown on the info page?

    I have attached an image of the screen.

    I note that when I list all current hosts, FOG can’t resolve any of them, is that anything to do with it? (as I thought it was the FOG Tray service).

    Any idea why it is not showing up?

    Thanks again.

    FOG1.jpg


  • Moderator

    Go to a host’s general information tab. If there is an additional mac address with a green check mark, that is the pending mac. click the check mark and it’s “accepted”.



  • Hi

    I can’t find the bit to allow pending MAC’s anywhere.

    I am runnning 0.32, all I can find is Pending MACs under the Reports icon, this produces a CSV with pending MACs listed, but I just can’t find anywhere where I can approve them on the GUI?

    Any help please.

    Thanks


  • Moderator

    Here: This will accept all pending MACs without question. This is a hack, and not an elegant way. It does try to wrap the statements in a transaction to avoid leaving macs in the pending table that have been approved, or removed macs that didn’t get added successfully.

    If someone wants to add some MySQL error handling to this, feel free. It won’t hurt my feelings.

    BEGIN;
     
    INSERT INTO hostMAC (hmHostID, hmMAC) SELECT pmHostID, pmAddress FROM pendingMACS;
     
    DELETE FROM pendingMACS;
     
    COMMIT;
    

    I use phpmyadmin, and run this as a bookmarked query in the fog database.

    You can also save this as a .sql file and use run it against your database from the command line:

    user@fogserver:~$ mysql -u root -p[password] fog < approvependingmacs.sql
    

    Maybe even schedule a cron job to automatically approve pending macs on a schedule.



  • So is there a setting or change that can be made to auto-accept pending MACs? I see this being a huge pain in the rear as I’m running primarily 1200 laptops and versus having to select each host one by one and approve the pending MAC, it’d be much simpler to just have it auto-register and approve with host registration.



  • hey chad-bisd - that will work…

    I guess because of the lack of documentation in the wiki combined with some assumptions on my part, I didnt think to leave both connections active until the second MAC registered.

    This does work and snapins do deploy to the wirelss client after you have added the pended MAC.

    So I guess simple wiki update would save some troubles.

    Thanks for your input.


  • Moderator

    In my situtation, the computer (Win 7 Pro 32 bit) is imaged, renamed, and joined to the domain all while connected to the wired network. When windows boots up before or after the domain join, the wireless network card auto connects to the local wireless because the image has the wireless network preconfigured on it and set to automatically connect.

    So, by the time I unplug the wired LAN and move the computer, Fog already knows about the wireless MAC and it’s waiting in the host information tab as a pending MAC.

    I don’t currently do anything with snap-ins, but I have plans to implement them for some things and it would be nice to know that they’ll work as long as the wireless MAC is approved for each host.



  • @BryceZ, post: 4640, member: 2 said:

    Have you added the wireless MAC addresses as additional MAC’s on the host’s page? I could be wrong, but I was under the impression that the additional MAC feature was built to address this issue.

    Hey BryceZ

    That feature is in 0.32, however, I believe there is a problem when it comes to its execution.

    From looking at the source code, it appears that the FOG agent on the host machien, after discovering that it is not associated with the server (because of a different MAC) polls the host for all MACs with “IPEndabled” = True.

    Microsoft describes IPEnabled as being the status of the TCP/IP being bound to a NIC.

    In windows XP, the binding persists to the physical NIC even though the network cable is unplugged. however, in windows 7, once the network cable is unplugged, the binding is released and IPEndabled = FALSE, therefore, FOG Service on host shows “exiting because only 1 mac found” or words to that effect, so it assumes that it has not been registered with the host.

    The fix would be to associate the task with the host name rather than the host MAC.

    I think I will be writing a script to modify the mysql database and update wired mac with wireless mac on boot up, then reverse the process on shut down.

    Should I be placing this post in the bugs forum?

    Can anyone replicate?


  • Moderator

    Is there a way to accept all pending MACs at once or do you still have to go host to host to see if it has a pending mac that needs approval?



  • Have you added the wireless MAC addresses as additional MAC’s on the host’s page? I could be wrong, but I was under the impression that the additional MAC feature was built to address this issue.



  • ok… a little update…

    MOD_Snapinclient.cs shows:

    “while (blGo)
    {
    // process every mac address on the machine
    // to make sure we get all intended snapins

    So, if I turn off [B]FOG_SERVICE_HOSTREGISTER_ENABLED[/B]

    I still should be able to send snap ins to hosts on a wireless active MAC with a non-active original LAN MAC used to register the host in the first place.

    OR

    are only active or live NIC’s being used for processing?

    Please help me out FOG GURU’s


Log in to reply
 

425
Online

38722
Users

10550
Topics

99863
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.