SOLVED How to create subfolders in a storage node

  • @george1421 Thank you. I actually got the subfolders to work. I had to manually create the folder, set rights, and it works inside /images. However, my latest thoughts, I want to add hard drive space outside of LVM to /images. So I set a mount point with the proper rights to /images/vol1, vol1 being the new mount point of a hard drive. The image looks like it goes up no issues, until the end, the system won’t copy the images from /dev over to /vol1. I tried creating this as a storage group /images/vol1, and a fake directory if you will concept and I have no luck. In the past, couldn’t you have more HD in the server for storage nodes, or am I dreaming about this. I have spent two days, trying to figure this out, its now a challenge to see if it works. Take care, thank you for the response.

  • Moderator

    Just circling back on this after I talked with the developers. That sub directory functionality WAS added to FOG 1.4.0. I was wrong before. You can create subfolders in the /images directory something (as seen below). Once you set your image name you can alter the image path field. Understand there is ONE caveat here, as in my example the /images/myfolder directory MUST exist before you create this image definition. If not your capture will fail.

    In your case the /images/myfolder (or what ever you call it) will be a mount point for your new disk volume.


  • Moderator

    @sdm42doc No joy for you, subfolders are still not supported.

    Now you do have some options.

    1. If your server uses LVM, just add the additional space to the LVM volume where the /images are.
    2. Temp mount the new volume over another directory, move the contents of /images to the new volume via the mount point, disconnect the mount point and mount it over /images

    There are some other ways to extend it but it then gets a bit messy.

  • Has anyone had any luck with directories under /images.

    I mounted another volume (for more storage) under /images to try to force it and no luck.

    I thought you could have multiple storage nodes on the same server with additional hard drives at one point. I have been a “fog user” since the beginning, and thought for sure i had this setup before.

    I am on Ubuntu 16.04.02 with current version of FOG 1.4.0.

  • @george1421 Thanks! I just upgraded FOG, and it works perfectly 🙂

  • Moderator

    @Hongyun There is no harm in doing this now or waiting for the stable release. The choice is yours.

  • @george1421 Thanks! I will wait for the stable release then, it’s not super urgent 🙂

  • Moderator

    @Hongyun FWIW: 1.3.5 has not been released just yet.

    If you would like to update to the latest release candidate 1.3.5-RC7 (that will most likely become 1.3.5 stable) you can follow these steps:

    git clone
    cd fogproject
    git checkout dev-branch
    cd bin
    ./ -y

    Understand that will tell git to only look at the dev-branch. So once 1.3.5 stable is released you will want to run these commands to reset git back to the main feed:

    cd fogproject
    git checkout master
    cd bin
    ./ -y

  • @Tom-Elliott Can you let me know where to download 1.3.5? I got a version by using git clone command, but the version I downloaded still have the same problem.

    git clone

  • @Hongyun Yes, update please. I fixed the stripping of forward slashes, and I think backslashes too.

  • @Tom-Elliott Any update on this?

  • But whenever I add CLAB/ in front of the image name, it will automatically remove /, for example, if my image name is ubuntu16, if I enter CLAB/ubuntu16 in the image name, it will automatically changed to CLABubuntu16.

  • @Hongyun I don’t think you need the NFS mount to handle “sub” directories.

    It would mean updating your images to use the proper path.

    For example, you have CLAB directory right? It’s already created.

    In the image path field, you would set it to:
    CLAB/<rest of path as you’d like it>

    No need to add the CLAB to the NFS mounts.

  • The old version I mean 1.2.0.
    The server OS is Red Hat Enterprise 6.8, kernel 2.6.32

    CLAB is just a sub folder of /images, I used to create multiple mount points so when I upload images, it will be saved in the sub folders instead of the /images folder.

    If you have better solution instead of using multiple storage nodes, it should be fine for me too. Otherwise, I guess I will have to live with it.

  • When you are giving us information, please give us as much as possible.

    In particular, “old version” is not very useful as old is relative. To me, 1.3.3 is “old” since 1.3.4 was released.

    Please also provide OS you’re running on and version of the OS if/as/where/when possible.

    From the sounds of things, you have two “storage” nodes on your setup?

    Is there a reason you’re using CLAB? Is this a mount from somewhere else.

  • Moderator

    While I don’t have an answer for you, could you also include what version is considered the “old version” of fog?