Fresh install Ubuntu 16.04.1 Fog 1.3.4 Error



  • AMD XII Server

    • FOG Version: 1.3.4
    • OS: Ubuntu 16.04.1
      Hi all,
      Setting up a new server fresh install of Ubuntu 16.04.1 and Fog 1.3.4; upon starting Fog install I get an error that says after Starting Debian Installation

    " Detected a Potential need to reinstall apache and PHP files.

    • this will remove /etc/php* and /etc/apache2* directories and remove / purge the Apache and php files from the system.
      IF you’re okay with this type “Y” anything else will break the install and you will have to remove the files yourself and make proper changes as necessary (Y/N).

    I am at a stand still here…my FIRST install of this Imaging software, currently running on separate server working fine is 1.2.0 on Ubuntu 12.04.5



  • @butch2861 said in Fresh install Ubuntu 16.04.1 Fog 1.3.4 Error:

    The problem above is on the CLIENT end, not there server…server is okay from what I can tell

    The server wasn’t OK at the time I posted what I did, it was out of space. This was not a fresh install of Ubuntu 16 /w fog if you were already out of space. The title of this thread should be changed.



  • BIG SHOUT OUT TO TOM!!! he is da man…saved by BACON…very nice to work with…appreciate all the work he did for me…I have a new Ubuntu 16.04.1 Server running 1.3.5 Fog…SWEET!!!


  • Senior Developer

    Just wanted to post an update on this as I didn’t last night.

    I remoted in last night and we were able to successfully install fog 1.3.5 working branch (just to ensure alter tables was being set). This installed without any major issues.

    Next we imported the originating fog server. This way we wouldn’t need to redefine image defs, register hosts, etc…

    Then we starting copying the actual image data from the original fog server (this was where the drive got filled up and why.)

    The reasoning for the unable to find issue was because the ip on the new was originally different than what set in the DB. This originally set the chain to get the main data at the wrong ip address. The next issue was it was missing the /fog/ part of the url. This would’ve been fine if it was a docrooted setup, but it was not.


  • Developer

    The link I am talking about is this one: http://10.0.10.247/service/ipxe/boot.php

    If your server is up and running and you cannot access this URL from any of your clients within this network, then something is definitely wrong with the installation. Possibly when installing the disk filled up and the installer was not able to copy all the files needed. Do a fresh install of FOG (possibly even the server OS) and see if it works out. What else can I say?



  • @Sebastian-Roth Yes as far as opening the links I did try that; this is where it takes me when I go to the ipxe.org link
    http://ipxe.org/err/2d0c61

    first link it fails because I have the old server hooked up at this moment…I am by no mean trying to waste ANYONES time…and I would be GLAD to PAY someone to fix the issue…I have 700 devices to take care of everyday and am just 1 guy for a school District and was wanting to update to a new server before Testing starts in a couple weeks so i can re-image and also be ready for future Windows 10 deployments…now we are mostly 7; I REALLY do appreciate ALL the help 25+ years experience…but NOT much on Linux CLI so I can see where I would come off like an idiot that knows nothing…lol


  • Developer

    Are you reading my posts at all? I am not going to repeat myself over and over again…



  • @Sebastian-Roth This is defiantly an issue with the new server; I fired up my other fog server that I have not de-commissioned yet and my client sees and boots to pxe no problems and starts download…could this be a pxe issue on new server? Error from client after seeing the webserver Ip and TFTP server on boot; basically right before it starts the small image copy this error comes up:

    http://10.0.10.247/service/ipxe/boot.php…No Such File or Directory (http://ipxe.org/2d0c613b) Could Not Boot: Chainloading failed


  • Developer

    Are you able to open that URL in your browser (from any PC within your network)?? If not then there is something wrong with your installation.



  • @Wayne-Workman The problem above is on the CLIENT end, not there server…server is okay from what I can tell; I edited the default.ipxe file and changed the Ip so good there…when I boot client it sees correct IP for Webserver and TFTP Server now but i get the error above about NO SUCH FILE OR DIRECTORY


  • Developer

    @butch2861 Did you to a fresh install of FOG? I kind of doubt it. The file service/ipxe/boot.php missing sounds to me like… well incomplete install.

    Is the IP in that URL correct? I mean is this your FOG server IP? Can you open that URL in your browser?



  • @Sebastian-Roth this is resolved…error I am getting now is No Such File or Directory as seen in other post below…Any ideas?


  • Developer

    @butch2861 said:

    System Ran out of disk space during copy process

    Well then free up enough disk space, clean it all up and do a fresh install of FOG altogether.



  • @Tom-Elliott http://10.0.10.247/service/ipxe/boot.php…No Such File or Directory (http://ipxe.org/2d0c613b) Could Not Boot: Chainloading failed



  • Also wanted to say that FOG 1.3.4 installs fine on Ubuntu 16.04, I test linux distributions and fog versions and report on them here: https://forums.fogproject.org/topic/8730/fog-installer-distro-check

    As Tom said below, if you run the installer as ./installfog.sh -y it wouldn’t even ask you, it would just take care of everything.



  • System Ran out of disk space during copy process…can 't get into system, get error
    Database Schema Installer / Updater
    Your database connection appears to be invalid. FOG is unable to communicate with the database. There are many reasons why this could be the case. Please check your credentials in /var/www/fog/lib/fog/config.class.php. Also confirm that the database is indeed running. If credentials are correct, and if the Database service is running, check to ensure your filesystem has enough space.


  • Senior Developer

    Please try these steps (anybody having these similar issues in Ubuntu 16.04)

    git clone https://github.com/fogproject/fogproject.git /root/fogproject_working
    cd fogproject_working
    git pull
    git checkout working-1.3.5
    git pull
    cd bin
    ./installfog.sh [-y] # the -y does not contain [] around it its meant to show optional
    


  • @Tom-Elliott When I did that earlier on the 1st try install I could NOT get to the server via web address, http error 505


  • Senior Developer

    You should be able to just type y though.


  • Senior Developer

    @Tom-Elliott Remember to change the warning message.


 

447
Online

41.9k
Users

12.4k
Topics

116.7k
Posts