Deployement failed on smaller drive (message "Target partition size smaller")



  • Server
    • FOG Version: 1.3.4-RC2 (SVN 6063)
    • OS: Debian 8.5
    Client
    • Service Version: 0.11.8
    • OS: Win10
    Description

    Hi

    I’ve got a “big” problem, I’ve just deployed image on 20 computers, and those who have a smaller drive failed with this message.

    0_1485432153024_fog1.jpg

    0_1485432194764_fog2.jpg

    And after that computer is unusable (Windows broken).

    Image prepared on dell optiplex 3020 with SSD 128GB, deployed successfully on dell latitude 3350 or dell optiplex 3040 (always with SSD 128, but not same reference), and even on a computer with HDD500Gb.
    But on 4 PC with SSD smaller (Kingston v200 or v300 60GB), it fails with same error…
    And I deployed same image 2 weeks ago on these same 4 computers and everything was fine !

    Thanks for help !
    Matthieu


  • Senior Developer

    Maybe somebody out there can make the suggestions?

    I’m going to try detecting smaller size and automatically applying it as a “fixed” partition, but I really need others to help determine if this is the best/safest route?

    I removed the required first partition fixed size due to some potential hdd layouts.



  • @Tom-Elliott YES !!! Thanks Tom
    It seems working, deployement begins after adding “1” in d1.fixed_size_partitions (which was empty).

    And I will remember Georges advice to prepare image on the smaller disk ;)


  • Senior Developer

    For these really snall drives, I might recommend you edit the d1.fixed_size_partitions file. Add the value:

    1 if it’s blank. or append :1 if there’s already another drive in there.


  • Moderator

    @Matthieu-Jacquart While this no way helps you now. We will typically create our reference image on the smallest size possible disk running on a vm. Our current standard reference image disk is 45GB. That way we are sure it will fit on any computer in our fleet. That standard came from when we ran fog 1.2.0 that didn’t support resizable disks. We just would deploy that image and then use windows to expand the OS disk to the size of the physical disk.

    In your case above I might understand that if your 128 GB disk is not defragmented and compacted in the first 60GB of your 128GB image why FOG can’t resize it. Lets say for example your 128GB disk has data located in the image at the 70GB location (on the physical disk). FOG can’t / doesn’t move data around so that it can shrink the disk.



  • @george1421 Hi,

    On computer with SSD 128 just deployed : 32GB used
    0_1485434257793_fog1.jpg

    On a 60GB SSD computer, deployed few months ago : 35GB used
    0_1485434285694_fog2.jpg


  • Moderator

    On these systems with 128GB hard drive, how much space is consumed by your image (with data not data+freespace)



  • I’ve just test with another image and it’s ok…
    so problem on my image, but I tried an older save (image from november) and same problem, while it works 2 weeks ago… Weird !


Log in to reply
 

381
Online

38918
Users

10688
Topics

101404
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.