"rEFInd - About" instead of booting properly



  • Server
    • FOG Version: 1.3.4-RC-2
    • OS: Debian
    Client
    • Service Version: Unknown
    • OS: OSX (various)
    Description

    Hi everyone! I’m currently using FOG to capture and deploy images, and there’s a tiny detail that keeps bothering me on OSX Client (and it’s not limited to a system version) : on some machines the option “boot from hard disk” just give me the “rEFInd - About” page. Sure, I can just press Enter, then refresh with ESC, and finally choose the right line, but on most of the machines it just boots naturally to the hard disk, and it seems there’s some resistance apparently.

    I have to keep the boot sequence “hands-free” as I’m currently in a formation center, and I don’t want the students to have access to this options. The goal is, at the end, to hide the menu so it’s totally transparent for them (but easier to use for us)

    I use currently the REFIND_EFI exite type on “Exit to Hard Drive Type(EFI)”, any other one just don’t work.

    Does anyone have an idea? Thanks a lot!

    EDIT : updated my current fog version



  • Hi,
    try setting this parameter in /var/www/html/fog/service/ipxe/refind.conf:

    # Delay for the specified number of seconds before scanning disks.
    # This can help some users who find that some of their disks
    # (usually external or optical discs) aren't detected initially,
    # but are detected after pressing Esc.
    # The default is 0.
    #
    scan_delay 5
    

    and, if you need, this:

    # Timeout in seconds for the main menu screen. Setting the timeout to 0
    # disables automatic booting (i.e., no timeout). Setting it to -1 causes
    # an immediate boot to the default OS *UNLESS* a keypress is in the buffer
    # when rEFInd launches, in which case that keypress is interpreted as a
    # shortcut key. If no matching shortcut is found, rEFInd displays its
    # menu with no timeout.
    #
    timeout 5
    


  • @Tom-Elliott Sorry about editing, I just didn’t want to double post :/

    When the setting on “Exit to Hard Drive Type(EFI)” is on “Exit”, booting from hard disk give me a message saying :

    “Chainloading failed, hit ‘s’ for the IPXE Shell : reboot in 10 seconds”

    And it just reboots over and over again…


  • Senior Developer

    @Fabcoo What if you use the “Exit” boot type? Because the system is EFI based, and the ipxe kernel is EFI based, I wonder if just using EXIT would work.

    I might also suggest posting new posts with new findings. I had no idea you had provided updates until I just randomly looked at the posting again. This means, if you edit an already read posting, I won’t know that you added any more information.

    Editing is nice for fixing minor issues and adding some more “relevant” information, but when it comes to providing more data it’s not a good idea as people will not know that there’s new information.



  • @Tom-Elliott I updated it to the 1.3.4-RC-2 tag commit, now I’m moving to the “working-1.3.4” branch, I’ll keep you updated

    EDIT : Just did it, sadly still no changes. Pictures are coming in the next edit

    EDIT 2 : Here’s the required images : http://imgur.com/a/FmpiM


  • Senior Developer

    @Fabcoo What do you mean “a few minutes ago”?

    Can you provide a picture of what you’re seeing? Do you see the changes I just pushed in?

    https://github.com/FOGProject/fogproject/commit/ffdcf326766538d9aed4f878e4962f5e26cfb872



  • @Tom-Elliott Just did it a few minutes ago, and tested on same machines with differents systems (10.9 and 10.10) but still the same bug :/ These are iMac 21.5" mid-2010 (if it can help)


  • Senior Developer

    @Fabcoo Please move into the working-1.3.4 branch and see if this is more suitably setup?



  • Just did it, now on 1.3.4-RC-2, and sadly still the same bug :/ I’m here for any questions you have, hoping to help fixing that bug!


  • Moderator

    Can you move to the latest release, 1.3.3 or if you’re willing the 1.3.4 RC2 version of FOG and see if it’s still an issue there or not?
    Going to ping @Tom-Elliott so he’s aware. Also thanks for posting, reports like this are what makes fog better every day.


Log in to reply
 

385
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.