Adding needed repository.....Failed



  • Server
    • FOG Version: 1.3.0—>1.3.3
    • OS: Ubuntu 16.04.1
    Client
    • Service Version: 0.11.7
    • OS: Windows 7 Ent. 64bit
    Description

    I am trying to upgrade Fog from 1.3.0 to 1.3.3 at one of my buildings but it keeps failing at “Adding needed repositorys…Failed!” The 2 storage nodes at the site upgraded without an issue but the DB fog server just keeps failing. I don’t believe our content filter is the issue because I was able to upgrade my other 6 buildings without problems. It’s the only one giving me an issue. I have tried creating a fresh install but it does the same thing. Is there a way to bypass the repository so it will continue through the setup?

    Thanks,



  • @FlareImp Glad you got it fixed.



  • The issue has been fixed. Our content filter was blocking it. idk how but it was only on that one server. go figure. lol



  • @Wayne-Workman Okay, the Firewall is disabled on the computer so I guess I will need to look elsewhere for the cause. Just not sure where to look.



  • @FlareImp Well there you go. 443 (https) is blocked on that machine, or a proxy or firewall is blocking the entire address or something.

    Just so you know, when I ran the command I gave you on my Ubuntu 16.04 laptop, I got about 5 pages of output, just the source html from the site.



  • @Wayne-Workman said in Adding needed repository.....Failed:

    curl https://launchpad.net/~ondrej

    curl: (7) Failed to connect to launchpad.net port 443: Connection refused
    


  • @FlareImp On your fog server, see what this gives you:

    curl https://launchpad.net/~ondrej



  • @Wayne-Workman said in Adding needed repository.....Failed:

    sudo add-apt-repository ppa:ondrej/php
    sudo apt-get update

    I get this…

    Cannot add PPA: 'ppa:~ondrej/ubuntu/php'.
    ERROR: '~ondrej' user or team does not exist.
    


  • @FlareImp said in Adding needed repository.....Failed:

    Cannot add PPA: ‘ppa:~ondrej/ubuntu/php’.

    Try it manually and then re-run the fog installer:

    sudo add-apt-repository ppa:ondrej/php
    sudo apt-get update
    

    Reference:
    https://launchpad.net/~ondrej/+archive/ubuntu/php



  • @Wayne-Workman This is the only log file I found.

    ntpdate is already the newest version (1:4.2.8p4+dfsg-3ubuntu5.3).
    python-software-properties is already the newest version (0.96.20.5).
    0 upgraded, 0 newly installed, 0 to remove and 42 not upgraded.
    20 Jan 08:56:54 ntpdate[3199]: adjust time server 50.16.201.39 offset -0.029476 sec
    Generating locales (this might take a while)...
      en_US.UTF-8... done
    Generation complete.
    Cannot add PPA: 'ppa:~ondrej/ubuntu/php'.
    ERROR: '~ondrej' user or team does not exist.
    Hit:1 http://us.archive.ubuntu.com/ubuntu xenial InRelease
    Hit:2 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease
    Hit:3 http://security.ubuntu.com/ubuntu xenial-security InRelease
    Hit:4 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease
    Reading package lists...
    Reading package lists...
    Building dependency tree...
    Reading state information...
    ntpdate is already the newest version (1:4.2.8p4+dfsg-3ubuntu5.3).
    software-properties-common is already the newest version (0.96.20.5).
    python-software-properties is already the newest version (0.96.20.5).
    0 upgraded, 0 newly installed, 0 to remove and 42 not upgraded.
    20 Jan 08:57:06 ntpdate[3435]: adjust time server 50.16.201.39 offset -0.013329 sec
    Generating locales (this might take a while)...
      en_US.UTF-8... done
    Generation complete.
    Cannot add PPA: 'ppa:~ondrej/ubuntu/php'.
    ERROR: '~ondrej' user or team does not exist.
    


  • This is probably the remi repo failing to install. If you look where the installfog.sh file is, in there with it will be a directory called error_log and in there some logs with version numbers. You’ll want to locate the logs with 1.3.3 in their name, one is what’s displayed, the other is output from ‘under the hood’, please post that one. Use the code wrapping tool when you do, it looks like this in the post editor on the forums: </>


 

392
Online

41.5k
Users

12.0k
Topics

113.5k
Posts