Upgrade to 1.3.2 or 1.3.3 leads to Communication ERROR 500

  • Server
    • FOG Version: 1.3.2, 1.3.3
    • OS: Ubuntu 14.04
    • Service Version: 11.08
    • OS: Windows 10

    Upgrading from 1.3.0 leads to Communication ERROR 500 on the client while contacting the server. With 1.3.0 (even with client 11.08) everything works fine.

    18.01.2017 08:25 Bus Registering ParseBus in channel Power
    18.01.2017 08:25 Middleware::Communication URL: http://fogserver/fog/management/index.php?sub=requestClientInfo&configure&newService&json
    18.01.2017 08:25 Middleware::Response Success
    18.01.2017 08:25 Middleware::Communication URL: http://fogserver/fog/management/index.php?sub=requestClientInfo&mac=00:19:99:AD:A2:5F||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&newService&json
    18.01.2017 08:25 Middleware::Communication ERROR: Could not contact FOG server
    18.01.2017 08:25 Middleware::Communication ERROR: Der Remoteserver hat einen Fehler zurückgegeben: (500) Interner Serverfehler.
    18.01.2017 08:25 Middleware::Response Success
    18.01.2017 08:25 Middleware::Communication URL: http://fogserver/fog/service/getversion.php?clientver&newService&json
    18.01.2017 08:25 Middleware::Communication URL: http://fogserver/fog/service/getversion.php?newService&json

  • Senior Developer

  • @edv-schuster The new problem is off-topic, please create a new thread with all the details. In the new thread, feel free to link to this one for reference. It’s important to create a new thread because this thread is solved, and therefore will be ignored by some moderators and testers (including myself). I only clicked on this thread because I was curious about how the issue was solved, I normally don’t do that. It’s also important for thread titles to accurately represent what’s in the thread.

  • @Tom-Elliott thanks for the quick 1.3.4-update. we also had duplicate mac-adresses and the server 500-error and our fog-clients stopped working (on 183 machines here…)
    we found a virtualbox-mac and deletet it from the db as you suggested. after the update to 1.3.4 (fogserver reports version “47”), the clients started working again…


    …now we get an error during the network-boot:
    “/fog/service/ipxe/boot.php… input/output error”
    chainloading failed…

    any suggestins?

  • @Tom-Elliott Installing working-brach 1.3.4 fixes the error. There are no more errormessages in the apache error.log, fogclient is working again.

    Thank you, Tom

  • @Tom-Elliott Of course you’re right, i didn’t read the errormessages carefully enough.
    In the apache-log the message changed from

    [Wed Jan 18 22:31:45.800312 2017] [php7:error] [pid 12380] [client] PHP Fatal error:  Uncaught Error: Call to a member function getDispVals() on null in /var/www/fog/lib/client/displaymanager.class.php:32\nStack trace:\n#0 /var/www/fog/lib/fog/fogpage.class.php(2787): DisplayManager->json()\n#1 /var/www/fog/lib/fog/fogpage.class.php(262): FOGPage->requestClientInfo()\n#2 /var/www/fog/lib/fog/processlogin.class.php(57): FOGPage->__construct('')\n#3 [internal function]: ProcessLogin->__construct()\n#4 /var/www/fog/lib/fog/fogbase.class.php(391): ReflectionClass->newInstanceArgs(Array)\n#5 /var/www/fog/management/index.php(29): FOGBase::getClass('ProcessLogin')\n#6 {main}\n  thrown in /var/www/fog/lib/client/displaymanager.class.php on line 32


    [Wed Jan 18 22:48:20.808860 2017] [php7:error] [pid 12381] [client] PHP Fatal error:  Uncaught Error: Call to a member function isValid() on null in /var/www/fog/lib/fog/host.class.php:694\nStack trace:\n#0 /var/www/fog/lib/fog/host.class.php(735): Host->_setDispVals()\n#1 /var/www/fog/lib/client/displaymanager.class.php(35): Host->getDispVals('width')\n#2 /var/www/fog/lib/fog/fogpage.class.php(2787): DisplayManager->json()\n#3 /var/www/fog/lib/fog/fogpage.class.php(262): FOGPage->requestClientInfo()\n#4 /var/www/fog/lib/fog/processlogin.class.php(57): FOGPage->__construct('')\n#5 [internal function]: ProcessLogin->__construct()\n#6 /var/www/fog/lib/fog/fogbase.class.php(391): ReflectionClass->newInstanceArgs(Array)\n#7 /var/www/fog/management/index.php(29): FOGBase::getClass('ProcessLogin')\n#8 {main}\n  thrown in /var/www/fog/lib/fog/host.class.php on line 694

    I’ll install the 1.3.4 branch and report back

  • Senior Developer

    Might I ask you (either of you or both as you see fit) try installing working 1.3.4 branch?

    This can be done with:

    git clone https://github.com/fogproject/fogproject.git
    cd fogproject
    git checkout working-1.3.4
    git pull
    cd bin
    ./installfog.sh -y

    I’ve made a few adjustements in the underlying code base to hopefully see what’s going on. I suspect it’s having something to do with my re-adding the hostregister back into the output. While the basic side of hostregister is working from my perspective, I think it may have been throwing errors back at the client. Rather than have the hostregister function in the returned output, I’ve removed it and am calling it before anything else with no output to send/see/review.

    Hopefully that will fix this error 500 and is really only a guessing game from my perspective at this point.

  • Senior Developer

    @michael_f The error messages might still remain, but the functionality should come back. Of course this is only good if it’s on the server that the client is requesting data from. Essentially, what you’re stating is impossible if you run the wget fix suggested. This is because before the calls, I’m testing the existence of the host object it’s complaining about.

    So it should, at the least, report a new error, but no it will not remove the originating errors from the logs.

  • @michael_f In this thread @tmldale found that disabling the displaymanager gets the client working again, which i can confirm.

  • @Tom-Elliott Unfortunately this doesn’t fix the problem. Error-messages in both log-files remain the same.

  • Senior Developer

    Based on the error messages:

    PHP Fatal error:  Uncaught Error: Call to a member function getDispVals() on null in /var/www/fog/lib/client/displaymanager.class.php:32

    is the problem.

    The weird things is, the file seems correct and I cannot replicate the problem.

    As a quick fix those running into this issue would you please run:

    wget -O /var/www/fog/lib/client/displaymanager.class.php https://raw.githubusercontent.com/FOGProject/fogproject/b632dd0c4bf03ff9fa16960736e41d25f6f57d90/packages/web/lib/client/displaymanager.class.php

    With any luck at least your clients should start working again.

  • @Tom-Elliott I’ve got the same problem (on ubuntu 14.04 and fog 1.3.3)

    Here is the fog.log 0_1484747088387_fog.log

    And error.log 0_1484747149856_error.log

  • Senior Developer

    Can you post the whole fog.log?

    Can you also try getting the error again and posting the apache error log? For ubuntu this is typically found in /var/log/apache2/error.log

  • What happen if you opoen the url juste above ? Same error ? And if you just open this url : http://fogserver/fog/management/index.php?sub=requestClientInfo ?

Log in to reply