Installing now everything is updated ........Failed



  • Server
    • FOG Version: first install
    • OS: Ubuntu 16.04
    Client
    • Service Version:
    • OS:
    Description :

    hello,
    At the end of the installation I have the following message:
    “Installing now everything is updated …Failed”


  • Senior Developer

    I’m solving this thread as 1.3.2 apparently fixed the issues that was seen for this thread to have been started.

    Now I don’t think anything was wrong, but the installation was started with specifying the php version causing the rest of the system to try to use that versioning. This made it try install incompatible packages on 16.04.


  • Moderator

    @sapeurorca what? 1.3.2 was just released, and it IS stable. It’s not a beta and it’s not a release candidate and it’s not a trunk version, it’s a release. The title in the news article says “1.3.2 Officially Released”. I apologize that somehow you misunderstood. If you point out why you thought this, I will correct it so nobody else is confused by whatever it is.



  • Hello, thank you for your help. I just saw that version 1.3.1 was released, so I will pass on this version which installs very well.



  • I’m not at work now, I’m doing it on Monday.
    Thank you
    Just for information, i try install 1.3.1 and install is OK. But I would prefer version 1.3.0 which is stable.


  • Moderator

    @sapeurorca Can you please run the following commands and post their output here

    sudo dpkg --configure -a
    sudo apt-get install -f
    


  • If i run just “./installfog.sh” i have error “Installing now everything is updated …Failed”.


  • Moderator

    @sapeurorca I believe FOG 1.3 doesn’t need that specified for Ubuntu 16.04

    Try just ./installfog.sh



  • No upgrade, it’s a new installation.

    Is it normal that I be forced to run this command “php_ver=‘7.0’ php_verAdds=’-7.0’ ./installfog.sh
    ” for installation ?


  • Senior Developer

    how did you get ubuntu 16.04? did you upgrade from earlier?



  • I went back from a clean install and setup a bit ahead, but every time I came across a new mistake.

    Now I have :

    • Configuring services

    • Setting up fog user…Already setup

    • Setting up fog password…OK

    • Stopping FOGMulticastManager.service Service…OK

    • Stopping FOGImageReplicator.service Service…OK

    • Stopping FOGSnapinReplicator.service Service…OK

    • Stopping FOGScheduler.service Service…OK

    • Stopping FOGPingHosts.service Service…OK

    • Stopping FOGSnapinHash.service Service…OK

    • Setting up and starting MySQL…OK

    • Backing up user reports…Done

    • Stopping web service…Failed!

    Error_log :
    “Failed to stop php\xe2\x80\x987.0\xe2\x80\x99-fpm.service: Unit php\xe2\x80\x98$”

    Do you have an idea, thanks for the help.



  • I advanced, following the php5 error, I run the command “php_ver=‘7.0’ php_verAdds=’-7.0’ ./installfog.sh”.

    Now I have the following error “* Control package: curl … . …Failed!”

    error_log :
    “Des erreurs ont été rencontrées pendant l’exécution :
    /tmp/apt-dpkg-install-YyPQ79/27-linux-firmware_1.161.1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    /tmp/apt-dpkg-install-YyPQ79/27-linux-firmware_1.161.1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    ii apache2 2.4.25-0.0+deb.sury.org~yakkety+1 amd64 Apache HTTP S$
    ii bc 1.06.95-9build2 amd64 GNU bc arbitrary precision calc$
    ii build-essential 12.1ubuntu2 amd64 Informational list of build-essen$
    ii cpp 4:6.1.1-1ubuntu2 amd64 GNU C preprocessor (cpp)”



  • Hello,
    I’m trying to install version 1.3.0. In the file fog_error_1.3.0.log, I have the error (no version of php 5 is available)


  • Moderator

    Need more information. What version of FOG? Please give us the error log too. where the install script is, the error logs are in a directory called error_log.


Log in to reply
 

461
Online

39183
Users

10832
Topics

103076
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.