Image replication bucle



  • Server
    • FOG Version: 1.3.1 RC 5
    • OS: Ubuntu 14.4 LTS
    Client
    • Service Version:
    • OS:
    Description

    Main problem:
    I’ve created now storage, added to my fog server. Now my fog server show his space so I assume that I’ve done it right until now.
    0_1484055631169_upload-721f5b6d-c271-46fd-9829-3e26febcd74a

    but the problem remains when the Main Node want to clonse his images to the “subnode”. It get on bucle and no errors shown.
    0_1484055865452_upload-fa9e05c8-2656-4c5b-91bd-02f096fe8575

    All this info its taken of fogreplicator.log from server.
    EDIT1: If I dont create the image folders MANUALY on the server the message is different, it say “File or Path cannot be reached.” So thats why I created the folders by myself

    Thx for your efforts, this software changed my way to work with 500 computers on my local network and 300 on another networks (that will be next step)


  • Moderator

    In addition to the below answer posted by George, this wiki article will help future readers as well:
    https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_FTP



  • @george1421 said in Image replication bucle:

    Now to the issue. The Master Node (fog server) sends to images to the storage node via the ftp protocol. Ensure you have no firewall between the master node and storage node. (check #1)

    • Firewalls down

    The Master Node logs into the storage node using the linux (fog user and password). Note this is NOT the fog user account related to the WebGUI, but the linux fog user. These account settings should be listed in the storage node settings for the server “storageSub”. Confirm (from the Master Node linux console) you can use the ftp command to connect to the storage node and log in with the user ID and Password defined on the storage node configuration page. (sorry for all the words on this check, I needed to explain what is going on under the hood of the FOG car).

    -After changing the fog password on the “Subnode” fogsettings I can connect using ftp from main server.
    Lets see what happen now :D
    SOLVED now it clone images, this post can be closed.
    Thx @george1421 for your help.
    Next step is using Locate


  • Moderator

    @Malarky Ah ok.

    Now to the issue. The Master Node (fog server) sends to images to the storage node via the ftp protocol. Ensure you have no firewall between the master node and storage node. (check #1)

    The Master Node logs into the storage node using the linux (fog user and password). Note this is NOT the fog user account related to the WebGUI, but the linux fog user. These account settings should be listed in the storage node settings for the server “storageSub”. Confirm (from the Master Node linux console) you can use the ftp command to connect to the storage node and log in with the user ID and Password defined on the storage node configuration page. (sorry for all the words on this check, I needed to explain what is going on under the hood of the FOG car).



  • @george1421 said in Image replication bucle:

    If you install FOG on the second computer as a Storage node configuration, you should not have to manually create the /images directory if the installer script is working as it should. My concern is the installer script not acting as it should.

    Yeah thats right, I’ve made a mistake, I mean that I have the /IMAGES folder created by fog, but INSIDE it, the program dont create the same folders i have on MASTER Node.
    If I dont create those folders my log show this line:
    0_1484063074817_upload-fd14fb59-2b0d-48a3-b889-8a9892743f5c

    On a slightly different topic, now that you have a storage node, you will probably want to install the location plugin so you can tell host computers which FOG server to connect to. (master node or storage node).

    I have it installed and ready for the next step, but if my secondary storage mode dont have the images I cant go forward :)
    Thx for your help @george1421


  • Moderator

    @Malarky Ok then. Are you asking if it is setup correctly? If so then yes it appears so.

    But this statement confuses me.

    EDIT1: If I dont create the image folders MANUALY on the server the message is different, it say “File or Path cannot be reached.” So thats why I created the folders by myself

    If you install FOG on the second computer as a Storage node configuration, you should not have to manually create the /images directory if the installer script is working as it should. My concern is the installer script not acting as it should.

    On a slightly different topic, now that you have a storage node, you will probably want to install the location plugin so you can tell host computers which FOG server to connect to. (master node or storage node).



  • sorry… typing mistake. It is 14.4LTS
    I’ve followed this link
    (https://wiki.fogproject.org/wiki/index.php/Managing_FOG#Adding_a_Storage_Node)
    And created a new storage node on another computer.
    0_1484056571990_upload-c8f8e65b-82d0-4219-80f1-f3a2286099c5
    Node disk utilization:
    0_1484056733989_upload-142d89b2-4539-4bde-aa2d-ed69c6b7e748
    0_1484056742337_upload-91fc51fd-b8f1-4cc7-96e7-ceda474905a6


  • Moderator

    First let me say that ubuntu 10.04 LTS is not currently a supported OS. But with that said, it appears you have fog installed and running.

    When you say you added new storage, what are you referring to? Is that local storage on your fog server, or did you create a fog storage node?


Log in to reply
 

375
Online

38975
Users

10712
Topics

101675
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.