SOLVED NFS volume failed to mount


  • Server
    • FOG Version: 1.3.1
    • OS: Debian Jessy

    Hello Foggers,

    I am sure that I am not the first one that has this problem, but I’m stuck using the conventional methods.

    I have the following setup:

    FOG is installed on SDA, SDB (which is a ext4 partition) is mounted to /images
    I chmod’ded the /images folder, and did chown fog.root as well.
    The same applies to the /images/dev

    I touched the .mntcheck in both folders; but still receive an error while partclone is loading,.

    The error I receive is:

    Checking Mounted File System…
    #######################
    an error has been detected!
    #######################

    Fatal Error: Failed to mount NFS Volume

    • If you believe the filesystem is mounted, make sure you have a file called .mntcheck
      in the directory you are mounting on the server

    #################
    Computer will reboot


  • @Tom-Elliott Thanks Tom for the quick help;
    For the others in this topic: Thanks as well,
    The issue has been resolved. Apparently there was a misconfiguration ‘somewhere’ in the server setup.
    I installed FOG 1.2.0 and immediately upgraded to 1.3.1, then configured the SDB harddisk and the images (which were copied from another server), chown-ed and grpch-ed the folders, reconfigured the node and MySQL …

    somewhere some setting went wrong;

    I’ve reinstalled the server and started from scratch with Fog 1.3.1, now everything works as intended.


  • @Wayne-Workman I will. I did not pay much attention to it because I assumed that I installed 1.3… but during our Q&A, i slowly realized that there might be an issue with my initial install, especially when I noticed that the FOG client that loaded was 1.2, not 1.3 (but that skips so darn fast that I noticed only after 3 reboots…)


  • @abos_systemax next time please include the bigger story. In this situation, telling us that this was a migration would have caused us to ask different questions.


  • @Tom-Elliott Thanks Tom for the quick help;
    For the others in this topic: Thanks as well,
    The issue has been resolved. Apparently there was a misconfiguration ‘somewhere’ in the server setup.
    I installed FOG 1.2.0 and immediately upgraded to 1.3.1, then configured the SDB harddisk and the images (which were copied from another server), chown-ed and grpch-ed the folders, reconfigured the node and MySQL …

    somewhere some setting went wrong;

    I’ve reinstalled the server and started from scratch with Fog 1.3.1, now everything works as intended.


  • Trying to hit you on chat with more ideas.


  • @abos_systemax To fix, typically I will find out which holds the current (most likely /var/www/html/fog).

    Then I will do:

    sudo rm -rf /var/www/fog
    sudo ln -s /var/www/html/fog /var/www/
    

  • @Tom-Elliott
    they were indeed! I was wondering where that issue arose from


  • @abos_systemax You might need to check the /var/www/fog folder and the /var/www/html/fog folders.

    If my guesses are right, right now they’re both individual folders. This would seem to be the cause of the “I installed 1.3.0 but it still looks like 1.2.0”.


  • @Wayne-Workman
    The reason why I am using another disk is because we want the images and the server to be separated for replication/backup/restore possibilities.
    That is why SDA is only 30GB, and the SDB is 1.2TB

    Right now I am reïnstalling the server to see why my FOG install seems to be weird; the password etc don’t match, and the FOG client appears to be 1.2.0 instead of 1.3.0 (dunno if that is what it should be). Upgrading the Kernel doesn’t work.

    I did first install FOG 1.2.0 by accident; after which I upgraded to 1.3.1, but there might be some configuration issues?

    Will post results asap


  • Also - you’re adding another drive to the system. Why? Is SDA full? If so, this would cause some pretty major weirdness. Check with this command: df -h and look for mount points with 99% or 100% usage.


  • What’s the status of: sudo ufw status


  • @abos_systemax What’s the name of the image you’re trying to deploy? Also, permissions on /images should be 777 recursive for troubleshooting purposes. We first want it working, you can change whatever you want after it’s working.

    You might also try to mount the NFS share manually using debug mode to see what sort of error you get. Instructions on that (and other stuff) are here:
    https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_NFS


  • @Quazz

    root@NLBDGASS-X03:/# ls -lah /images
    total 56K
    drwxr-xr-x 11 fog  root 4.0K Jan  9 13:40 .
    drwxr-xr-x 25 root root 4.0K Jan  8 17:03 ..
    drwxr-xr-x  2 fog  root 4.0K Dec 23 14:08 M900_v1
    drwxrwxrwx  2 fog  root 4.0K Jan  8 16:15 dev
    drwxr-xr-x  2 fog  root  16K Jan  8 15:44 lost+found
    -rwxrwxrwx  1 fog  root    0 Jan  9 09:36 .mntcheck
    drwxr-xr-x  2 fog  root 4.0K Jan  8 16:15 postdownloadscripts
    
    root@NLBDGASS-X03:/# ls -lah /images/dev
    total 8.0K
    drwxrwxrwx  2 fog root 4.0K Jan  8 16:15 .
    drwxr-xr-x 11 fog root 4.0K Jan  9 13:40 ..
    -rwxrwxrwx  1 fog root    0 Jan  9 09:37 .mntcheck
    

    IPTables has been removed (apt-get remove --purge iptables) and the server has been rebooted, but no change

  • Moderator

    @abos_systemax What’s the output of

    ls -lah /images
    ls -lah /images/dev
    

    Also, can you try disabling the firewall? (rather than flush it)


  • @Quazz changing the root path did not solve the issue.

  • Moderator

    @abos_systemax Yes. They have to be in their folders directly under /images (eg /images/W7IMAGE instead of /images/FOGIMAGES/W7IMAGE)


  • that is the case.
    could it be an issue that the images themselves are in /images/FOGImages (which is also configured in the FOG Setup btw)

  • Moderator

    @abos_systemax Ownership should be fog root (fog = user root = group)


  • @Quazz no, is not enabled. iptables have been flushed.

    What is the group that fog belongs to by default that needs ownership of the folder?
    Right now the ownership is: fog.root root

  • Moderator

    @abos_systemax Is SELINUX enabled? How about the firewall?

307
Online

8.7k
Users

15.4k
Topics

144.1k
Posts