UNSOLVED Disappearing hosts from host list

  • @wayne-workman

    I realised that only ip could have been sensitive, so i altered it, rest is unmodified. I am curious if log helps this time (as i mentioned it has now an extra step over normal daily work (mac was changed during selected host was being deployed).

    (as logs cannot be inserted here this long as i have, and uploaded files are only pictures, i send to your email.)

  • @foglalt said in Disappearing hosts from host list:

    here is what happened now:
    task was deploying and DURING that task the host data was updated with new mac address (i am aware that it is not best usage 😄 it was not me)

    No matter how it happened, we can learn from this and possibly improve FOG while doing so.

  • @wayne-workman hehe, sanitize 🙂 i will, well, i already started reading it but work came in the office in waves, so i postponed it to tomorrow. I will send or post it here from work. btw i kept your address from last db transaction we did together.

  • @foglalt You can sanitize the log and post it here, or you could email it to me and I can look over it - PM me for my email address. To reset the ‘trap’, you just need to delete/move/rename the log that appeared. If you choose to sanitize and post here, don’t just wholesale delete stuff. For example, instead of completely removing an address or hostname, replace it with a sanitized one. Use search & replace for this - and ensure the integrity of the log is still valid.

  • here it comes again 😞 now, i have a log file that your script created and i think this is not the usual situation. here is what happened now:

    task was deploying and DURING that task the host data was updated with new mac address (i am aware that it is not best usage 😄 it was not me)

    so i have the log, where to put it? mail maybe? it has many info about our setup, maybe not best to have it on a forum ,) let me know how to share with it with you.

  • Oh, i see. I will inform you if file is appearing.

  • @foglalt said in Disappearing hosts from host list:

    Why post is solved?

    Because we found a solution that fixed the problem earlier, and I marked that post as a solution. Now we are continuing in this same thread because it’s the same problem, trying to find the root cause to this issue. We can ask the @moderators to mark the thread as unsolved I suppose.

  • No, not yet. During weekend we do nothing, and we have a pulsating imaging. As we change pcs we create new imaging waves 😀 trust me, it will happen. (Why post is solved?)

  • @foglalt Do we have the rabbit yet?

  • This post is deleted!

  • And again, impressive response time! Thanks again 🙂 ok, i do preparation and wait fo the rabbit to jump out its nest. If i understand well, if a log appears it found something. Lets wait and hope. i will report back on next hit. (anyway you gave me good ideas on how to do some things for myself as i read through your script, nice work!)

  • @foglalt I put together a script:
    For future readers, this script will be here in the troubleshooting tools:

    It monitors the count of hosts that are missing a primary mac. If the count goes above 0, it gets those host IDs, the last 100 lines of the apache access log, the last 100 lines of the apache error log, and the last 50 entires from FOG’s history table and dumps them to the file /root/troubleshooting.log
    Once that log file is written to, the script will not write anything else.

    Get the script onto your fog server, and then you will need to setup this script to run as a cron task every minute on your FOG Server. There’s lots of tutorials if you google search cron or crontab but generally steps are as follows:

    sudo -i
    crontab -e     # this might ask you if you want to use vim basic or vim tiny, it doesn't matter which.
    # Go into insert mode with:
    # Paste in the below line:
    * * * * * /root/monitor-missing-primary-mac.sh        # Or wherever you put the script.
    # Leave insert mode with the escape key
    # Save and close in vim with

    There are probably better tutorials out there on how to use Vim & create a cron job, but I put together this little Vim tutorial some years ago:

    If you need further instructions/clarification on how to setup the script, just ask. When the file /root/troubleshooting.log appears on your server, just look through it yourself first - remove any sensitive information. Maybe this file will help you figure out the bug yourself even. If not, you can share the file here with us and we can probably get a very good idea on how to reproduce this issue.

  • Ok, just take your time. I am glad that you guys are so responsive in all ways of user interaction! I dont even get the clue about that moron on forum claiming that fogproject is dead… We should thank your work, not complain in such nonsense way.

  • @foglalt Ok, give me a day or two - I’ll put together a monitoring script that will record when the problem occurs - the script will also grab the last 100 lines from apache access logs and error logs - and say the last 50 entries from the history table. That information will have the clues that we can use to find what’s causing this.

  • @wayne-workman i am open for any idea. Issue is same on my end, i can fix it with previous methods you mention.

  • @foglalt Are you sure it’s the same problem? Do the SQL commands I posted fix it still? I have some ideas on how to track down the issue.

  • @Wayne-Workman @Tom-Elliott

    Guys, I know this topic is old, but i dont want to create a new topic as my issue now is the exact same as was in this topic. We here had solution to “fix database” with this issue, and i strongly hoped that the problem is only cos of some twisted database issue somehow, but now i again has it happening.

    ATM, server is current uptodate 1.4.4, server os is debian 9.3, database is practically totally new (i kept only 2-3 image from old installation to make a new and flawless db. And colleagues report that host time-to-time disappeare from database.

    As i has now key to find and eliminate it, i can solve this, but… god, it is so frustrating that i cant see the true reason for such. Issue is still same method as for creation: “dummy host” has mac, it gets deployed. new machine comes in, the original dummy is updated with new mac, deploying again. And on the mac update the host disappears sometimes! (mac is literally overwritten with new, which makes prev mac to be secondary or what? in host/mac pairing i see the new machine has the actual mac in db, but it has no primary mac. And as it has only 1 mac, it is “a host without mac” (as i cannot register a host without a mac, maybe gui wont display such hosts).

    We previously cooperated in this matter, maybe with this post it can be continued towards a solution 🙂 I hope at least.

  • Sorry, i wasnot aware that I didnt press post on my reaction to this topic (pc left on when i went home and family killed memory fagments :D)

    Yes, missing host issue was fixed. After that i could register that host again! THX for cooperation and kind help!

    Anyway can i “mark it solved” somehow?

  • @Foglalt Is the original problem solved though? Were you able to register those disappeared hosts now?

    If you want to dig into the DB issues, that should be another thread.

  • Just for your intention: that strange user and password that was found in our database is even more strange. Those are actually fog users and passwords saved with host data. Fog client was never used in our environment and all (which would require ad passwords maybe).

    Even more, user for ad cannot be saved from host or image gui part. None of my colleagues use any of db manipulating software (actually never ever used for any purpose 🙂 ). This means that those fields are mysteriously got those info!

    This database was created with version 1.2.0, previous db was not used at all only as reference for the new database building (hosts are mass imported from newly created lists coming from other source).

    So, if our database is corrupted somehow, we dont have no clue how it was done.