Deploying too fast?



  • Hello All,

    I’m having a problem with my FOG server. What appears to be happening is the FOG server is pushing the image at speeds that claim 6.75 GiB/min and will get to 1% and the deployment will freeze. I can successfully image computers using the multicast function but I cannot image doing Unicast. I’ve tried this on multiple models of computers - HP Probook 4520, HP DC7800, HP DC7900, as well as different images - all of which have the same results.

    I’m not even sure if the speed is what is causing the problem, it just seems very fast (too fast). I’ve tried swapping different kernals around and none of which have solved the problem.

    I’m using version .32 and I’ve set up multiple fog servers in different districts and never have I seen this issue.

    Any help or guidance would be greatly appreciated.

    Thanks.



  • I tried different kernels but it didn’t work. When booting from liveCD and pulling image from the server via NFS there is a spike of 1 Gbps transfer for like 10 seconds and then 0 after that. I found out that if on a managed switch i set the port through which it is deploying to 100 Mbps instead of AUTO then it goes through without getting stuck. Also, wiki claims that it can be done from a server by “ethtool -s eth0 speed 100 duplex half autoneg off”



  • I decided to try a few different kernels until I found one that worked. I’ve now set up my FOG with a different kernel for each machine type that I have after testing out which works best.



  • In my case whenever I have a problem I try a different Kernel. I was using not the Kernel that came with Fog but the one after it. (just before 3.3.3 (3.2.4). I updated to 3.3.3 and that resolved my issue.



  • Hi,

    Was a solution ever found for this? We have the exact same error (When deploying an image it stops after a few seconds). Sending images from the workstation to the server are fine, as are all other tasks.



  • Thanks Matt for Redirecting us here, The person that started the thread put it in Developers and I didnt realise it wasnt Technical Support (Used the search feature for once).

    Chad, See this Thread: http://fogproject.org/forum/threads/deploy-stops-at-just-over-a-hundred-mb.967/#post-4770
    It has a Video of exactly the issue I am having and what it sounds like Matt and Joseph are having… Except mine doesnt seem like its TOO fast, it just instantly stops for me at 65.20MB. It starts at a Normal Speed for our Network of 1.4GB per Minute then BAM, it stops.

    Also per reading a different thread, I am able to Put that single host into a Group and do a Multicast to it… REALLY strange…

    I am running:
    Distributor ID: Ubuntu
    Description: Ubuntu 11.10
    Release: 11.10
    Codename: oneiric

    Fog .32, and the kernel that came with the .32 Installer.



  • Hmm, I’ll have to take a look. We orinally had our FOG server installed on a standalone 4 GB 2.3 GHZ box with a single 10/100 card installed and it was working fine. I recently got my hands on a pretty hefty server to use instead with quad nics, of which I still am only using 1 nic as I don’t see it making a huge difference by bridging these and using all 4. I’m not too familiar with configuring the switches, but what would be the ideal situation for FOG to work?


  • Moderator

    sounds like you have a conflicting configuration with your original switch. Jumbo Packets, duplex mode, or something wonky?



  • Update
    It would appear that this issue is hit or miss on the same as well as different models of machines. Just now, I was attempting to deploy an image and it’s freezing at 1% still and claiming to be pushing at 7 GiB. I decided to plug the machine into a 10/100 switch and the same image and the machine that I was having problems with is now deploying fine. Is there anyways to throttle the speeds coming from the server?



  • If you have a Windows machine on the network, pull up an explorer window and go to \<ip address of FOG server>\images.
    If you have a Linux machine on the network, pull up a terminal and type…

    sudo mkdir /mnt/images/
    sudo mount -o nolock <ip address of FOG server>:/images /mnt/images
    

    Then just browse to an image file and try to copy it locally.



  • I’m not familiar with manually pulling down an image. Is there a guide to this that I can test this out?



  • What about pulling down one of your images over NFS “normally”? As in mounting the server drive and grabbing a copy of the image from a desktop. How fast does that transfer?

    I’m just trying to narrow this down to specific conditions that could cause this type of issue. If you’re able to upload the image at a more reasonable rate then it’s not all NFS transfers, and if you’re able to grab the image over NFS from something other than the FOG boot image then it’s not the FOG server, which means it’s something to do with the boot image.



  • Steady 650 MiB/Min



  • How fast does the upload transfer?



  • I can upload an image without a problem.



  • Out of curiosity, what happens when you upload a new image?



  • Update
    I’ve also tried reverting back to .29 version of FOG with no luck. It really boggles my mind on how UDPCAST works but NSF doesn’t.


Log in to reply
 

320
Online

38727
Users

10554
Topics

99920
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.