Problem trying to update from 1.2.0 to 1.3.0



    • FOG Version: 1.2.0/ 1.3.0
    • OS: Ubuntu 12.04
      I tried installing the stable update 1.3.0, I had an unable to stop web services error and upon finishing the installing which seemed to fail my apache2 completely quit working, now when trying to roll back to 1.2.0 I cannot get it to install either apache2 fails to start. If i need to provide any logs please let me know where i can easily locate them and i will do my best to provide them as soon as I can. I am not super well versed inside of Linux, more specifically the terminal side, so i may need a bit more direction than others.

    Thank you



  • @RoweAdmin Thanks for the feedback, I’ll get those items changed. I have no idea why I wrote ‘copy’ or wrote the mounting command backwards. Guess I was pretty tired. Never-the-less, thank you for your feedback. It’s very appreciated.



  • @Wayne-Workman

    Some things I found trying to follow the wiki -> at least on a fresh Ubuntu 16.04.1 server.

    Mounting should read: (got error “bash: x.x.x.x:/images/test.txt: No such file or directory”)

    mkdir /new 
    mount x.x.x.x:/images/dev /new
    

    Export DB should read: (kept getting error “mysqldump: unknown option ‘-D’”

    #No password.
    mysqldump -B fog > /new/fogdb.sql
    
    #Password with root user.
    mysqldump -B fog -u root -p > /new/fogdb.sql
    
    #No password, localhost.
    mysqldump -B fog -h localhost > /new/fogdb.sql
    
    #No password, local loopback.
    mysqldump -B fog -h 127.0.0.1 > /new/fogdb.sql
    
    #Password with localhost.
    mysqldump -B fog -h localhost -u root -p > /new/fogdb.sql
    
    #Password with local loopback.
    mysqldump -B fog -h 127.0.0.1 -u root -p > /new/fogdb.sql
    

    Export Images should be: (got error: “no command ‘copy’ found”)

    cp -r /images/* /new
    

    This might help if people are getting similar errors…





  • I did go ahead and do an upgrade in place from 12.04 to 14.04 then to 16.04
    After that i reran the installation for FOG 1.3.0 and SUCCESS!!!
    Thank you so much for the helpful advice from this board. Also wow FOG loads so much faster for me inside the web GUI, its like a whole new program.



  • Just letting people know I edited the below post - and those instructions are only valid for 1.2.0 migration to 1.3.0. If you were migrating 1.3.0 to 1.3.0 there would be one extra step, moving over certificates. Those steps are detailed here, under “Maintain control of hosts when building new server” https://wiki.fogproject.org/wiki/index.php?title=FOG_Client



  • @dbakerwardog The easiest way to do this is actually to build the new one while the old one is still running. So, go build a new Ubuntu 16.04 server, follow these steps to get the latest fog: https://wiki.fogproject.org/wiki/index.php?title=Upgrade_to_trunk

    After you have that done, via terminal, become root with sudo -i and then just do a mysqldump to a file. Like this:
    mysqldump -D fog > fogdb.sql
    That’ll give you a file called fogdb.sql. You can transfer this file to the new server the same way you would transfer the images.
    https://wiki.fogproject.org/wiki/index.php?title=Upgrade_to_trunk

    An example for the db file using the old server to the new server would be:
    scp fogdb.sql root@x.x.x.x:/root/fogdb.sql where x.x.x.x is the new server’s IP you’re sending it to.

    Follow instructions in the link, it’s got examples on how to send all your image files at once.

    On the new server, to import the db file (after you get it there) it’s just this:
    mysql < fogdb.sql

    Then after importing the DB, you’ll need to change spots in the web interface that will have the old fog server’s IP (because you imported the old DB). This is easy, here are all the places:
    https://wiki.fogproject.org/wiki/index.php?title=Change_FOG_Server_IP_Address


  • Moderator

    @Tom-Elliott He seems to be on 12.04, I don’t know if they can still do-release-upgrade.


  • Senior Developer

    @dbakerwardog You can upgrade in place.

    I think ubuntu uses do-release-upgrade

    I would say try that route first.

    If IT is having issues, then do the full backup.



  • What is the easiest way to create a backup of everything FOG essential, hosts, images, groups, if I don’t have access to the web side of FOG since my apache isn’t working? I am in the process of downloading a 16.04 LTS ISO to begin upgrading and want to make sure I don’t lose anything.


  • Moderator

    @Tom-Elliott Got to love how Ubuntu constantly changes their repository layout.



  • I’d even suggest building a new Ubuntu 16.04 server from scratch, then copying things over.

    Debian and CentOS generally have had better luck with FOG, just fyi.


  • Senior Developer

    @dbakerwardog You’re probably going to want to upgrade your version of Ubuntu first.

    I’ve been seeing the versions (currently) below 16 not having the PHP packages available within the ondrej repository.

    Upgrading should be somewhat straightforward though.


 

392
Online

41.5k
Users

12.0k
Topics

113.5k
Posts