Image deployment failed



  • Server
    • FOG Version: fog-1.3.0-RC-36
    • OS: Ubuntu14
    Client
    • Service Version:
    • OS: Win10
    Description

    I have the images captured in my fog server. Now I want to deploy image to the another laptop.

    But unfortunately the process halts at:

    “Checking mounted file system …Failed.
    Error has been detected!
    Could not verify mount point, check if .mntcheck exists (/bin/fog.download) Args Passed:
    Computer will reboot in 1 minute”

    did some checks in the Fog server
    cat /etc/exports
    /images *(ro,sync,no_wdelay,no_subtree_check,insecure_locks,no_root_squash,insecure,fsid=0)
    /images/dev *(rw,async,no_wdelay,no_subtree_check,no_root_squash,insecure,fsid=1)

    I think that looks ok.

    The .mntcheck is there
    -rwxrwxrwx 1 fog root 0 Dec 13 11:09 /images/dev/.mntcheck

    nfsd is also running.
    ps aux |grep nfs
    root 505 0.0 0.0 0 0 ? S< Dec16 0:00 [nfsiod]
    root 1281 0.0 0.0 0 0 ? S< Dec16 0:00 [nfsd4]
    root 1282 0.0 0.0 0 0 ? S< Dec16 0:00 [nfsd4_callbacks]
    root 1296 0.0 0.0 0 0 ? S Dec16 0:00 [nfsd]
    root 1297 0.0 0.0 0 0 ? S Dec16 0:00 [nfsd]
    root 1298 0.0 0.0 0 0 ? S Dec16 0:00 [nfsd]
    root 1299 0.0 0.0 0 0 ? S Dec16 0:00 [nfsd]
    root 1300 0.0 0.0 0 0 ? S Dec16 0:00 [nfsd]
    root 1301 0.0 0.0 0 0 ? S Dec16 0:02 [nfsd]
    root 1302 0.0 0.0 0 0 ? S Dec16 1:55 [nfsd]
    root 1303 0.6 0.0 0 0 ? S Dec16 49:49 [nfsd]

    Fog services are running too…
    root 1365 0.0 0.5 218932 23824 ? S Dec16 0:01 /usr/bin/php -q /opt/fog/service/FOGPingHosts/FOGPingHosts
    root 1391 0.0 0.5 218928 23836 ? S Dec16 0:01 /usr/bin/php -q /opt/fog/service/FOGSnapinReplicator/FOGSnapinReplicator
    root 1422 0.0 0.4 296828 18644 ? S Dec16 0:05 /usr/bin/php -q /opt/fog/service/FOGPingHosts/FOGPingHosts
    root 1427 0.0 0.4 296824 18556 ? S Dec16 0:10 /usr/bin/php -q /opt/fog/service/FOGSnapinReplicator/FOGSnapinReplicator
    root 1501 0.0 0.5 218928 23900 ? S Dec16 0:00 /usr/bin/php -q /opt/fog/service/FOGImageReplicator/FOGImageReplicator
    root 1526 0.0 0.5 218928 24000 ? S Dec16 0:00 /usr/bin/php -q /opt/fog/service/FOGMulticastManager/FOGMulticastManager
    root 1551 0.0 0.5 218928 23944 ? S Dec16 0:00 /usr/bin/php -q /opt/fog/service/FOGTaskScheduler/FOGTaskScheduler
    root 1569 0.0 0.4 296824 18548 ? S Dec16 0:26 /usr/bin/php -q /opt/fog/service/FOGImageReplicator/FOGImageReplicator
    root 1572 0.0 0.4 296824 18624 ? S Dec16 3:42 /usr/bin/php -q /opt/fog/service/FOGMulticastManager/FOGMulticastManager
    root 1576 0.0 0.5 218928 23900 ? S Dec16 0:00 /usr/bin/php -q /opt/fog/service/FOGSnapinHash/FOGSnapinHash
    root 1616 0.0 0.4 296824 19156 ? S Dec16 0:29 /usr/bin/php -q /opt/fog/service/FOGTaskScheduler/FOGTaskScheduler
    root 1686 0.0 0.4 296824 18604 ? S Dec16 0:02 /usr/bin/php -q /opt/fog/service/FOGSnapinHash/FOGSnapinHash

    I saw its here : /images/dev/.mntcheck
    So everything looks ok, where is this .mntcheck supposed to be ?

    As for fog.download
    -rwxr-xr-x 1 root root 13807 Dec 13 13:47 /root/fogproject/src/buildroot/package/fog/scripts/bin/fog.download
    Could someone please tell me what am I missing or how do I correct this issue ?


  • Moderator

    How was that missing??



  • Awesome!
    many thanks again george1421, it worked right away after I put it in :)


  • Moderator

    for a deploy ensure that /images contains the mntcheck file too.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.