UNSOLVED Trying to use fog on pc with 2 nic

  • Server
    • FOG Version: 1.3 RC 14
    • OS: Debian
    • Service Version:
    • OS: Win7

    I have a pc with 2 nic card. when i want to boot on fog it will boot but any attemp at registering the machine or doing a quick image will fail saying its not finding a DHCP address. what can i do to fix this ?

    i can provide picture if needed.

    ps: i tried to play with the cable and the 2 nic and i can register one but its not going to know it on pxe fog until i add the second mac address on the FOG website setting for that pc.

  • This is a known issue. In systems with two NICs, the 1st NIC in iPXE isn’t always the 1st NIC in FOS (fog operating system). This messes with tasking. Also, I’m not entirely sure if both NICs or just the first NIC gets registered.

    A long while back, I suggested that we should loop through all the NICs in FOS and try to get an address on them one at a time, and with each one try to contact the FOG Server from each. Once a NIC is found to be successful, exit the loop and proceed.

  • @george1421
    i tried with 2 cables and 1 in each and changing them mid procedure.

  • Moderator

    @fpsacha Understand I’m not saying there is no problem, just need to rule out the possibilities. Is it safe to say that this second nic interface is not connected to the network at the time of registration?

  • Good call on the manual registration. I will post picture soon.

  • Moderator

    Having a picture would be nice to see the exact spot of the error.

    If you manually register the host (as a test) make sure you define the network adapter mac address the same as the mac address of the booting nic. See if you can capture or deploy based on the manual registration.

    I might also suggest that you update your FOG install, the current rc release is 36.