Attempting to check in................... Failed



  • Server
    • FOG Version: SVN 6047
    • OS: Ubuntu Linux 14.04.5
    Client
    • Service Version: 1.3.0-RC-36
    • OS: Windows 10
    Description

    When trying to deploy an image the it is stuck saying Attempting to check in… Failed
    (in line for X) where X starts at 5 and goes up in increments of 5 looks like seconds cause after 60 its 1:5

    The Apache Log has the lots of lines like this in it.

    [Tue Dec 13 18:28:38.228654 2016] [php7:error] [pid 1533] [client 192.168.19.14:54886] PHP Fatal error: Uncaught Error: Using $this when not in object context in /var/www/html/fog/lib/reg-task/taskingelement.class.php:206\nStack trace:\n#0 /var/www/html/fog/lib/reg-task/taskingelement.class.php(124): TaskingElement::checkStorageNodes(Object(StorageGroup))\n#1 [internal function]: TaskingElement->__construct()\n#2 /var/www/html/fog/lib/fog/fogbase.class.php(391): ReflectionClass->newInstanceArgs(Array)\n#3 /var/www/html/fog/service/Pre_Stage1.php(23): FOGBase::getClass(‘TaskQueue’)\n#4 {main}\n thrown in /var/www/html/fog/lib/reg-task/taskingelement.class.php on line 206



  • @Tom-Elliott Thanks i did svn up and then re-installed and it looks like its all good again :)


  • Senior Developer

    Repushed with fixed file.



  • Thanks, ill give it ago tomorrow ive gone home now :)


  • Senior Developer

    The line you’re seeing the error on please edit and remove the this-> part. It should work. I will fix shortly. Please follow exactly. Line 206 of the taskingelement file


 

510
Online

5.4k
Users

12.6k
Topics

118.7k
Posts