Where are the logs!?!?!



  • I created a unattend.xml using System Image manager and I am having trouble with it and windows 10 Build 1607, after I sysprep and upload and then deploy (which all works fantastic thanks to all the help here) Windows begins to go through the XML file and answers all the setup questions, I then get the annoying popup "Windows has restarted unexpectedly or encountered an unexpected error Windows installation cannot proceed. click okay to reboot…blah blah blah.

    I’ve searched the internet up and down and everyone just say use the registry editor to set the child completion status to 3 or something like that (I don’t remember exactly) and it will get passed it. although I don’t want to do that because its going to happen on every machine and I don’t want to touch every machine.

    I should add that I have checked the Setuperr.log and the setupact.log in C:\Windows\Panther (both are blank) and just about every other log in that folder and got nothing.

    Maybe one of you guys that are super good with the answer files could look at it or something see if anything pops out? I am going on round 3 and its very time consuming.


  • Moderator

    @Quazz said in Where are the logs!?!?!:

    From what I can tell, this answer file has some issues, but I’m far from an expert on them.

    I’m not an expert either. I thought these files were being generated by some helper program that you can run to set everything the way you want? Please do not tell me everyone has to manually make these things.



  • @Arsenal101
    You may have to add it to the <settings pass=“oobeSystem”>. At least I found my old script and had it there. the <autologon> section was just under where your <timezone> section is.



  • Excuse the formatting, I have this section in the XML it has worked in the passed, maybe it rebooted twice and I didnt catch it, maybe it was on the third reboot and set not to auto login.

    <AutoLogon>
    <Password>
    <Value>MAA4ADAAOQBwAHcANABzAHIAcwBkACEAUABhAHMAcwB3AG8AcgBkAA==</Value>
    <PlainText>false</PlainText>
    </Password>
    <Enabled>true</Enabled>
    <LogonCount>2</LogonCount>
    <Username>Administrator</Username>
    </AutoLogon>

    Not a big deal.


  • Senior Developer

    @Arsenal101 There’s a setting to have it autologin multiple times within the answer file. I don’t remember what the setting is, I just know that it is there.



  • Good News,

    It looks like clearing out the WinPE section of the answer file allowed it to pass! I just have to figure out the copy profile thing and the autologin, It auto logged in once but that was it. as well as leaving the defaultprofile0 on the machine… but I think i can get that.



  • @Quazz, I see what your saying, although I believe that the username is defined under the auto logon, at least that’t what I gathered watching you-tube. Almost as if you define a password for the default admin account it will be enabled by sysprep? What has worked in the passed for us is have the auto login information in there so the default admin account Logs in twice in order to get fog to rename and reboot.
    I removed the entire WinPE section and we’ll see if that helps.

    @KnightRaven We had a huge problem with AVG in years past with that exact type of thing but we found that if you turn off AVG self protection it will work. We are using the same version as years passed as well so I think I can safely rule that out.
    as far as the copy profile thing I am using the system audit mode which I think uses the Administrator profile and copies it to the default user profile when sysprep runs. There are no other profiles on the computer.

    Removing the WinPE section removes the drive setup, so I am going to give it another shot and see how hit goes! wish me luck



  • Just thought I’d add my $0.02 worth. I may not be a pro at answer files but can relay my experiances. First I hate them. But are a neccesary evil at times it seems. I hate that MS essentialy bricks your image for seemingly minor errors or such. With tjhat said…

    My experiances have been that it usually is a service. Usually an Antivirus that isnt turned off or uninstalled properly. In our case it has been when I forget to remove Avast.
    Also have issues on occasion with CopyProfile. It seems to get confused easy. If you have used another account(a generic perhaps) to setup general settings it may be getting hung on which account to use as the default profile.
    I havent tried to use the Drive setup so I don’t know if there is anything there causing an issue.

    I would agree that the CPI location is not the issue. In my file it usually points or did to a jump/USB drive location that doesn’t exist during imaging.


  • Moderator

    @Arsenal101 From what I can tell, this answer file has some issues, but I’m far from an expert on them. I believe you’re trying to make certain actions take place in a phase that has already taken place before you captured the image.

    I don’t know if windows likes that (I somehow doubt it). The entire Windows PE section is not relevant for deployments as that part happened before sysprep and all that already.

    Also, you seem to be adding an administrator password to an account without specifying the account name. (not sure the built-in administrator account is a good idea for this, by the way, since it will be disabled by default)



  • Okay, good enough for me!


  • Moderator

    @Arsenal101 It won’t, I have my wim files on a mapped network drives that clients won’t have on first boot and it worked fine. It’s only needed for Windows System Image manager



  • Unless it was included in the Image in a folder on the C: drive or something. I could try to upload without deleting it and see if that helps


  • Moderator

    @Arsenal101 I don’t believe so, I think that’s only use when you want to edit the file so it knows which Windows version it’s being provisioned for. The target device will have no use for it because you can’t expect the file to be there anyway.



  • Ohhhh I hate how that happens? Think it might be the CPI Source WIM pointing to a file I deleted? haha not sure how important that is.




  • Moderator

    @Arsenal101 Attached file will be better to prevent formatting from breaking it accidentally.



  • You are very right @Quazz I have had AVG cause that problem as well, I remember being able to find a log back when that happened though, in my case you have to disable AVG self protection in order for it to go through the setup.

    Would you prefer I attach as text or as an attached file?


  • Moderator

    You could post your answer file here, if you like. I personally prefer not to use it to prefer its headaches, but that’s obviously not possible for every environment.

    Do note, that the error you mentioned is not necessarily caused by the answer file (though it can), but can also be caused by incorrect drivers or certain anti-virus installations as far as I know.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.