Another "unable to locate image store"



  • Server
    • FOG Version: 1.2.0
    • OS: Debian 8
    Client
    • Service Version: None
    • OS: Windows10
    Description

    Hello

    Sorry for my bad english…
    A another " Unable to locate image store"
    0_1481629368396_unableLocateImageStore.JPG

    to fix it, I have try :

    0_1481628711987_1910.jpg

    0_1481628798811_1911.JPG

    Any suggestion for help me please!

    Merci

    Pico


  • Moderator

    Did FOS in 1.2.0 reboot on error in 1 minute or 2, I thought it was 2?


  • Senior Developer

    I feel I need to add, the messages that are giving the “unable to locate image store” should only occur when you are deploying / downloading an image to a client machine. Based on your stating you need to upload an image, what are the steps you’re going through? It would seem, to me, that you haven’t uploaded an image yet and you’re receiving this message simply because there is no image uploaded.

    That, or, you uploaded an image but it didn’t completely properly. While the tasking was cleared up the image is still present in /images/dev/<macofhostthatuploadedimage> rather than /images/<nameoftheimage>


  • Moderator

    Your resize test failed because you tried to make the partition smaller than the data was occupying. Therefore, this tells us nothing meaningful related to the image store.

    Most likely there’s a problem with your storage node setup, /etc/exports file(doubt this one since it seems to mount it in your test), SELINUX or firewall, in that order.


  • Moderator

    @pico Please help me understand.

    You can not upload or download images is that correct?

    If that is yes, please execute this command from the fog console showmount -e 127.0.0.1
    That should list the exported nfs shares on your fog server.

    I don’t remember FOG 1.2.0 anymore but you need to make sure your storage node settings point to the proper nfs share locaiton. FOG uses nfs to capture and deploy images and then ftp to move images from /images/dev/<mac_address> to /images/<image_name>


  • Senior Developer

    @pico I fail to understand the problem.

    An upload does not have “an image store” so I don’t understand what you mean by just "upload" a image it's impossible ...

    The pictures you posted don’t show any amount of information that could help us help you either.

    Maybe you can try updated to one of the RC versions of fog and get better results?



  • it’s a “another” because i have try 3 install of FOG and i have again this ****** message :

    memtest&co work fine … just “upload” a image it’s impossible …

    I’m lost please help me to solve my problèm


  • Senior Developer

    I don’t know how this is “another unable to locate image store”. This is not a common thing people are reporting.

    Typically, you will see this if the files that “make up the image” are missing though. As the “store” is no longer available.


Log in to reply
 

499
Online

38924
Users

10691
Topics

101425
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.