Cannot change language of management webpage



  • Server
    • FOG Version: 1.3.0-RC30
    • OS: Ubuntu 16.04
    Client
    • Service Version:
    • OS:
    Description

    I cannot change language of management webpage. I set the language in Fog Settings => General settings, and also selected in login page, but the language is still English. I tried all languages.



  • Hi, I can’t help you, I’m French but I’m prefer to stay with english language
    I tried to choose French on mamagement login page and in fog settings - General settings change FOG_DEFAULT_LOCALE with French also, but any change on display language.


  • Moderator

    I don’t know, I’ve never had to use the language stuff in FOG. Therefore, I’m going to ping folks that maybe have experience with this.

    @Quazz
    @x23piracy
    @Matthieu-Jacquart
    @Sebastian-Roth
    @ch3i



  • I typed YES during the installation process. Any other place I shall change or check?


  • Moderator

    @Maorui2k After you change that setting inside of the .fogsettings file, I think that you need to re-run the fog installer for the setting to be applied. This is how most things in the .fogsettings file are.



  • I selected to install additional languages in the installer.

    root@relay:~/soft/trunk# cat /opt/fog/.fogsettings 
    ## Start of FOG Settings
    ## Created by the FOG Installer
    ## Version: 1.3.0-RC-30
    ## Install time: Tue 13 Dec 2016 12:19:31 PM CST
    ipaddress='192.168.1.2'
    copybackold='0'
    interface='enp2s0'
    submask='255.255.255.0'
    routeraddress='192.168.1.1'
    plainrouter='192.168.1.1'
    dnsaddress='10.1.0.11'
    username='fog'
    password='JzkoKr315dp35IWgR8Lcw9Ua2rp1NcT1unM9zU+d1ZI='
    osid='2'
    osname='Debian'
    dodhcp='y'
    bldhcp='1'
    dhcpd='isc-dhcp-server'
    blexports='1'
    installtype='N'
    snmysqluser='root'
    snmysqlpass=''
    snmysqlhost='localhost'
    installlang='1'
    donate='0'
    storageLocation='/images'
    fogupdateloaded=1
    docroot='/var/www/'
    webroot='/fog/'
    caCreated='yes'
    startrange='192.168.1.10'
    endrange='192.168.1.254'
    bootfilename='undionly.kpxe'
    packages='apache2 bc build-essential cpp curl g++ gawk gcc gettext gzip htmldoc isc-dhcp-server lftp libapache2-mod-php7.1 libc6 libcurl3 m4 mysql-client mysql-server net-tools nfs-kernel-server openssh-server php7.1 php7.1-bcmath php7.1-cli php7.1-curl php7.1-fpm php7.1-gd php7.1-json php7.1-ldap php7.1-mbstring php7.1-mcrypt php7.1-mysql php-gettext sysv-rc-conf tar tftpd-hpa tftp-hpa vsftpd wget xinetd zlib1g '
    noTftpBuild=''
    notpxedefaultfile=''
    sslpath='/opt/fog/snapins/ssl/'
    backupPath='/home/'
    php_ver='7.1'
    php_verAdds='-7.1'
    sslprivkey='/opt/fog/snapins/ssl//.srvprivate.key'
    ## End of FOG Settings
    

    And I can see .mo files.

    root@relay:~/soft/trunk# ls -R /var/www/html/fog/management/languages/
    /var/www/html/fog/management/languages/:
    de_DE.UTF-8  en_US.UTF-8  es_ES.UTF-8  fr_FR.UTF-8  inputfiles  it_IT.UTF-8  messages.pot  pt_BR.UTF-8  zh_CN.UTF-8
    
    /var/www/html/fog/management/languages/de_DE.UTF-8:
    gpl-3.0.txt  LC_MESSAGES
    
    /var/www/html/fog/management/languages/de_DE.UTF-8/LC_MESSAGES:
    messages.mo  messages.po
    
    /var/www/html/fog/management/languages/en_US.UTF-8:
    gpl-3.0.txt  LC_MESSAGES
    
    /var/www/html/fog/management/languages/en_US.UTF-8/LC_MESSAGES:
    messages.mo  messages.po
    
    /var/www/html/fog/management/languages/es_ES.UTF-8:
    gpl-3.0.txt  LC_MESSAGES
    
    /var/www/html/fog/management/languages/es_ES.UTF-8/LC_MESSAGES:
    messages.mo  messages.po
    
    /var/www/html/fog/management/languages/fr_FR.UTF-8:
    gpl-3.0.txt  LC_MESSAGES
    
    /var/www/html/fog/management/languages/fr_FR.UTF-8/LC_MESSAGES:
    messages.mo  messages.po
    
    /var/www/html/fog/management/languages/it_IT.UTF-8:
    gpl-3.0.txt  LC_MESSAGES
    
    /var/www/html/fog/management/languages/it_IT.UTF-8/LC_MESSAGES:
    messages.mo  messages.po
    
    /var/www/html/fog/management/languages/pt_BR.UTF-8:
    LC_MESSAGES
    
    /var/www/html/fog/management/languages/pt_BR.UTF-8/LC_MESSAGES:
    messages.mo  messages.po
    
    /var/www/html/fog/management/languages/zh_CN.UTF-8:
    gpl-3.0.txt  LC_MESSAGES
    
    /var/www/html/fog/management/languages/zh_CN.UTF-8/LC_MESSAGES:
    messages.mo  messages.po
    

  • Senior Developer

    You need to tell the FOG system to build the .mo files.

    This is done by setting the installlang=0 to installlang=1 within the /opt/fog/.fogsettings file.


Log in to reply
 

438
Online

38955
Users

10706
Topics

101580
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.