Windows laptop unable to boot into Fog menu

  • Hi george1421,

    Unfortunately no, I don’t see any of those in the pcap. The results I’ve pasted earlier is the full pcap. Does it mean the fog server isn’t talking to the dhcp server ?
    I’ve verified the fog server , client and dhcp server are on the same network.

  • Moderator

    @froydo (it would help if I could see the pcap, but 5 packets should be sufficient).

    In the pcap you should see
    Client: Discover->
    DHCP Server: Inform->
    Client: Request
    DHCP Server: Ack
    Client: tftp get

  • ok. I upgraded to RC36 now. I tried the tcpdump test again, and this time I got an output.pcap file so I used tcpick to unravel it. Here are the results, but I modified with open inverted commas for just the description :

    Starting tcpick 0.2.1 at 2016-12-13 14:00 EST
    Timeout for connections is 600
    tcpick: reading from output.pcap
    …u…T.u… …()+236:;<BC…9…a…U…H]…4]…^…< PXEClient:Arch:00000:UNDI:002001… …
    .x…T.u…“fog server ip”…undionly.kpxe… …c.Sc5…6.

    …“domain name”…
    undionly.kpxe. VLAN-A=9;…
    .…T.u…pxelinux.0… …c.Sc5…6.
    …“domain name”.
    …u…T.u… …c.Sc5…2.
    ..a… U…H]…4]…^…< PXEClient:Arch:00000:UNDI:002001… …
    .x…T.u…“fog server ip”…undionly.kpxe… …c.Sc5…6.

    …“domain name”…
    undionly.kpxe. VLAN-A=9;…
    …T.u… …c.Sc5…=…T.u…2.
    …!+,./y…“laptop.domainname”<.MSFT 5.07
    .*u…T.u… …c.Sc5…=…T.u…
    “laptop”<.MSFT 5.07…!+,./y…
    tcpick: done reading from output.pcap

    Any ideas ?

  • I ran the tcpdump on my fog server and waited while my laptop was PXE booting but got no results.

    root@fog:/# tcpdump -w output.pcap port 67 or port 68 or port 69 or port 4011
    tcpdump: listening on eth0, link-type EN10MB (Ethernet), capture size 65535 bytes
    ^C5 packets captured
    5 packets received by filter
    0 packets dropped by kernel

    Looks like the fog server didn’t receive anything. Any thoughts ?
    In the meantime as Tom suggested I will upgrade one more time to RC36

  • Senior Developer

    @froydo I just pushed up RC 36 and this should address the error you were seeing with logs not populating (sorry was an oversight in one switch).

  • Moderator

    @froydo is your fog server, target system, and dhcp server on the same subnet? If so lets capture a log of the pxe booting process.

    1. install tcpdump on your fog server.
    2. Launch tcpdump with the following command sudo tcpdump -w output.pcap port 67 or port 68 or port 69 or port 4011
    3. pxe boot your target computer until you get the errir
    4. press ctrl-c on the console to stop the tcpdump program
    5. you can review it with wireshark or post it here and we will review it.

    We really need to see what is going down the network wire during dhcp booting.

  • I’ve just upgraded my Fog server via the Git trunk to 1.3.0RC35 which is the latest and confirmed it is upgraded.

    I then replaced in the “Boot File” box in my Juniper ex330 dhcp server the value of undionly.kpxe

    Also upgraded the Fog client to the latest one in my lenovo laptop, still on the booting off the network, but
    I still get the TFTP timeout and Exiting Intel Boot error messages.

    In the laptop I tried :
    tftp –i x.x.x.x get pxelinux.0
    “Connect request failed”

    tftpd service in the fog server is running.

    I see there is now /opt/fog/log but no logs there.
    I noticed there were no Fog service running . Should they be running all the time ?

    Anyway I tried to start a few for e.g.
    PHP Fatal error: Uncaught Error: Class ‘FOGCore’ not found in /opt/fog/service/lib/service_lib.php:25
    Stack trace:
    #0 /opt/fog/service/FOGMulticastManager/FOGMulticastManager(25): require()
    #1 {main}
    thrown in /opt/fog/service/lib/service_lib.php on line 25

    What does that mean ?

    Interestingly when I was browsing for logs on the fog page I noticed my laptop with the correct MAC address in the Reports management under host listing and Inventory. I did a search in host management and found it. There’s a statement saying “Pending Registration created by FOG_CLIENT”. For “Host Bios Exit Type”, I selected SANBOOT and “Host EFI Exit Type” I chose “Refind_EFI” . Are these correct ?

    Once it was on the host list I decided to try anyway to Capture and Force task to start. And immediately I see the Fog message on my laptop asking for restart which is good, so restarted, but now its on perpetual reboot because the tftp failed and exit on intel boot errors and it keeps trying again. Please help .

  • Many thanks for the suggestions george1421 and Wayne, I’ll upgrade to the newer Fog1.3.0RC . Didn’t realise Fog1.2.0 was that old, that probably explains why it doesn’t work with my new lenovo laptop with win10.

  • George is right, use FOG 1.3.0 Release Candidate. And for DHCP option 067, use undionly.kpxe or undionly.kkpxe

    I don’t know why your TFTP service is configured to use the directory /var/lib/tftpboot but thats the wrong directory. FOG puts all of the boot ROMs into /tftpboot If you’re customizing things - this doesn’t help us in helping you - tell us what you’ve customized, what you’ve done, or we are just lost.

  • Moderator

    @froydo bzImage is wrong for the boot file. You need an iPXE kernel to load the FOG Menu. You should have either undionly.kpxe here for bios (legacy) systems or ipxe.efi for uefi systems.

    That aside I would also recommend that you upgrade to the 1.3.0RCx version if you need support for uefi, gpt disks, NVMe disks, Win10 support, and/or new hardware support. FOG 1.2.0 is over 3 years old and doesn’t support the previously mentioned kit.

    <edit> also don’t provide any path inforation for the boot file unless you are using an i386 uefi system. Everything you need is in the root of the /tftpboot directory</edit>

  • Hi george1421,

    My dhcp server is a Juniper ex3300 and under the Boot options, there is the Boot Server , I entered my fog server ip there.
    there is the boot file which I entered “/bzImage”. There’s no next server option anywhere I could see.

  • I also checked and tftp service is running…
    root 8074 0.0 0.0 15128 944 ? Ss 18:30 0:00 /usr/sbin/in.tftpd --listen --user tftp --address [::]:69 --secure /var/lib/tftpboot

    Also the firewall is also disabled.
    but when I tried tftp –i x.x.x.x get pxelinux.0 in the laptop it failed “Connect request failed”

    i found the config file # /etc/default/tftpd-hpa

    I also did a chmod 777 in that /var/lib/tftpboot

    I restarted the tftp service in the fog server, but same problem. I’m wondering what I’m missing ?

  • Moderator

    What precisely do you have set for dhcp options 66 {next-server} and 67 {boot-file}?

  • @Tom-Elliott Thanks for the reply Tom. My laptop was set to boot with Both UEFI and Legacy and the choice was “Legacy First” . Anyway I reconfigured to “legacy only” and I still get the same result - TFTP timeout and Exiting Intel Boot agent. I checked and have none of those services running on my Fog server.

  • Senior Developer

    Based on what I’m seeing,

    Your issue is the systems are trying to boot using UEFI but your boot file is handing out Legacy files. This is just a guess though.

    I don’t know what fog services you’re expecting though.

    1.2.0 had:


    Them not running has no impact on TFTP at all.

Log in to reply