Wrong permissions for NFS Share



  • Server
    • FOG Version: 1.3.0-RC-25
    • OS: Ubuntu 16
    Client
    • Service Version: ??
    • OS: Windows
    Description

    My Storage is an NAS. I want to save the images to “/volume1/images/” on that Server.
    The IP of the Server is 192.168.16.3 and it has NFS enabled.
    The IP of my FOG Server is 192.168.19.6.

    Here is the Error I get:
    0_1479923831475_20161123_185323.jpg

    Here is the Storage Node:
    0_1479923630566_chrome_2016-11-23_18-53-27.png

    Does anybody know whats wrong?
    It says the Permissions are wrong, but which permission? Everyone has read/write on the server NFS Share, and I mounted the Share on /images and /images/dev on my FOG-Server.


  • Moderator

    @Mokomoko I’m free today if you want help. IM me.



  • @Wayne-Workman Sounds very reasonable to me - didn’t work though. Still the same Problem. I wish there was something like “Use NFS” in the Menue of the Storage Node. We’ll probably look for a different solution - we already invested hours of debugging with multiple people.

    Thanks for you help though.


  • Moderator

    @george1421 Assuming its possible to upload to a remote NAS device (as Wayne would indicate). I did have an issue when creating a proof of concept windows storage node with NFS. https://forums.fogproject.org/topic/6941/windows-server-as-fog-storage-node-proof-of-concept-blog

    More precisely this command was used to create the nfs export on the windows server.
    New-NfsShare –Name "images" –Path c:\share\images –Authentication sys -AllowRootAccess $True -EnableUnmappedAccess $True –Permission Readwrite

    I had troubles mapping to the windows box until I added the -AllowRootAccess $True -EnableUnmappedAccess $True I seem to recall something similar when I was playing with a synology NAS as a storage node. You needed the unmapped user enabled as well as the root access. The FOS client executes as root.

    From your fog server you can issue this command to see what’s shared on the NAS box showmount -e <ip_address_of_nas> That should show you the exported shares.


  • Moderator

    @Mokomoko said in Wrong permissions for NFS Share:

    and I mounted the Share on /images and /images/dev on my FOG-Server.

    An imported directory cannot be re-exported in the Linux kernel, it’s not possible. ISCSI devices are different because they are not imported directories but are literally block-level devices being directly accessed across a network.

    You need to un-mount these directories that you have mounted in the FOG Server, and create a new node in the fog web interface for your NAS. Uploads in this particular situation (because you want to just use a NAS) should not pass through the FOG server at all, but should go directly to the NAS during capture.

    On the NAS, you’ll need to setup FTP and a NFS share.

    On the NAS, you need the files /volume1/images/.mntcheck and /volume1/images/dev/.mntcheck. Use the touch command to make them, they are just blank files.

    /volume1/images should be NFS read for everyone and /volume1/images/dev should be NFS write for everyone. Giving full permissions to just the images directory will also work, but anyone could delete all your images this way.

    An FTP account called fog needs made and needs full permission to everything in /volume1/images

    In the FOG Web interface, create a new node, plug in the fog user and it’s FTP password for the credentials, plug in the correct image path and the correct FTP path. Typically those two paths are the same but on some NAS devices they are not. Use the NAS ip address.

    Permissions on the images directory ought to be root:fog and 777.


  • Moderator

    AFAIK you can only upload to the master FOG server. You could use a NAS for a storage node, but not a master node. As for the permission part, your fog server should be setup to share its /images/dev directory already.


Log in to reply
 

371
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.