RC-25 boot error when pxe booting.



  • Server
    • FOG Version: RC-25
    • OS: Fedorea 24
    Client
    • Service Version: 11.5
    • OS: win 7
    Description

    Getting pxe boot error only on vm below is the output from vm.
    0_1479739629627_bootPHPError.docx



  • @Tom-Elliott worked like a charm sir


  • Senior Developer

    Found the originating issue and it has been fixed in the working RC-26 branch.

    If you need the immediate fix please run:

    wget -O /var/www/fog/lib/plugins/location/class/locationassociation.class.php https://raw.githubusercontent.com/FOGProject/fogproject/00c62f9e739bb56d3a084690327740e99a650fa7/packages/web/lib/plugins/location/class/locationassociation.class.php


  • Senior Developer

    @Matthieu-Jacquart said in RC-25 boot error when pxe booting.:

    3:40.97

    Mind adjusting your “FOG_URL_AVAILABLE_TIMEOUT”



  • I think it’s that error for me :

    [Mon Nov 21 16:03:40.978741 2016] [:error] [pid 17935] [client 192.168.8.75:60801] PHP Fatal error:  Uncaught exception 'Exception' with message 'No valid storage nodes found' in /var/www/html/fog/lib/fog/bootmenu.class.php:1427\nStack trace:\n#0 /var/www/html/fog/lib/fog/bootmenu.class.php(425): BootMenu->getTasking()\n#1 [internal function]: BootMenu->__construct(Object(Host))\n#2 /var/www/html/fog/lib/fog/fogbase.class.php(389): ReflectionClass->newInstance(Object(Host))\n#3 /var/www/html/fog/service/ipxe/boot.php(36): FOGBase::getClass('BootMenu', Object(Host))\n#4 {main}\n  thrown in /var/www/html/fog/lib/fog/bootmenu.class.php on line 1427```


  • @Matthieu-Jacquart do you have this in your error logs ?

    [Mon Nov 21 09:57:46.787970 2016] [:error] [pid 11741] [client 10.72.2.25:4168] PHP Fatal error: Uncaught Error: Call to a member function get() on null in /var/www/html/fog/lib/plugins/location/class/locationassociation.class.php:118\nStack trace:\n#0 /var/www/html/fog/lib/plugins/location/hooks/changeitems.hook.php(77): LocationAssociation->isTFTP()\n#1 /var/www/html/fog/lib/fog/hookmanager.class.php(185): ChangeItems->BootItemSettings(Array)\n#2 /var/www/html/fog/lib/fog/bootmenu.class.php(362): HookManager->processEvent('BOOT_ITEM_NEW_S...', Array)\n#3 [internal function]: BootMenu->__construct(Object(Host))\n#4 /var/www/html/fog/lib/fog/fogbase.class.php(389): ReflectionClass->newInstance(Object(Host))\n#5 /var/www/html/fog/service/ipxe/boot.php(36): FOGBase::getClass('BootMenu', Object(Host))\n#6 {main}\n thrown in /var/www/html/fog/lib/plugins/location/class/locationassociation.class.php on line 118
    


  • For me I tried to deploy one image on 15 computers in the same room, and 4 of them gave me this error…
    I restart deployment after the 11 others pc were finished and this time it was ok.



  • @Matthieu-Jacquart upgraded from RC 23-25 myself…I can get an actual machine to image, just not VM



  • I had same error on some pc today, due to RC24 or RC25 update


Log in to reply
 

422
Online

39001
Users

10717
Topics

101762
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.