mounting /home/images on /images failed: permission denied



  • Server
    • FOG Version: 1.2.0
    • OS: Centos 6.8
    Client
    • Service Version:
    • OS: Centos 7.2
    Description

    The default of /images works just fine when I image a machine. However the / partition only has 15 GB of space. The /home partition has over 500GB of space for images. I created a /home/images folder and made it the master node, the only node for holding images. I am getting a permission denied error.

    NFS is mounting 172.16.61.17:/home/images/dev on /images failed: permissioned denied.

    I checked the perms and they appear to be ok at 777 on the /home/images folder recursively.

    Any ideas?

    Just trying to change the default path from /images to /home/images



  • This post is solved


  • Moderator

    @finvader You can leave your /etc/exports to default if you create a symbolic link to your /home/images

    I think I understand that the /home/images should be rw instead of ro?

    No, /home/images/dev should be rw

    I don’t even know how it wrote anything in your /home/images/dev folder if it’s defined as ro in your exports…unless you never exported it and already have a symbolic link that is.

    Assuming all of that is true, then you need to remove the /home/images line from /etc/exports and do what Wayne says.


  • Moderator

    I think you setup /etc/exports properly if you were able to capture. I think you forgot to change the FTP path inside of Storage Management -> node -> FTP Path or Image Path.



  • @Tom-Elliott
    Not sure I understand what you are saying.

    Do I only need the /home/images in my /etc/exports?
    I think I understand that the /home/images should be rw instead of ro?


  • Senior Developer

    @finvader
    The mac address labeled folder is typically ONLY when you’re imaging. ro should actually read rw for the dev line.

    You should not need to have /home/images and /home/images/dev if your /images is a symbolic link to the /home/images point.



  • @Tom-Elliott

    Quick question:

    The FOG server was able to upload (capture) the image successfully, however when I look in /home/images (my new image path), I see the mac address as the image name instead of centos72IT1103, the image name associated with my hosts? The old fog server created the same name folder in /home/images as the image name in “Image Management”.

    V/R



  • Got it, was missing the .mntcheck and dev folder. Not sure why the dev did not get created but just copied over and maintained perms.

    I am IMAGING!!!

    A great learning process for me for sure. Thank you for all the help. Now the lab is up. Back to 1.3.0 on CENTOS 7.2. I think I got it this time around no prob.

    V/R



  • /images *(ro,sync,nowdelay…fsid1)
    /images/dev *(ro,sync,nowdelay…fsid2)

    not seeing /home/images… does it need to be here, if so I believe it would be something like

    /home/images/dev *(ro, sync…fsid3)

    ?


  • Senior Developer

    What does your /etc/exports file look like?


Log in to reply
 

368
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.