Problem while deploying image



  • Server
    • FOG Version: 1.3.0
    • OS: Ubuntu 14.04
    Client
    • Service Version:
    • OS:
    Description

    Have updated from 0.32 to 1.20 in summer. Then recently. I’ve updated again to 1.3.0. installation went fine with no issues. Uploaded the image files (using ftp) to home/fog/images and tried to deploy. Mid-image, I get:

    … volume file
    /stdin.001

    : corrupted – invalid deflate data (invalid block type)
    pigz: bort: internal … s error

    Will upload picture soon.

    Thanks

    EDIT:

    Images worked fine on 1.2.0 with no issues



  • Hi guys,

    First of all, thanks for your support and patience.

    Fortunately, I found what was wrong with the images.

    Unfortunately, I had to put the server down and start a new on a slightly newer server which had been collecting dust.

    The issue here was that the hard drives were failing and a number of sectors were found with errors. The server was from 2006 and I’m pretty sure the hard drives were the same age…

    The image I had was transferred from 0.32, to 1.20 then to 1.30 using part image and moved using FTP. I’ve recaptured the original images using part clone on 1.3.0 with the newer server and decided to start from scratch.

    Thanks again for your help. It’s very much appreciated.


  • Moderator

    What version of fog was used to capture this particular image?

    Also, is the problem with all images, or just this one?

    Please post a photo of the error so we can see the entire monitor and other information it’s displaying.


  • Senior Developer

    Typically, This would indicate a problem with the image. The scripts managing imaging may have changed, but the way the data is stored/used (while a bit of compatibility was needed first) hasn’t changed when it comes to handling deployments.

    Seeing as you stated you uploaded the images how did you go about this? Did they properly upload? If you still have the original, if you do a checksum comparison between the original the uploaded file (on the new server) do they match?

    Where is /stdin.001 coming in? FOG now uses /tmp/pigz1 as the location in memory via a FIFO system to handle the incoming data flow.


Log in to reply
 

397
Online

38744
Users

10565
Topics

100021
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.