Image sharing via Storage Groups - Primary group issue.

  • Server
    • FOG Version: 1.3.0 RC-18
    • OS: CentOS 7

    We use the location plugin.

    For an image that exists on one storage group and you want to share it with another storage group,
    Image Management -> pick image -> Storage Group -> Add Storage Group

    The storage group that originally was assigned does not automatically become primary, so replication doesn’t happen.

    Because replication doesn’t happen, the image doesn’t exist yet on the other storage group. So when someone at the other location tries to image with the image, FOG assigns the image to only the storage group that has a copy of the image, which then of course doesn’t work because it’s not in the right location, and the additional storage group is un-done.

  • @Tom-Elliott Yes solved. We need to make an SQL statement though that will set all images that only have one storage group to make that group primary. Because we have a ton of images that have no primary group but also only have one group.

  • Senior Developer

    I’m thinking this is now safe to solve, can you verify first?

  • Senior Developer

    For what it’s worth, I’m not seeing anything in the code that removes groups unless an action was indeed taken prior. I’m still sifting just in case, just wanted to give a heads up.

    I believe it was fixed here, though:

    I don’t know what I was thinking there. Ultimately, though, it was setting the group to the “lowest ID” stored. That said, this was just a “sanity” setter, and nothing (in regards to imaging) updates the image definition itself (which would in-turn update the storage groups). At least not within RC-19, (I didn’t test against RC-18 sorry).

  • Senior Developer

    Confirmed the schema changes are working as intended, now. (Upgrades will set all images to be primary master automatically).

    Only need help, potentially, with the removing of another group.

  • Senior Developer

    I’ve modified the code so storage groups will be defined as master on new image creation as you can only select one group.

    I’ve also modified the schema so upgrades should have their relevant images auto populated to contain their relevant storage group set as the master group.

    I’m still doing testing to ensure all is well, first, just wanted to give a heads up.

    As for the group being lost from the image, I’m not sure where the issue is occurring currently.

Log in to reply





Looks like your connection to FOG Project was lost, please wait while we try to reconnect.