Upgrade rc13 to rc19



  • Server
    • FOG Version: 1.3.0 RC 19
    • OS:
    Description

    Hello,

    after upgrading from RC13 to RC19, i get this error message when capturing image:

    0_1478081413024_error.jpg

    Do you have an idea? NFS mount seems ok, webgui gives me no errors…pxe boot is ok as well.

    Thank you



  • Ok thank you, everything works perfectly, i dont know why it was not working anymore…


  • Senior Developer

    @raumin You can remove them, but for the MAC address labels those ARE the uploaded files.

    For your particular situation, I’d try running the Post_Stage2.php link I suggested earlier. This should remove the image from the dev folder for that relevant mac address and complete the “process” of the task for you.



  • can i remove manually temp folders in /images/dev?



  • The user ID 500 was on the NAS so i changed on my server the UID of my user fog to 500.
    So now, the UID and GID on the NAS and on my server are the same.

    I retry…


  • Senior Developer

    What might also help is to reset the fog uid on the NAS to match that of the server’s FOG user id (currently 500 on your server).


  • Senior Developer

    @raumin So it looks like the ownership has been changed to that of whatever the FOG uid is On your server, but it’s not owned by the FOG user UID on yoru NAS.

    Can you get the NAS’s representation of the UID? Maybe something like:

    chown -R fog:users /images on the NAS?



  • Oh ok.

    My images are on a NAS (credentials are ok), here the output:

    root@rudolf:/tmp/willy# ls -lhaRrt dev
    dev:
    total 36K
    -rwxrwxrwx+  1 500 root     0 Jan 12  2015 .mntcheck
    drwxrwxrwx+  2 500 users 4.0K Oct 12 10:42 9890969ef3c2
    drwxrwxrwx+ 24 500 users 4.0K Oct 18 14:51 ..
    drwxrwxrwx+  4 500 users 4.0K Nov  2 10:18 .
    drwxrwxrwx+  2 500 users 4.0K Nov  2 13:57 9890969fa527
    
    dev/9890969ef3c2:
    total 44K
    -rwxrwxrwx+ 1 500 users    3 Oct 12 10:42 d1.fixed_size_partitions
    -rwxrwxrwx+ 1 500 users  190 Oct 12 10:42 d1.partitions
    -rwxrwxrwx+ 1 500 users    0 Oct 12 10:42 d1.original.swapuuids
    drwxrwxrwx+ 2 500 users 4.0K Oct 12 10:42 .
    -rwxrwxrwx+ 1 500 users   15 Oct 12 10:42 d1.original.fstypes
    drwxrwxrwx+ 4 500 users 4.0K Nov  2 10:18 ..
    
    dev/9890969fa527:
    total 7.0G
    drwxrwxrwx+ 4 500 users 4.0K Nov  2 10:18 ..
    -rwxrwxrwx+ 1 500 users    3 Nov  2 13:43 d1.fixed_size_partitions
    -rwxrwxrwx+ 1 500 users  190 Nov  2 13:43 d1.partitions
    -rwxrwxrwx+ 1 500 users    0 Nov  2 13:43 d1.original.swapuuids
    -rwxrwxrwx+ 1 500 users   15 Nov  2 13:43 d1.original.fstypes
    -rwxrwxrwx+ 1 500 users 1.0M Nov  2 13:43 d1.mbr
    -rwxrwxrwx+ 1 500 users  190 Nov  2 13:43 d1.minimum.partitions
    -rwxrwxrwx+ 1 500 users 305M Nov  2 13:43 d1p1.img
    -rwxrwxrwx+ 1 500 users 6.7G Nov  2 13:57 d1p2.img
    drwxrwxrwx+ 2 500 users 4.0K Nov  2 13:57 .
    

  • Senior Developer

    @raumin Single or double does not matter. Is the username and password correct in the storage node?

    What’s the output of:

    ls -lhaRrt /images/dev


  • Senior Developer

    @raumin The quote is started from with message ‘Type: 2, File… and ends on Username fog’



  • it seems to be an FTP access error…

    in /opt/fog/.fogsettings the password is with single or double quotes ?

    password="my_password"
    

    or

    password='my_password'
    

    I get this error:

    [Wed Nov 02 13:57:26.900128 2016] [:error] [pid 39749] [client 172.20.151.202:55526] PHP Fatal error:  Uncaught exception 'Exception' with message 'Type: 2, File: /var/www/html/fog/lib/fog/fogftp.class.php, Line: 708, Message: ftp_put(images/dev/9890969fa527): failed to open stream: No such file or directory, Host: 172.20.25.204, Username: fog' in /var/www/html/fog/lib/fog/fogftp.class.php:367\nStack trace:\n#0 /var/www/html/fog/lib/fog/fogftp.class.php(772): FOGFTP->ftperror(Array)\n#1 /var/www/html/fog/lib/reg-task/taskqueue.class.php(389): FOGFTP->rename('images/dev/9890...', 'images/CELAB_AV...')\n#2 /var/www/html/fog/lib/reg-task/taskqueue.class.php(435): TaskQueue->_moveUpload()\n#3 /var/www/html/fog/service/Post_Stage2.php(24): TaskQueue->checkout()\n#4 {main}\n  thrown in /var/www/html/fog/lib/fog/fogftp.class.php on line 367
    

    There seems to be a problem with

    Username: fog'
    

    One single quote is missing no ?


  • Senior Developer

    @raumin Not necessarily, but what’s in the /var/log/apache2/error.log or /var/log/httpd/error_log file?



  • No problem with chmod -R 777 but i get white screen when executing your command http://fogserver/fog/service/Post_Stage2.php?mac=xx:xx:xx:xx:xx:xx

    Does it mean it’s ok ?


  • Senior Developer

    @raumin I’m not able to replicate. Can you try:

    chmod -R 777 /images/dev

    Then in the browser run:

    http://fog.mastacontrola.com/fog/service/Post_Stage2.php?mac=xx:xx:xx:xx:xx:xx

    Replacing the “X’s” with that of the mac of the host you’re performing the upload with.



  • Hmm i get another problem after the end of capture.
    0_1478089233126_error-2.jpg



  • Perfect, thank you!

    raumin


  • Senior Developer

    Found and fixed. Please repull and install and you should be fine.


  • Senior Developer

    Based on what I’m seeing, there’s an error somehwere.

    Can you get output of apache error log?


Log in to reply
 

556
Online

39009
Users

10724
Topics

101874
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.