"Backing Up Database ... Failed" when updating FOG 1.3.0 RC



  • Server
    • FOG Version: 1.3.0 RC13
    • OS: Debian 8.6 x64
    • Behind a Proxy (Squid)
    Description

    Hello,

    When i try to update my FOG server RC13 to RC17, i encounter this error :

    Backing up database…Failed!

    I encountered this issue a first time when i tried to update from RC3 to RC13…

    I know there are many topics about this error, but i haven’t find a solution which solve my problem… :(

    For information, when i install FOG, i install first the 1.2.0 version, and after i update to 1.30 RCx version.
    Why ? Because i find 1.2.0 version more “customizable” during installation.
    Perhaps the problem is here … ?

    When i access to http://x.x.x.x/fog/management/export.php?type=sqldump, i have a blank page with “###Invalid Login” …

    If you need more information, i will try to give it to you as faster as possible.

    Regards,

    Xely


  • Senior Developer

    @Quazz If he went to the browser and ran it, invalid login is coming from the fact the browser is failing to see any login information.


  • Moderator

    Can you check your /opt/fog/.fogsettings for

    snmysqluser="{root}"
    snmysqlpass="{PasswordIfYouHaveOne}"
    snmysqlhost="{localhost}"
    

    Given that it says invalid login, I’m guessing the login will be invalid in the fogsettings file.


  • Senior Developer

    @xely Is there anything in the bin/error_logs/fog_error_1.3.0-RC-17.log file?

    Can you post the last 20 lines here?



  • You are fast :o

    I don’t understand very well what you mean… I make a fresh install with FOG 1.3.0 RC-17 ? Because i have this problem when i run the installfog.sh script after updating my FOG install folder with GIT (from RC13 to RC17)


  • Senior Developer

    Can you try updating to RC-17 and see if this still happens? I don’t know if it will or not, but RC-13 had a few issues which I’m pretty sure are addressed in RC-17.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.