Image files not deleting


  • Moderator

    Server
    • FOG Version: 1.3.0 RC-14
    • OS: CentOS 7 fully updated
    Description

    Here’s a copy/paste from an email I just got. This particular person knows very well how to delete images plus image files too via the web GUI.

    please delete the FOG image file for AdminE5470W10E. I checked FOG disk space prior to my “deletion” and afterwards. It did not change. Still at 26%, 131.76 GB available.

    I checked and the image is still on disk. I looked through apache errors and only found this:

    [Wed Oct 19 08:18:33.733000 2016] [:error] [pid 2445] [client 10.12.8.52:49622] PHP Warning: Unknown: FTP server error 426:426 Failure writing network stream.\r\n in Unknown on line 0
    

    But that error is dated from 2.5 hours earlier than when I received the email - so I’m not sure if that’s even relevant - still looks like a bad error though.

    Not sure if it’s related but, on a storage node connected to the main server, I found these apache errors, 10.51.1.53 is the main fog server. The getfiles.php error is spamming the log. I think this is related to snapins and the location plugin and some snapins not being available for this location. Not entirely sure.

    [Wed Oct 19 11:00:27.795245 2016] [:error] [pid 13902] [client 10.51.1.53:32924] client denied by server configuration: /var/www/html/fog/status/getfiles.php
    [Wed Oct 19 11:00:27.743790 2016] [:error] [pid 13899] [client 10.51.1.53:32920] client denied by server configuration: /var/www/html/fog/status/getfiles.php
    [Tue Oct 18 11:12:52.398879 2016] [:error] [pid 13901] [client 10.36.14.8:59190] PHP Warning: fopen(ftp://...@10.65.2.20/opt/fog/snapins/DameWare-Update-MSI.MSI): failed to open stream: FTP server reports 550 Could not get file size.\r\n in /var/www/html/fog/lib/client/snapinclient.class.php on line 662
    [Tue Oct 18 10:03:00.935528 2016] [core:notice] [pid 13891] AH00094: Com
    

    It would appear that is the only storage node with those sorts of errors, I checked a few others and they were fine.


  • Senior Developer

    @Wayne-Workman Yep, and this is also fixed. The files and folders remaining was from order of it doing things. Once it caught a directory of either . or .. it returned without finishing.


  • Moderator

    @Tom-Elliott but my issue was different, in my case the folder and files remained.


  • Senior Developer

    Confirmed the issue and hopefully have it fully addressed now.

    It was a bit of an issue, but ultimately very simple. The files were deleting at least on one node (where possible) but failing to iterate due to return which was meant to be changed to a continue.

    After finding that out, the issue was the folder for images would still exist (the data would be removed though).

    After some fairly thorough testing (I tested what I could, when and where possible) it appears I’ve finally addressed the problem. Trailing folders get removed as well as the contents of those folders.

    I’m solving this, and the other, for now. Feel free to keep us posted though.


  • Moderator

    I’m currently running a test now with an image that is shared with the node that had mod_evasive, and I’m seeing if it will delete now or not.


  • Moderator

    @Tom-Elliott said in Image files not deleting:

    mod_evasive

    It’s not installed:

    [root@acfog ~]# yum remove mod_evasive
    Loaded plugins: fastestmirror
    No Match for argument: mod_evasive
    No Packages marked for removal
    [root@acfog ~]#
    

    However it was installed on the node with the “client denied” errors. I’ve removed it.


  • Senior Developer

    @Wayne-Workman If the FTP delete is erroring or the page is returning due to mod_evasive, then it’s exiting because it’s done doing the work it can do. That’s it.


  • Moderator

    More information from the user via email:

    Just so you know, when I attempt the deletion of the FOG image, I get a screen to authenticate. After I authenticate, I can see another screen pop up where I could select DELETE or CANCEL, but it disappears so fast that I cannot ever click on DELETE.
    Perhaps the programming error is with that second screen that disappears too quickly?


  • Moderator

    @Tom-Elliott We’ve only been on RC-14 for a couple days, only one image has been attempted to be deleted so far. None of the image’s files were deleted at all. This particular image isn’t present on other storage nodes, it was only present on the main server.


  • Senior Developer

    Does it not remove ANY image data on ANY node or it never deletes any files?



  • I too had the same issue. Deleted all images but hdd or node spce was not reclaimed. I even went to /images and deleted the files and didnt reclaim space. Since this is a dev server im testing i ended up formatting the partition where image folder was mounted. I have the same setup as you. Keep me posted and ill try to recreate this tomorrow.


  • Senior Developer

    @Wayne-Workman Client denied usually is becuase of mod evasive.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.