SOLVED Want to skip "Booting... (Press Escape to access the menu)"

  • Server
    • FOG Version: 1.3.0-RC14
    • OS: Ubuntu 14.04
    • Service Version: NA
    • OS: Windows 7

    Setting up a new FOG server (trunk 1.3.0-RC14) to replace current FOG server (1.0.1).

    PXE boot is working ok, EXCEPT after it shows:… ok”

    It then shows:
    “Booting… (Press Escape to access the menu)”

    It hangs on that line until I press ‘ESC’ or ‘ENTER’

    • ESC asks for FOG LOGIN/PASSWORD then will enter the PXE menu with the Boot countdown, quick host register, etc.
    • ENTER boots right to Windows.

    I would like skip the “Booting… (Press Escape to access the menu)” line and have it go directly to the Menu without a login/password requirement.


    1. Editing FOG SETTINGS>FOG Boot Settings with both FOG_PXE_MENU_HIDDEN and/or FOG_NO_MENU
    2. Importing hosts (didn’t work yet).
    3. Registering a host to see if unregistered host was causing the hang. This worked for “FOG_NO_MENU” but I would like to not worry about host registration until I image the labs again in December.
    4. Unregistered hosts sit at “Booting…” even with “FOG_NO_MENU” selected.

    What to edit and where to at least turn off the login/password requirement for getting the PXE menu, so it boots like the older versions did (with background.png) and no keystrokes required to boot to Windows.

    Thanks for your help!

  • @FlareImp Because you did a “fresh” install from RC-14, moving to 15 would not fix the issue.

    You would need to run:

    mysql -u root
    drop database fog;

    Re-run the installer.

    If you have hosts, images, etc… make a backup of these definitions as you will be starting from scratch essentially.

  • Moderator

    @FlareImp Sorry for giving you an incomplete answer before. I thought you revered and installed 1.2.0 which would upgrade to RC15 without issue. There would be no need to drop the database in this case.

    I’m glad you have it all sorted out. The 1.3.0RC series is so much better than 1.2.0. You will be glad you are on this release.

  • @Tom-Elliott said in Want to skip "Booting... (Press Escape to access the menu)":

    mysql -u root
    drop database fog;

    All fixed, Thanks so much!

  • @Tom-Elliott Awesome response time! I’ll give that a try now, thank you!

  • @FlareImp Because you did a “fresh” install from RC-14, moving to 15 would not fix the issue.

    You would need to run:

    mysql -u root
    drop database fog;

    Re-run the installer.

    If you have hosts, images, etc… make a backup of these definitions as you will be starting from scratch essentially.

  • @george1421 I just did an upgrade from a fresh install of RC-14 to RC-15 and I am still seeing this issue. I have tried turning “No Menu” on, same issue. I have tried all the different boot options under PXE Menu, same issue. The only workaround that works for me is setting the PXE Menu to “Hide” and then it blinks past the screen and boots the hard drive. I did not see this happening in RC-13, it started for me when I upgraded to RC-14, and doing a fresh install of RC-14. I just upgraded to RC-15 from RC-14 hoping it would fix it after reading your post. Mine does this for both registered and unregistered hosts, any recommendations?

    Ubuntu 16.04
    Fog Running Version 1.3.0-RC-15 upgraded from a fresh install of RC-14

  • Moderator

    The developers have confirmed this is “an issue” with RC14 and a new install. When both conditions are met the database is not created properly. While I understand you have committed to 1.2.0 (actually if you upgrade from 1.2.0 to RC14 the upgrade would have worked correctly.). The issue has been resolved in RC15 for both upgrade as well as a new install.

  • Update: 1.2 works ok, so I’m sticking with that for now.

  • @Wayne-Workman I think I’m going to try a clean install again using sudo -i instead of logging in as root and see if that helps. I will report back soon!

    OK! Still not working. I tried installing using sudo -i that still had the same problem.

    I rm’d everything, and I tried installing using SVN (just in case) and still have the same problem.

    I might try installing 1.2.0, see if I can get that to work, then try again.

    UPDATE: I’m sticking with 1.2 for now. It’s working ok, and I’ll try again with Trunk in the Spring.

    Thanks for the help!

  • @DAHansen75 said in Want to skip "Booting... (Press Escape to access the menu)":

    Perhaps I should have installed through SVN instead of GIT, and/or not as ROOT when installing trunk.

    SVN and GIT repositories are identical, you will get no different version from either. You absolutely should be installing as root. The proper way to become root is sudo -i and using other methods (esp. in Ubuntu) will cause you trouble.

  • @george1421 No one here has edited the boot.php. It was a clean install on a freshly formatted machine, with a fresh install of Ubuntu 14.04. I used GIT to install trunk. I think I figured something out though.

    If I go to /fog/service/ipxe/boot.php - it looks nothing like what I copied/pasted. The actual file is different and looks correct.

    I DID FIND, around line 598, in /root/trunk/packages/web/lib/fog/bootmenu.class.php the code that changes the menu. I just don’t why it’s doing it.

    Perhaps I should have installed through SVN instead of GIT, and/or not as ROOT when installing trunk.

  • @george1421 if I had to guess this is remnants of the old 1.0.1 server, or as u like to refer it as ‘bleedover.’

    Maybe try sudo rm -rf /var/www/{html/,}fog and re run installer?

  • Moderator

    @DAHansen75 Well on the plus side, iPXE is doing exactly what its being told to do.

    The next question would be why? What do you have under FOG Configuration -> iPXE Boot menu? This almost looks like someone hacked/created a custom boot menu. If it was something that someone did in the past with the boot.php file, it should have been overwritten when you installed 1.3.0RCx series.

  • @george1421 Here you go! It is WAY different from what I get doing the same thing using the Old Fog Server:

    set fog-ip
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    cpuid --ext 29 && set arch x86_64 || set arch i386
    iseq ${platform} efi && set key 0x1b || set key 0x1b
    iseq ${platform} efi && set keyName ESC || set keyName Escape
    prompt --key ${key} --timeout 0 Booting… (Press ${keyName} to access the menu) && goto menuAccess || sanboot --no-describe --drive 0x80
    param mac0 ${net0/mac}
    param arch ${arch}
    param platform ${platform}
    param username ${username}
    param password ${password}
    param menuaccess 1
    param debug 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    chain -ar

  • Moderator

    @DAHansen75 well this is an interesting one then.

    Does it act differently for a unregistered system vs a registered one?

    Actually lets try this check.

    open a browser and go to:

    That should send out a bunch of text, this is the configuration behind the iPXE boot menu. Please post the content of that action here. The mac address is the address from the picture you posted below.

  • @george1421 Mine looks exactly like yours, except for the first one, which is 3 on mine, instead of the 5 on yours.

  • Moderator

    @DAHansen75 Ok that info is correct so we can rule out any of the iPXE booting stuff.

    Have you inspected the FOG Configuration->FOG Settings and the FOG Boot settings section.

    This is what I have in that section and my fog server boots directly into the FOG menu and then after 5 seconds exits to the hard disk boot (via sanboot)


  • @george1421


    Option 67 should be “undionly.kpxe”

    IIRC, 66 should be the IP of the FOG Server.

    Our SysAdmin has been out sick for past week, so he’s catching up today, and I’m trying not to harass him.

  • Moderator

    What do you have precisely for dhcp option 67? I can say I haven’t seen this one before. The only reason why I’m asking here is because this was an upgrade I want to make sure that you are using undionly.kpxe and not pxelinux.0 or unidonly.0. I don’t think this is the problem, I just want to rule it out.

    This is almost acting like there is a password protect on booting into the FOG iPXE menu.

  • My FOG doesn’t do any DNS, we have a separate DNS. My Fog server(s) get a static IP on the network.

    The actual DNS has Option 66/67 settings for the Fog Server (both old and new servers are using the same static IP settings and I only connect one at a time to the network.

    I checked the old Fog server that works as expected, AND the new one, and neither has anything in dnsmasq.d except a network-management file that is basically rem’d out.

    I might not have explained it too well above. The HOSTS are what I’m having an issue with.

    The hosts boot like they did on the 1.0.1 FOG, but when they get to the part where they are just supposed to show the menu - with the regular boot, quick register, deregister, etc. options - instead of just going to the menu it waits for EITHER an ‘esc’ or an ‘enter’

    ‘ESC’ - takes user to a login screen that is asking for the username as password (the same username and password as the FOG server), I enter the username and password, and THEN the menu shows up where I can boot to hard disk, quick register the host, etc.

    ‘ENTER’ bypasses the menu and takes me right to loading the OS.

    I THINK it is acting like the advanced menu is ON, but I’ve never used the advanced menu, so I don’t know…!

    HERE IS WHERE IT WAITS! Press escape, and I have to enter credentials and then I get the standard menu…

    alt text

    Here’s the standard menu of which I speak:

    alt text