PXE boot menu advanced



  • Server
    • FOG Version: 1.3.0 rc13
    • OS: centos 6.6
    Description

    After fog upgrade from 1.2.0 this advanced menu option seems to not be working. How do i adjust:

    kernel bzImage root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns="dnsiphere" web=${fog-ip}/fog/ consoleblank=0 loglevel=4 type=down img=win10master ftp=${fog-ip} imgType=mps osid=7 storage=${fog-ip}:/images imgFormat=2
    imgfetch init.xz
    


  • @george1421 Thank you for the tip. I copied values from .../ipxe/boot.php?mac=<mac_address_you_just_deployed_to> and now it works.

    @Quazz Yes, quite a few things are altered.


  • Moderator

    @Dark000 Alright, so the menu works, but the imaging doesn’t. I’m fairly certain quite a few things in how this is done has been altered.


  • Moderator

    @Dark000 I’m confused why you want to do it this way, but with that said, I might recommend how you reverse engineer this solution since the kernel parameters have been updated since 1.2.0.

    Go into the web gui and schedule a deployment with all of the features you have listed in your current custom URL. Make sure you record the mac address of this system you are deploying to. (No worries you will not actually deploy to this system). Now with a browser navigate to http://<fog_server_ip>/fog/service/ipxe/boot.php?mac=<mac_address_you_just_deployed_to> Now this will show the full command line used to deploy an image in 1.3.0 with the settings you selected.



  • I get this error:
    0_1476695544497_DSC_1209.JPG

    If i send the same image over web interface it works.


  • Moderator

    @Dark000 What exactly does it say when it’s “not working”?

    At a guess, I’d say something got “broken” during upgrade.

    Typing it over from scratch might just fix it straight up.



  • No this is from FOG Configuration>PXE Boot Menu>Advanced Configuration Options:

    :MENU
    menu
    item --gap -- --Images---
    item master10 Windows 10 Image
    :master10
    kernel bzImage root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns="dnsiphere" web=${fog-ip}/fog/ consoleblank=0 loglevel=4 type=down img=win10master ftp=${fog-ip} imgType=mps osid=7 storage=${fog-ip}:/images capone=1 imgFormat=2
    imgfetch init.xz
    boot || goto MENU
    

    This setting was in 1.2.0 and it’s also now in 1.3.0 its just that now it doesn’t work.


  • Moderator

    A better question is where is this text at? Are you pulling it from some file or from the web interface?


  • Moderator

    Is this a FOG created menu entry or something you created by hand in 1.2.0?

    On a side node, fog has the ability now to create / edit the advanced menu from inside the web gui, that is something new with 1.3.0


Log in to reply
 

332
Online

38726
Users

10554
Topics

99916
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.