Can not deploy using multicast - read image_hdr block_size error

  • Server
    • FOG Version: 1.3 - RC- 13 - 5962rev
    • OS: CentOS 7
    • Service Version: 0.11.5
    • OS: Windows 10/CentOS 7

    I am trying to do a deploy using multicast, i have created my image and all is fine if i use ‘unicast’.
    But when i try multicast, i can not deploy and partclone shows an error (sorry, i have no image from screen):

    read image_hdr block_size error

    and at the bottom, after partclone screen:

    .... exit with code 0 (writeImage)           
    args passed /images/mytest/d1p1.img* /dev/sda1 yes
    your computer will reboot in 1 minute

    Following multicast troubleshoot from wiki, multicast works like expected, so the problem would be my image?
    My image settings:

    Image Name	mytest
    Operating System	Linux - (50) (but is dual boot system)
    Image Path	/images/mytest
    Image Type	Single Disk - Resizable - (1)
    Partition	Everything - (1)
    Compression	6
    Image Enabled	y
    Replicate?	y

    What i have to do to make this work?

  • For further clarification to future readers of this thread, the specific commands to allow the necessary ports for Multicast can be found in the CentOS 7 wiki article, linked below.

  • @Wayne-Workman, @Quazz
    Firewalld was disabled when testing, but enabled at production…
    My mistake!!!
    I did not open 49152 to 65532/udp ports in my firewall.
    Thanks to all Fog team!

  • Moderator

    Multicast comes with its own set of requirements to work properly.

    Try going through the tests on the wiki.

    Additionally, check Multicast settings under FOG Configuration, make sure the interface is correct amongst other things.

  • @Thiago Did you specify a port when you did the test or no? Is CentOS 7 firewalld configured? You can check by running systemctl status firewalld

  • This is the first time that i try this.
    sending .fogsettings using udp-sender/udp-receiver worked.
    and this error (read image_hdr block_size error) happens on all images when multicasting.

  • Has multicast with fog ever worked for you?

Log in to reply