Unsure if these settings in FOG are correct



  • Server
    • FOG Version: 1.3
    • OS: Ubuntu
    Client
    • Service Version:
    • OS:
    Description

    Can someone tell me if these settings are correct in my FOG install. 0_1475742186654_TFTP settings.PNG


  • Moderator

    @Sebastian-Roth I agree, after looking at a dhcp booting process all weekend I can read the pcap like code from the matrix.

    The requesting system is in BIOS mode so undionly is the proper boot kernel for it. I see the target requested the file size for undionly.0 from the tftp server at 192.168.1.133 with no second response from the fog server or no request for undionly.0 to be downloaded from the tftp server. This tells me the tftp server responded with “file not found” for undionly.0.


  • Developer

    @pencils Worked loading in a different browser… my issue.

    The PCAP dump looks pretty good! DHCP is fine and I see the client requesting a file via TFTP. The filename is undionly.0!! Did you copy that file as Tom suggested?

    sudo cp /tftproot/undionly.kpxe /tftproot/undionly.0
    


  • @Sebastian-Roth i just clicked it and worked for me?? this is frsutrating!!


  • Developer

    Google Drive is saying it’s not available at the moment?!??!?!



  • @george1421 sorry george. The links are now updated with full rights.


  • Moderator

    @pencils I attempted but they wanted me to provide my google login to access them. You should make the public read only for a short time. I will not provide my credentials to look at them.



  • @george1421 hi george, were you able to access the above links OK? any ideas?




  • Moderator

    @pencils Is it possible to upload the file to a google doc and post the link here. We really need to see where the file name is missing.

    Since you are using dnsmasq this should be sending the file name. I looked back through this thread and I did not see if you posted the dnsmasq config file. Would you post that here in a code block too?



  • @george1421 hi george, i have run the packet analyser. Im no expert but after Line 16 where the client is asking for the file…it seems that there is no server defined and no file defined. I have uploaded the file. If you can point to what i might need to change?

    I cant seems to upload the file. The website is saying i dont have sufficient rights…?


  • Moderator

    @pencils said in Unsure if these settings in FOG are correct:

    Initially i didnt have a folder at the root called /tftproot. So i manually copied it over.

    Why are you manually doing these things? Why can you not run the installer completely? Why is your setup so unusual? Is this a fresh OS or pre existing? What else have you installed on this server?


  • Moderator

    @pencils If debugging tools or process is needed. Then this is how I would go about it.

    1. From a windows computer with the tftp client installed, attempt to grab undionly.kpxe from your fog server if you can do that then move on to step 2
    2. Since you are using dnsmasq to supplement your dhcp server settings ensure you FOG (dnsmasq) server, booting target computer, and preferrably your dhcp server are all on the same subnet (for this test). Install tcpdump on your fog server. Key in the following command sudo tcpdump -w output.pcap port 67 or port 68 or port 69 or port 4011 This will tell tcpdump to only caputer dhcp, tftp, and dhcpProxy traffic and record it in output.pcap. Now pxe boot your target computer until you get the error. Once that is done review the pcap file with wireshark. If you can’t see anything wrong then upload the pcap to this thread and we will take a look at it. The pcap will tell us the truth of what is actually going on the wire. (just to be clear, I’m not saying you are not telling the truth, its just we need to see exactly what is going on with the communications)

  • Moderator

    I’m still of the opinion that the install is botched and possibly you need to run the installer again. Make sure (since you are using ubuntu) that you change the downloaded package’s /bin dir and run sudo ./installfog.sh using the su command. You also need to ensure that your FOG server has direct internet access. If you have a proxy server between FOG and the internet you will have to make a few changes for that. But directories not being where they should is a solid indication that the installer failed to work properly. But again that is only my opinion here. You may be able to back into a working system, but the question is how much time will and effort it take?



  • @george1421 hi both. Its weired. All the file paths which you guys have said hadnt existed in the place you suggested. Basically, i installed a brand new copy of ubuntu and installed 1.3 RC using the instructions on the Wiki. It failed to work. I thought it was a DHCP issue as we have a a switch that performs that function. So, i researched DNSmasq. I installed that with the instructions again from the wiki.

    Nothing has really changed. I just cant get the TFTP to work. So im looking for any diagnostic tools which may be able to help.

    Tom, the other weired thing is that installing a brand new copy of Ubuntu and then installing FOG 1.3 didnt create that folder at the root of the drive?? so i copied it from another location…to the root. When i use root, im talking in windows terminology where “root” means at the root of the c: drive…or any other drive. But it will be the a folder at the top level…if that makes sense.

    This is a picture of a brand new install of ubuntu and FOG with nothing done to it.0_1475765131552_new ubuntu install.PNG


  • Moderator

    @Tom-Elliott I agree here. The OP is operating at a level of interaction not common with most fog installs. Pencils did something happen with the original FOG install on Ubuntu?


  • Senior Developer

    I’m so very confused by the configuration here and what the problem IS.

    This looks like something has been extremely customized and makes it almost impossible for us to properly help.

    For example, a “fresh install” will normally “just work” but based on the configuration files things have been changed quite severely. Now that doesn’t mean we can’t help you, but we need a full backstory first.

    For example, a fresh install will create /tftpboot folder for you. (Not tftproot).



  • @george1421 hi,

    right what i have done thus far. I worked through your tutorial. I uncommented "enable-tftp"and switched off the TFTPD-hpa service. I got 2 errors. PXE-E32 and PXE-M0F. I then commented out the enable-tftp and switched the service tftpd-hpa on and i only got the second error-PXE-M0F

    are there any tools i can use to see what the tftpd service is doing? I have googled it and it said something about a grep command? Is there any software i can install on my ubuntu?

    Any ideas…im nearly there with getting FOG working and i really dont want to abandon it at this late stage.


  • Moderator

    I did create a tutorial for dnsmasq on Cento 7. The config file and instructions are still relevant for other flavors of linux too. You might want to review this document: https://forums.fogproject.org/topic/6376/install-dnsmasq-on-centos-7

    Personally I would create the link to the .0 files and not just copy the files statically to the .0 files. The link will work if / when you upgrade, where the static copy files won’t.


  • Senior Developer

    @pencils As from the configuration I can see you’re trying to use undionly.kpxe, can you please make a copy from the undionly.kpxe to undionly.kpxe.0:

    sudo cp /tftproot/undionly.kpxe{,.0}
    

    Also, because your network boot is only looking for undionly please also run:

    sudo cp /tftproot/undionly{.kpxe,.0}

Log in to reply
 

467
Online

38960
Users

10706
Topics

101584
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.