Deploy to onboard SSD



  • Server
    • FOG Version: 1.2
    • OS: Centos 6.6
    Client
    • Service Version:
    • OS: Either Win7 or Win10
    Description

    How do i deploy fog image to ssd disk that is not recognized by fog. The ssd is onboard and it is not listed in bios under storage it is however visible in bios list order as “N1-Samsung SSD 950 PRO 256G”. Also if i try to do classic install with windows dvd it is recognized.



  • @george1421 Yes the grub menu that is specified as exit. As with goes into bios i meant that even if i don’t boot to network (no cable), computer wont boot from deployed (Win10 image) hard drive and since it can’t find operating system it goes into bios settings. But that is problem with my image or with bios settings. Maybe the problem is only one partition i tend to merge recovery 500mb partition with the rest. But that is fixable i guess, i am just glad that now after fog upgrade the deployment to NVMe disks works. Also thank you for the tip about KBs updates for Win7.


  • Moderator

    @Dark000 Your grub menu has me a bit confused. FOG doesn’t specifically use grub unless you tell it. IF you mean the iPXE boot menu then I understand. Also the goes into bios also confuses me. Let me see if I can translate to what I’ve seen/know. For win7 you need to add to OS updates (KBs) that will enable Win7 to use NVMe disks (much like you needed to upgrade FOG to support NVMe). For Win10 these updates are built in.

    If you are truly seeing a grub boot menu with a Windows OS target system, I would look at the bios exit mode in either the host configuration (in FOG) or the global bios exit mode in the FOG Configuration section.



  • Thank you for all the information it worked! I upgraded to latest version via “Upgrade to trunk” instructions.

    Now when i try to deploy the disk gets recognized, and deployment finishes normally. So that is solved than.

    I have two somehow related questions if i can ask them here. After deployment and reboot the system doesn’t boot up. It goes into GRUB menu or if i pull out the network cable it goes into bios. I figured it is because NVMe creates all sorts of partitions compared to just one that i have from syspreped image which is created in virtualbox. Do you have any advice how to recreate new one (virtualbox (how) or should i just do it from physical machine).

    Second question is related to quick menu item, i had this line which was working, now after upgrade how do i adjust:

    kernel bzImage root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns="dnsiphere" web=${fog-ip}/fog/ consoleblank=0 loglevel=4 type=down img=win10master ftp=${fog-ip} imgType=mps osid=7 storage=${fog-ip}:/images imgFormat=2
    imgfetch init.xz
    

  • Moderator

    said in Deploy to onboard SSD:

    N1-Samsung SSD 950 PRO 256G

    To join the chorus here, upgrade to 1.3.0-RCx series. That disk is a NVMe disk that is supported by the latest version of FOG. You will want to use 1.3.0 if you need to capture / deploy to newer hardware, GPT format, NVMe disks, or need native Win10 support. If you have virtualization at your company, I would suggest spinning up a new VM with Centos 7 and then install FOG 1.3.0 on it. There are enough changes between the OS and FOG to make upgrading sometimes break.

    Mod note: Moving to Hardware issues.


  • Moderator

    As @Sebastian-Roth said, upgrade to trunk release

    Instructions can be found here: https://wiki.fogproject.org/wiki/index.php/Upgrade_to_trunk


  • Developer

    @Dark000 Updating your FOG server to the latest (release candidate) version will make it work!


Log in to reply
 

331
Online

38729
Users

10555
Topics

99939
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.