Delayed or cron tasks don't work



  • Server
    • FOG Version: 1.3 RC14
    • OS: Ubuntu 14.04
    Client
    • Service Version: 0.11.5
    • OS: Windows 7
    Description

    Hello,
    I’m trying to use delayed task but Fog say “Date is in the past”. Date and time is correct in Ubuntu, UTC is good in apache2/php.ini and I’ve change the UTC in FOG as said here: schedule delayed or cron task doesn’t work But still don’t work…
    Any idea?



  • @Tom-Elliott
    Hello,
    Fog configuration page:
    text alternatif
    Fog general settings:
    text alternatif
    FOG services logs:
    text alternatif
    servicemaster.log:

    [09-14-16 2:23:45 pm] FOGMulticastManager Start
    [09-14-16 2:23:45 pm] FOGMulticastManager forked child process (18686).
    [09-14-16 2:23:45 pm] FOGMulticastManager child process (18686) is running.
    [09-14-16 2:23:47 pm] FOGImageReplicator Start
    [09-14-16 2:23:47 pm] FOGImageReplicator forked child process (18735).
    [09-14-16 2:23:47 pm] FOGImageReplicator child process (18735) is running.
    [09-14-16 2:23:50 pm] FOGImageReplicator Start
    [09-14-16 2:23:50 pm] FOGImageReplicator forked child process (19050).
    [09-14-16 2:23:50 pm] FOGImageReplicator child process (19050) is running.
    [09-14-16 2:23:55 pm] FOGPingHosts Start
    [09-14-16 2:23:55 pm] FOGPingHosts forked child process (19218).
    [09-14-16 2:23:55 pm] FOGTaskScheduler Start
    [09-14-16 2:23:55 pm] FOGTaskScheduler forked child process (19219).
    [09-14-16 2:23:55 pm] FOGTaskScheduler child process (19219) is running.
    [09-14-16 2:23:55 pm] FOGPingHosts child process (19218) is running.
    [09-14-16 2:33:55 pm] FOGTaskScheduler child process (19219) exited with code 255.
    [09-14-16 2:38:55 pm] FOGTaskScheduler forked child process (21217).
    [09-14-16 2:38:55 pm] FOGTaskScheduler child process (21217) is running.
    [09-29-16 12:34:55 pm] Service_Signal_handler (18733) received signal 15.
    [09-29-16 12:34:55 pm] Service_Signal_handler (18733) killing child (18735).
    [09-29-16 12:34:55 pm] Service_Signal_handler (18733) exiting.
    [09-29-16 12:34:55 pm] Service_Signal_handler (18685) received signal 15.
    [09-29-16 12:34:55 pm] Service_Signal_handler (18685) killing child (18686).
    [09-29-16 12:34:55 pm] Service_Signal_handler (18685) exiting.
    [09-29-16 12:34:55 pm] Service_Signal_handler (19199) received signal 15.
    [09-29-16 12:34:55 pm] Service_Signal_handler (19199) killing child (19218).
    [09-29-16 12:34:55 pm] Service_Signal_handler (19199) exiting.
    [09-29-16 12:34:55 pm] Service_Signal_handler (19147) received signal 15.
    [09-29-16 12:34:55 pm] Service_Signal_handler (19147) killing child (21217).
    [09-29-16 12:34:55 pm] Service_Signal_handler (19147) exiting.
    [09-29-16 12:34:55 pm] Service_Signal_handler (18828) received signal 15.
    [09-29-16 12:34:55 pm] Service_Signal_handler (18828) killing child (19050).
    [09-29-16 12:34:55 pm] Service_Signal_handler (18828) exiting.
    [09-29-16 12:35:17 pm] FOGTaskScheduler Start
    [09-29-16 12:35:17 pm] FOGTaskScheduler forked child process (1718).
    [09-29-16 12:35:17 pm] FOGTaskScheduler child process (1718) is running.
    [09-29-16 12:35:17 pm] FOGImageReplicator Start
    [09-29-16 12:35:17 pm] FOGImageReplicator forked child process (1719).
    [09-29-16 12:35:17 pm] FOGImageReplicator child process (1719) is running.
    [09-29-16 12:35:17 pm] FOGMulticastManager Start
    [09-29-16 12:35:17 pm] FOGMulticastManager forked child process (1720).
    [09-29-16 12:35:17 pm] FOGMulticastManager child process (1720) is running.
    [09-29-16 12:35:17 pm] FOGImageReplicator Start
    [09-29-16 12:35:17 pm] FOGImageReplicator forked child process (1721).
    [09-29-16 12:35:17 pm] FOGImageReplicator child process (1721) is running.
    [09-29-16 12:35:18 pm] FOGPingHosts Start
    [09-29-16 12:35:18 pm] FOGPingHosts forked child process (2195).
    [09-29-16 12:35:18 pm] FOGPingHosts child process (2195) is running.
    [09-29-16 12:45:18 pm] FOGTaskScheduler child process (1718) exited with code 255.
    [09-29-16 12:50:18 pm] FOGTaskScheduler forked child process (5825).
    [09-29-16 12:50:18 pm] FOGTaskScheduler child process (5825) is running.
    [09-30-16 12:13:29 pm] Service_Signal_handler (1558) received signal 15.
    [09-30-16 12:13:29 pm] Service_Signal_handler (1558) killing child (1720).
    [09-30-16 12:13:29 pm] Service_Signal_handler (1558) exiting.
    [09-30-16 12:13:31 pm] Service_Signal_handler (1512) received signal 15.
    [09-30-16 12:13:31 pm] Service_Signal_handler (1512) killing child (1721).
    [09-30-16 12:13:31 pm] Service_Signal_handler (1512) exiting.
    [09-30-16 12:13:34 pm] Service_Signal_handler (1535) received signal 15.
    [09-30-16 12:13:34 pm] Service_Signal_handler (1535) killing child (1719).
    [09-30-16 12:13:34 pm] Service_Signal_handler (1535) exiting.
    [09-30-16 12:13:36 pm] Service_Signal_handler (1487) received signal 15.
    [09-30-16 12:13:36 pm] Service_Signal_handler (1487) killing child (5825).
    [09-30-16 12:13:36 pm] Service_Signal_handler (1487) exiting.
    [09-30-16 12:13:38 pm] Service_Signal_handler (1951) received signal 15.
    [09-30-16 12:13:38 pm] Service_Signal_handler (1951) killing child (2195).
    [09-30-16 12:13:38 pm] Service_Signal_handler (1951) exiting.
    

    There is a problem, I have no more logs, look at the dates, it seems that since the 1.2 to 1.3 update FOG write nothing.

    And I have a issue with all FOG services:
    text alternatif


  • Senior Developer

    @Lenain Something seems really strange here. There’s not a particular reason why things are failing, just I know that they ARE failing.

    Can you please try:

    rm -rf /var/www/fog /var/www/html/fog
    

    Then rerun the installer? It almost seems like from days past. Also, please post the information from:

    FOG Configuration Page ->
    FOG Settings ->
    FOG Service Logs, FOG Service Sleep Times, and FOG Service TTY Output


  • Moderator

    Bumping this.



  • @Tom-Elliott
    servicemaster.log:

    [09-14-16 2:23:45 pm] FOGMulticastManager Start
    [09-14-16 2:23:45 pm] FOGMulticastManager forked child process (18686).
    [09-14-16 2:23:45 pm] FOGMulticastManager child process (18686) is running.
    [09-14-16 2:23:47 pm] FOGImageReplicator Start
    [09-14-16 2:23:47 pm] FOGImageReplicator forked child process (18735).
    [09-14-16 2:23:47 pm] FOGImageReplicator child process (18735) is running.
    [09-14-16 2:23:50 pm] FOGImageReplicator Start
    [09-14-16 2:23:50 pm] FOGImageReplicator forked child process (19050).
    [09-14-16 2:23:50 pm] FOGImageReplicator child process (19050) is running.
    [09-14-16 2:23:55 pm] FOGPingHosts Start
    [09-14-16 2:23:55 pm] FOGPingHosts forked child process (19218).
    [09-14-16 2:23:55 pm] FOGTaskScheduler Start
    [09-14-16 2:23:55 pm] FOGTaskScheduler forked child process (19219).
    [09-14-16 2:23:55 pm] FOGTaskScheduler child process (19219) is running.
    [09-14-16 2:23:55 pm] FOGPingHosts child process (19218) is running.
    [09-14-16 2:33:55 pm] FOGTaskScheduler child process (19219) exited with code 255.
    [09-14-16 2:38:55 pm] FOGTaskScheduler forked child process (21217).
    [09-14-16 2:38:55 pm] FOGTaskScheduler child process (21217) is running.
    

    /var/log/apache/error.log

    [Tue Oct 04 15:13:45.668665 2016] [ssl:debug] [pid 9366] ssl_engine_pphrase.c(181): AH02199: SSL not enabled on vhost srv-image:80, skipping SSL setup
    [Tue Oct 04 15:13:45.668716 2016] [ssl:debug] [pid 9366] ssl_engine_pphrase.c(181): AH02199: SSL not enabled on vhost 10.144.35.67:80, skipping SSL setup
    [Tue Oct 04 15:13:45.668719 2016] [ssl:debug] [pid 9366] ssl_engine_pphrase.c(181): AH02199: SSL not enabled on vhost srv-image:80, skipping SSL setup
    [Tue Oct 04 15:13:45.668734 2016] [ssl:info] [pid 9366] AH01887: Init: Initializing (virtual) servers for SSL
    [Tue Oct 04 15:13:45.668755 2016] [ssl:info] [pid 9366] AH01876: mod_ssl/2.4.7 compiled against Server: Apache/2.4.7, Library: OpenSSL/1.0.1f
    [Tue Oct 04 15:13:45.695627 2016] [ssl:debug] [pid 9367] ssl_engine_pphrase.c(181): AH02199: SSL not enabled on vhost srv-image:80, skipping SSL setup
    [Tue Oct 04 15:13:45.695643 2016] [ssl:debug] [pid 9367] ssl_engine_pphrase.c(181): AH02199: SSL not enabled on vhost 10.144.35.67:80, skipping SSL setup
    [Tue Oct 04 15:13:45.695645 2016] [ssl:debug] [pid 9367] ssl_engine_pphrase.c(181): AH02199: SSL not enabled on vhost srv-image:80, skipping SSL setup
    [Tue Oct 04 15:13:45.695660 2016] [socache_shmcb:debug] [pid 9367] mod_socache_shmcb.c(389): AH00821: shmcb_init allocated 512000 bytes of shared memory
    [Tue Oct 04 15:13:45.695663 2016] [socache_shmcb:debug] [pid 9367] mod_socache_shmcb.c(405): AH00822: for 511912 bytes (512000 including header), recommending 32 subcaches, 88 indexes each
    [Tue Oct 04 15:13:45.695665 2016] [socache_shmcb:debug] [pid 9367] mod_socache_shmcb.c(438): AH00824: shmcb_init_memory choices follow
    [Tue Oct 04 15:13:45.695667 2016] [socache_shmcb:debug] [pid 9367] mod_socache_shmcb.c(440): AH00825: subcache_num = 32
    [Tue Oct 04 15:13:45.695669 2016] [socache_shmcb:debug] [pid 9367] mod_socache_shmcb.c(442): AH00826: subcache_size = 15992
    [Tue Oct 04 15:13:45.695671 2016] [socache_shmcb:debug] [pid 9367] mod_socache_shmcb.c(444): AH00827: subcache_data_offset = 2128
    [Tue Oct 04 15:13:45.695672 2016] [socache_shmcb:debug] [pid 9367] mod_socache_shmcb.c(446): AH00828: subcache_data_size = 13864
    [Tue Oct 04 15:13:45.695674 2016] [socache_shmcb:debug] [pid 9367] mod_socache_shmcb.c(448): AH00829: index_num = 88
    [Tue Oct 04 15:13:45.695725 2016] [socache_shmcb:info] [pid 9367] AH00830: Shared memory socache initialised
    [Tue Oct 04 15:13:45.695728 2016] [ssl:info] [pid 9367] AH01887: Init: Initializing (virtual) servers for SSL
    [Tue Oct 04 15:13:45.695736 2016] [ssl:info] [pid 9367] AH01876: mod_ssl/2.4.7 compiled against Server: Apache/2.4.7, Library: OpenSSL/1.0.1f
    [Tue Oct 04 15:13:45.697547 2016] [mpm_prefork:notice] [pid 9367] AH00163: Apache/2.4.7 (Ubuntu) OpenSSL/1.0.1f configured -- resuming normal operations
    [Tue Oct 04 15:13:45.697558 2016] [mpm_prefork:info] [pid 9367] AH00164: Server built: Jul 15 2016 15:34:04
    [Tue Oct 04 15:13:45.697572 2016] [core:notice] [pid 9367] AH00094: Command line: '/usr/sbin/apache2'
    [Tue Oct 04 15:13:45.697575 2016] [mpm_prefork:debug] [pid 9367] prefork.c(995): AH00165: Accept mutex: fcntl (default: sysvsem)
    [Tue Oct 04 15:13:45.747834 2016] [authz_core:debug] [pid 9372] mod_authz_core.c(802): [client 172.18.129.247:52304] AH01626: authorization result of Require all granted: granted
    [Tue Oct 04 15:13:45.747855 2016] [authz_core:debug] [pid 9372] mod_authz_core.c(802): [client 172.18.129.247:52304] AH01626: authorization result of <RequireAny>: granted
    [Tue Oct 04 15:13:45.748184 2016] [authz_core:debug] [pid 9373] mod_authz_core.c(802): [client 172.18.129.232:50019] AH01626: authorization result of Require all granted: granted
    [Tue Oct 04 15:13:45.748223 2016] [authz_core:debug] [pid 9373] mod_authz_core.c(802): [client 172.18.129.232:50019] AH01626: authorization result of <RequireAny>: granted
    [Tue Oct 04 15:13:45.748489 2016] [authz_core:debug] [pid 9374] mod_authz_core.c(802): [client 172.18.132.116:51920] AH01626: authorization result of Require all granted: granted
    [Tue Oct 04 15:13:45.748511 2016] [authz_core:debug] [pid 9374] mod_authz_core.c(802): [client 172.18.132.116:51920] AH01626: authorization result of <RequireAny>: granted
    

    fogscheduler.log empty and I have e /var/log/php-errors.log empty too.


  • Senior Developer

    Then you’re not running systemd which is fine. Can you get the logs that @mp12 showed?



  • @Tom-Elliott
    Ubuntu 14.04 use Upstart, I’ve enter initctl status FOGScheduler the response is initctl: Unknown Job: FOGScheduler


  • Senior Developer

    Sorry I didn’t get to respond sooner. @mp12 is correct, those are the log files that would be the most relevant. I don’t know what version of OS you’re running, but in some cases you may need to run: systemctl status -l FOGScheduler to see messages too. This is only relevant if you’re running an OS that is using systemd as the initializer of services.



  • @Lenain

    /opt/fog/log/servicemaster.log
    /opt/fog/log/fogscheduler.log
    /var/log/apache/error.log



  • @Tom-Elliott
    Trying a UP ^^
    Is there a log file where I can find error message for FOGScheduler service?



  • @Tom-Elliott
    Good point, it can’t start. Is there a log file where I can find error message?
    Error


  • Senior Developer

    @Lenain Is the ‘FOGScheduler’ Service running?



  • @Wayne-Workman
    Hello,
    Here the problem, I create the scheduled task at 8:35AM (in this example deploy task):
    Creation
    Ok message from fog:
    Create successful
    In scheduled tasks list it’s ok:
    scheduled tasks
    But the task stay in scheduled at 8:37AM:
    Look at the time

    There is nothing in Active Tasks and computer don’t deploy.


  • Moderator

    @Tom-Elliott Agreed. Knowing WHAT kind of task would be of great help, and a screen-shot of the scheduling you’re trying to do would be invaluable. Otherwise we’re just making guesses and guesses are generally not helpful.


  • Senior Developer

    I know this sounds mean but doesn’t work is of zero help to anybody. Please provide details of exactly what isn’t working and how you know if.


  • Moderator

    @Lenain Can you check your server time? Its displayed in the top left of the web gui. Is it accurate?



  • @Tom-Elliott
    I did it, i’m in RC11 and there is no message now but cron task and delayed task still don’t work


  • Senior Developer

    Update to RC11. Cron tasks will work. Once you make a date change, you have to restart the FOGScheduler service as well.


Log in to reply
 

510
Online

39009
Users

10722
Topics

101856
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.