Failed to Update to 1.3.0-RC-10



  • Hi guys,

    We have a Fog server mounted on a CentOS Server.
    Now, we have the fog on the 1.3.0-RC-8 version. When we try to update this version, we often this error:

    0_1473952431653_ErrorFOG 1.3.0-RC-10.PNG

    I tried to restart the MySql, reboot the server, change the password for the user Fog on the MySQL…
    Any idea to solve that?

    Thanks!


  • Senior Developer

    @george1421 I wonder if it’s the same error as the line 103 error of the other items?


  • Moderator

    @rnavarro Thank you for the feedback. This java error is a bit confusing then. FOG does not use java at all (as Tom posted below), so its not clear why mysql is wanting to use it.

    Is this a fresh install of cento 6.5? And did you pick the minimal (basic) install of centos 6.5? Normally java isn’t installed unless you pick something other than minimal (like centos workstation)

    Can you also say when you tried to upgrade FOG were you logged in as the linux root user?



  • hI @george1421

    I will ask ur question while the centOS update.
    This server only run the Fog, and its istalled on a vmware environment.


  • Moderator

    @rnavarro OK you are on Centos 6.5. Great. Before you try to upgrade fog, can you run yum update and make sure Centos is up to date.

    One question, is this server that FOG is running on, supporting any other application or is it only FOG that runs on it?

    One thing I just noticed, in your ssh terminal session you are logged in as the “fog” user but you are doing an upgrade. Unless I’m wrong, you should do any FOG installs as root. The “fog” user is only used by the FOG program internally and should never be logged into directly.



  • Hello, thanks for the responses.

    The CentOS are in the 6.5 version, with the 2.6.32-431 on the Linux Core.
    Actually, i uninstalled anything version of Java or JDK. When i try to reinstall, i often that the process failed on the Mysql. The next step that i do, its reinstall Mysql, and the result is the same.

    Any idea?


  • Moderator

    What version of CentOS?


  • Senior Developer

    @rnavarro fog does not do anything with Java, so something else is the matter. Can you remove Java and try reinstalling?


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.