Upgrade 1.2 => 1.3 RC10 error Mysql



  • Hello,

    I tried tu upgrade my fog server but I have an issue during the process :

    • Confirming package installation

    • Checking package: bc…OK

    • Checking package: curl…OK

    • Checking package: dhcp…OK

    • Checking package: gcc…OK

    • Checking package: gcc-c++…OK

    • Checking package: gzip…OK

    • Checking package: httpd…OK

    • Checking package: lftp…OK

    • Checking package: m4…OK

    • Checking package: make…OK

    • Checking package: mod_ssl…OK

    • Checking package: mysql…OK

    • Checking package: mysql-server…OK

    • Checking package: net-tools…OK

    • Checking package: nfs-utils…OK

    • Checking package: php…OK

    • Checking package: php-bcmath…OK

    • Checking package: php-cli…OK

    • Checking package: php-common…OK

    • Checking package: php-fpm…OK

    • Checking package: php-gd…OK

    • Checking package: php-mbstring…OK

    • Checking package: php-mcrypt…OK

    • Checking package: php-mysqlnd…OK

    • Checking package: php-process…OK

    • Checking package: tar…OK

    • Checking package: tftp-server…OK

    • Checking package: vsftpd…OK

    • Checking package: wget…OK

    • Checking package: xinetd…OK

    • Configuring services

    • Setting up fog user…Already setup

    • Setting up fog password…OK

    • Stopping FOGMulticastManager Service…OK

    • Stopping FOGImageReplicator Service…OK

    • Stopping FOGSnapinReplicator Service…OK

    • Stopping FOGScheduler Service…OK

    • Stopping FOGPingHosts Service…OK

    • Setting up and starting MySQL…Failed!

    After that if i try to restart mysqld service I have this error :

    /etc/init.d/mysqld: line 103: Erreur de syntaxe près du symbole inattendu « fi »
    /etc/init.d/mysqld: line 103: ` fi’
    [root@mfvml14 error_logs]#

    I have to reinstall mysql-server with yum if I want to restart the service

    Can someone help me ?


  • Senior Developer

    https://forums.fogproject.org/topic/8758/fog-installation-error-cannot-restart-mysql/9#

    I’ve found and fixed the cause of the issue. It was my scans looking to correct other issues. I didn’t realize some distros were adding that particular if statement. Sorry :(


  • Moderator

    @Seydoo That’s pretty strange… This must be custom, someone had to have set that up that way, and then commented it without realizing an if statement in BASH cannot do “nothing”.


  • Senior Developer

    @Seydoo fog does not add any normal service init files. It only adds for the fog services



  • I finally succeed upgrading FOG
    What I did :

    mysqld return an error on line 103 so I Looked at mysqld : line 103 there was a # inside an IF (put by installfog.sh ?) :

        if [ "$1" = "sos" ] ; then
    

    # MYOPTIONS="$MYOPTIONS --skip-grant-tables --skip-networking"
    fi
    To solve this i have deactivated these 3 lines



  • @Quazz said in Upgrade 1.2 => 1.3 RC10 error Mysql:

    snmysqlhost='localhost' ./installfog.sh
    

    I tried this command but it still doesn’t work
    Im on RedHat Enterprise 6


  • Moderator

    snmysqlhost='localhost' ./installfog.sh
    

Log in to reply
 

396
Online

38729
Users

10555
Topics

99942
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.