Multicast remains on Partclone screen (HP switch)



  • Hi,

    I made some search but found no response to my problem…
    Since we changed our switch 3 years ago (before : Cisco, after : HP), multicast won’t work anymore…
    Tested on fog 0.32, 1.0, 1.11, 1.2, 1.3…

    Here is what happens, even if I deploy one single host, and nothing else happens
    0_1473248214585_WP_20160907_13_13_25_Pro.jpg

    And I’ve got this in multicast.log:

    [09-07-16 12:25:40 pm]  | Task (6) Multi-Cast Task is new!
    [09-07-16 12:25:40 pm]  | Task (6) Multi-Cast Task has been cleaned.
    [09-07-16 12:25:40 pm]  | Task (6) /images/Win10 image file found.
    [09-07-16 12:25:40 pm]  | Task (6) 12 client(s) found or to receive.
    [09-07-16 12:25:40 pm]  | Task (6) Multi-Cast Task sending on base port: 64448
    [09-07-16 12:25:40 pm]  | CMD: cat /images/Win10/d1p1.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 12 --max-wait 600 --portbase 64448 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/Win10/d1p2.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 12 --max-wait 10 --portbase 64448 --full-duplex --ttl 32 --nokbd --nopointopoint;
    [09-07-16 12:25:40 pm]  | Task (6) Multi-Cast Task has started.
    [09-07-16 12:25:50 pm]  | Task (6) Multi-Cast Task is already running PID 24324
    [09-07-16 12:26:00 pm]  | Task (6) Multi-Cast Task is already running PID 24324
    [09-07-16 12:26:10 pm]  | Task (6) Multi-Cast Task is already running PID 24324
    [09-07-16 12:26:20 pm]  | Task (6) Multi-Cast Task is already running PID 24324
    [09-07-16 12:26:30 pm]  | Task (6) Multi-Cast Task is already running PID 24324
    

    I read wiki about this, enabled IGMP on each vlan of each switch, but no change…

    Thanks for your help, deploying tens of computer in unicast is really long…


  • Moderator

    @Matthieu-Jacquart My thought was to take two spare computers aside, install FOG on one with DHCP too, then take it off-network with your spare switch. And we just work on adjusting the switch configuration until we get multicast working to the other computer.



  • @Wayne-Workman For the moment I just test multicast on one computer.
    I have a 2530 spare to make test, but even if I try to deploy directly on my core L3 (2920), it’s similar…


  • Moderator

    @Matthieu-Jacquart said in Multicast remains on Partclone screen (HP switch):

    Thanks for your help, deploying tens of computer in unicast is really long…

    In the meantime, I would suggest only deploying 2 or 3 at a time. You can limit the number in Storage Management -> node -> max clients.

    We need to figure out where the failure is exactly. Do you have a spare HP 2920/2530 switch that you can tinker with for a few days off-network ?


  • Senior Developer

    @Matthieu-Jacquart I believe this is related to the ports. I don’t know if you have a specific port or set of ports that are allowed vs, those that are not allowed.



  • Please help… ?
    Everything seems fine when testing, just this screen remaining on Partclone screen :(



  • Ok, I’ll continue test with sotfware IC_Tester_Multicast and communication is ok between 2 PC (1 server and 1 client).

    After that I run on fog server (with client in debug mode and “udp-receiver” command) :

    
    root@FOG:~/fogproject/bin$ udp-sender --file /opt/fog/log/multicast.log --ttl 1
    Udp-sender 20120424
    Using full duplex mode
    Using mcast address 232.168.10.60
    UDP sender for /opt/fog/log/multicast.log at 192.168.10.60 on eth0
    Broadcasting control to 192.168.10.255
    New connection from 192.168.10.200  (#0) 00000009
    Ready. Press any key to start sending data.
    Starting transfer: 00000009
    bytes=      17 782  re-xmits=0000000 (  0.0%) slice=0112 -   0
    Transfer complete.
    Disconnecting #0 (192.168.10.200)
    

    So everything seems good for multicast, but still same problem : computer stays on partclone screen.
    In multicast.log

    [10-19-16 11:23:22 am]  | Task (16) Multi-Cast Task is new!
    [10-19-16 11:23:22 am]  | Task (16) Multi-Cast Task has been cleaned.
    [10-19-16 11:23:22 am]  | Task (16) /images/Win10 image file found.
    [10-19-16 11:23:22 am]  | Task (16) 1 client(s) found or to receive.
    [10-19-16 11:23:22 am]  | Task (16) Multi-Cast Task sending on base port: 64158
    [10-19-16 11:23:22 am]  | CMD: cat /images/Win10/d1p1.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 1 --max-wait 600 --mcast-data-address 192.168.10.60 --portbase 64158 --full-duplex --ttl 32 --nokbd --nopointopoint;cat /images/Win10/d1p2.img | /usr/local/sbin/udp-sender --interface eth0 --min-receivers 1 --max-wait 10 --mcast-data-address 192.168.10.60 --portbase 64158 --full-duplex --ttl 32 --nokbd --nopointopoint;
    [10-19-16 11:23:22 am]  | Task (16) Multi-Cast Task has started.
    [10-19-16 11:23:32 am]  | Task (16) Multi-Cast Task is already running PID 10132
    [10-19-16 11:23:42 am]  | Task (16) Multi-Cast Task is already running PID 10132
    [10-19-16 11:23:52 am]  | Task (16) Multi-Cast Task is already running PID 10132
    [10-19-16 11:24:02 am]  | Task (16) Multi-Cast Task is already running PID 10132
    [10-19-16 11:24:12 am]  | Task (16) Multi-Cast Task is already running PID 10132
    [10-19-16 11:24:22 am]  | Task (16) Multi-Cast Task is already running PID 10132
    

    Help will be appreciate, thanks
    Matthieu



  • @Tom-Elliott nop, no change…
    Anyone else use fog with HP 2920/2530 swtich ?


  • Senior Developer

    @Matthieu-Jacquart in GUI. There’s actually a variable called port override



  • @Tom-Elliott you mean in file fogsettings on debian server, or in web management ?
    Because I’ve tried to fix it in web management but it changes again…


  • Senior Developer

    @Matthieu-Jacquart it does, however you can override it in fog settings



  • @Tom-Elliott ok, appliying this command to all vlan (64158 is multicast port in fog configuration)

    ip forward-protocol udp 192.168.10.60 64158
    

    And now :

    show ip forward-protocol
     IP Forwarder Addresses
        UDP Broadcast Forwarding: Enabled
     VLAN: 1
      IP Forward Addresses UDP Port
      -------------------- --------
      192.168.10.60        64158
     VLAN: 2
      IP Forward Addresses UDP Port
      -------------------- --------
      192.168.10.60        64158
     VLAN: 3
      IP Forward Addresses UDP Port
      -------------------- --------
      192.168.10.60        64158
     VLAN: 4
      IP Forward Addresses UDP Port
      -------------------- --------
      192.168.10.60        64158
     VLAN: 5
      IP Forward Addresses UDP Port
      -------------------- --------
      192.168.10.60        64158
     VLAN: 6
      IP Forward Addresses UDP Port
      -------------------- --------
      192.168.10.60        64158
     VLAN: 7
      IP Forward Addresses UDP Port
      -------------------- --------
      192.168.10.60        64158
     VLAN: 8
      IP Forward Addresses UDP Port
      -------------------- --------
      192.168.10.60        64158
     VLAN: 9
      IP Forward Addresses UDP Port
      -------------------- --------
      192.168.10.60        64158
     VLAN: 10
      IP Forward Addresses UDP Port
      -------------------- --------
      192.168.10.60        64158
     VLAN: 11
      IP Forward Addresses UDP Port
      -------------------- --------
      192.168.10.60        64158
    

    But always same result, even with 1 PC :(
    And I’ve just noticed that FOG_UDPCAST_STARTINGPORT seems change every time ???


  • Senior Developer

    @Matthieu-Jacquart assuming you have all vlans looking at a single fog server each vlan would need to allow forwarding to the broadcast address set for the fog server.


  • Senior Developer

    @Matthieu-Jacquart I believe you’d only need to enable it at the thing handling the routing so it can move about. This namely because the main central switch or router is what’s communicating to the other switches. Of course enabling forwarding on each switch shouldn’t hurt either but I believe you’d need it pointing at the place to forward ad welk



  • I’ve got this on my L3 switch (HP 2920)

    SW-RGI-01(config)# ip udp-bcast-forward
    SW-RGI-01(config)# show ip forward-protocol
     IP Forwarder Addresses
        UDP Broadcast Forwarding: Enabled
     VLAN: 1
      IP Forward Addresses UDP Port
      -------------------- --------
     VLAN: 2
      IP Forward Addresses UDP Port
      -------------------- --------
     VLAN: 3
      IP Forward Addresses UDP Port
      -------------------- --------
     VLAN: 4
      IP Forward Addresses UDP Port
      -------------------- --------
     VLAN: 5
      IP Forward Addresses UDP Port
      -------------------- --------
     VLAN: 6
      IP Forward Addresses UDP Port
      -------------------- --------
     VLAN: 7
      IP Forward Addresses UDP Port
      -------------------- --------
     VLAN: 8
      IP Forward Addresses UDP Port
      -------------------- --------
     VLAN: 9
      IP Forward Addresses UDP Port
      -------------------- --------
     VLAN: 10
      IP Forward Addresses UDP Port
      -------------------- --------
     VLAN: 11
      IP Forward Addresses UDP Port
      -------------------- --------
     VLAN: 12
      IP Forward Addresses UDP Port
      -------------------- --------
     VLAN: 13
      IP Forward Addresses UDP Port
      -------------------- --------
     VLAN: 21
      IP Forward Addresses UDP Port
      -------------------- --------
     VLAN: 22
      IP Forward Addresses UDP Port
      -------------------- --------
     VLAN: 251
      IP Forward Addresses UDP Port
      -------------------- --------
     VLAN: 252
      IP Forward Addresses UDP Port
      -------------------- --------
     VLAN: 253
      IP Forward Addresses UDP Port
      -------------------- --------
     VLAN: 254
      IP Forward Addresses UDP Port
      -------------------- --------
    

    But UDP forwading command seems not exist on my L2 switch (HP 2530)…



  • @Tom-Elliott said in Multicast problem:

    enable udp broadcast forwarding

    ok, I’m not very familiar with HP switch, but I’m going to test that ;)


  • Senior Developer

    I’m guessing you also have vlans in your environment? You probably need to enable udp broadcast forwarding


Log in to reply
 

791
Online

38729
Users

10555
Topics

99942
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.