USB NIC PXE Boot?



  • Hello!

    Currently have FOG Version 1.3.0-RC-9/ SVN Revision: 5952 running on an Ubuntu 16.04 server; works great!
    I’m able to boot almost any PC, and image sysprepped Windows images to the device without registration. This is great for me, because I run a small repair shop that gets tons of different PCs every single day.

    Anyways, recently I bought a StarTech USB21000S2 (recommended from these forums) in the hopes of booting the newer Dells, HPs and Lenovos that don’t come with a built-in ethernet adapter. However, I have so far been unsuccessful - booting directly with PXE as well as using an iPXE bootable ISO. I’ve also tried adding the host manually via MAC address (kind of a pain for my techs, honestly) with the appropriate kernel arguments. I’ve made sure the BIOS had the appropriate settings (no secure boot, USB/PXE boot enabled where available, etc).

    I’ve seen some mention of symlinking a different bootable kernel, but haven’t found anything “solid” pointing me to where I’m going wrong.

    FWIW, I’m a Linux and Windows sysadmin, so don’t hold back! Any advice appreciated.

    Thanks


  • Moderator

    @Sebastian-Roth said in USB NIC PXE Boot?:

    The PC/notebook/tablet/whatever device you are trying to PXE boot with this USB NIC needs to have specific drivers for this USB NIC chip in the BIOS!!

    I suppose now we must record the device that the adapter worked on, too. I didn’t think of this but it makes sense.

    #wiki



  • @Sebastian-Roth

    Apologies, I’ll explain:

    On ~10 different machines (XPS 15, Precision 5510, X1 Carbon 3rd gen, Thinkpad T500, Thinkpad X220, HP Elitebook, etc) I have the same result: it’s as if nothing is plugged into the ethernet port. I get a “Waiting for link-up on net0 . . . . . . . . . . . . . . . . Down” no matter what. I’ve tried using an iPXE bootable ISO as well as simply connecting to the FOG server via BIOS/UEFI PXE. I can successfully boot to the FOG menu (and image) using actual ethernet, but never using this adapter (or the other two I’ve tried). Further, I’ve made 100% certain that the BIOS/UEFI is configured for ethernet PXE booting (the X1 Carbon for instance has a menu entry for this exact purpose). I always switch to Legacy/CSM with secureboot disabled.

    I’d found John Willis blog previously - that’s what led me here, actually :).


  • Developer

    @yochaigal We have confirmation on working StarTech USB21000S2 in the wiki as well. But USB NICs are a bit special as they don’t work for every device. The PC/notebook/tablet/whatever device you are trying to PXE boot with this USB NIC needs to have specific drivers for this USB NIC chip in the BIOS!!

    As far as I can see you haven’t told us where things go wrong yet. “Does not work” is not very helpful. Please post a picture of an error or a hang you see. If you don’t run into such a situation but simply see windows booting up I think it’s that USB NIC not being recognized by your device’s BIOS. Try all your Dells, HPs and Lenovos and see which ones are working with the StarTech USB21000S2 and which ones don’t.

    By the way, John Willis (this one and his other articles) is a must read if you are trying to get USB NIC PXE booting to work…


  • Moderator

    That thread is quite old. I found this one that references the adapter you’re using, confirmed working as of 2016-02-02:
    https://forums.fogproject.org/topic/6510/boot-dell-xps-12-to-usb-to-network-card/66

    I’m sort of disappointed because the word “kernel” was used upwards of 15 times in this thread and it’s ‘continuation’ thread but never once was an actual version spoken…

    You can correlate the age of these posts with kernel publish dates and perhaps try those around that time.



  • @Wayne-Workman

    Tom Elliot’s seem to work, see https://forums.fogproject.org/topic/2118/looking-for-usb-nic-that-is-known-to-work-with-pxe-fog/5
    And that’s what I’m using (via FOG). I’ve tried booting from various iPXE builds as well but with no luck.


  • Moderator

    @yochaigal Is there a kernel version mentioned in the thread where you found the recommendation for this particular USB NIC? If so, go ahead and try that kernel and see what happens.



  • I’ve set the kernel arguments system-wide, as well after host registration - I still can’t get anything to boot using USB NIC! Not sure what I’m missing.



  • Thanks, found it under FOG System Settings.


  • Moderator

    @yochaigal Don’t have a FOG system near me right now, so not 100% sure, but from memory, I think it’s Settings -> FOG Settings -> General Settings



  • This post is deleted!


  • Thanks.
    Forgive my ignorance here, but where can I set system-wide kernel arguments?
    Thanks


  • Moderator

    alt text

    Same Kernel option can be used on groups and system wide in the FOG options.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.