[1.3.0-RC-8] Issue when connecting to a node with Active Directory Authentication style



  • Server
    • Version: [1.3.0-RC-8]
    • OS: Debian Wheezy
    Description

    When doing replication between nodes, I have a login issue with this command :

    lftp -e 'set ftp:list-options -a;set net:max-retries 10;set net:timeout 30;  mirror -c -R --ignore-time -vvv --exclude 'dev/' --exclude 'ssl/' --exclude 'CA/' --delete-first /images/GEO2015AUTPOST /ifs/data/ACAD/DIR-CI/SAMARIS/geo-bkp2/GEO2015AUTPOST; exit' -u domain\fog,[Protected] xx.yyy.zz
    

    When modifying this command this way (quoting user name), it does work :

    lftp -e 'set ftp:list-options -a;set net:max-retries 10;set net:timeout 30;  mirror -c -R --ignore-time -vvv --exclude 'dev/' --exclude 'ssl/' --exclude 'CA/' --delete-first /images/GEO2015AUTPOST /ifs/data/ACAD/DIR-CI/SAMARIS/geo-bkp2/GEO2015AUTPOST; exit' -u "domain\fog",[Protected] xx.yyy.zz
    

    This way it also works (user@domain) :

    lftp -e 'set ftp:list-options -a;set net:max-retries 10;set net:timeout 30;  mirror -c -R --ignore-time -vvv --exclude 'dev/' --exclude 'ssl/' --exclude 'CA/' --delete-first /images/GEO2015AUTPOST /ifs/data/ACAD/DIR-CI/SAMARIS/geo-bkp2/GEO2015AUTPOST; exit' -u fog@domain,[Protected] xx.yyy.zz
    

    It seems that there is an issue handling backslashes

    Thank you in advance for checking this.

    Guillaume

    Here is an excerpt from the fogreplicator log :

    [09-02-16 6:51:42 pm] * Found Image to transfer to 2 node(s)
    [09-02-16 6:51:42 pm] | Image name: GEO-2015AUT-POST
    [09-02-16 6:51:43 pm] * Starting Sync Actions
    [09-02-16 6:51:43 pm] | CMD:
    lftp -e ‘set ftp:list-options -a;set net:max-retries 10;set net:timeout 30; mirror -c -R --ignore-time -vvv --exclude ‘dev/’ --exclude ‘ssl/’ --exclude ‘CA/’ --delete-first /images/GEO2015AUTPOST /ifs/data/ACAD/DIR-CI/SAMARIS/geo-bkp2/GEO2015AUTPOST; exit’ -u domain\fog,[Protected] xx.yyy.zz
    [09-02-16 6:51:44 pm] * Started sync for Image GEO-2015AUT-POST
    [09-02-16 6:51:44 pm] * Found Image to transfer to 2 node(s)
    [09-02-16 6:51:44 pm] | Image name: GEO-2015AUT-PRE
    [09-02-16 6:51:46 pm] * Starting Sync Actions
    [09-02-16 6:51:46 pm] | CMD:
    lftp -e ‘set ftp:list-options -a;set net:max-retries 10;set net:timeout 30; mirror -c -R --ignore-time -vvv --exclude ‘dev/’ --exclude ‘ssl/’ --exclude ‘CA/’ --delete-first /images/GEO2015AUTPRE /ifs/data/ACAD/DIR-CI/SAMARIS/geo-bkp2/GEO2015AUTPRE; exit’ -u domain\fog,[Protected] xx.yyy.zz
    [09-02-16 6:51:46 pm] * Started sync for Image GEO-2015AUT-PRE
    [09-02-16 6:51:46 pm] * Found Image to transfer to 2 node(s)
    [09-02-16 6:51:46 pm] | Image name: geo-2015P-dep
    [09-02-16 6:51:47 pm] | Local File: /images/geo2015Pdep/d1.mbr
    [09-02-16 6:51:47 pm] | Remote File: /ifs/data/ACAD/DIR-CI/SAMARIS/geo-bkp2/geo2015Pdep/d1.mbr
    [09-02-16 6:51:48 pm] | Local File size: 512
    [09-02-16 6:51:48 pm] | Remote File size: 512
    [09-02-16 6:51:48 pm] | Files match
    [09-02-16 6:51:48 pm] | Local File: /images/geo2015Pdep/d1p1.img
    [09-02-16 6:51:49 pm] | Remote File: /ifs/data/ACAD/DIR-CI/SAMARIS/geo-bkp2/geo2015Pdep/d1p1.img
    [09-02-16 6:51:49 pm] | Local File size: 8926699
    [09-02-16 6:51:49 pm] | Remote File size: 8926699
    [09-02-16 6:51:49 pm] | Files match
    [09-02-16 6:51:50 pm] | Local File: /images/geo2015Pdep/d1p2.img
    [09-02-16 6:51:50 pm] | Remote File: /ifs/data/ACAD/DIR-CI/SAMARIS/geo-bkp2/geo2015Pdep/d1p2.img
    mirror: Login failed: 530 Login incorrect.
    mirror: Login failed: 530 Login incorrect.



  • Problem solved in 1.3.0-RC-10. Thanks !


  • Senior Developer

    @glefebvr Can you try using the rc 10 working branch for a replication?

    I just want to see if all is working properly. I’ve added safe argument handling to the lftp commands so theoretically your particular case should work once again.



  • No, my password does only have letters and digit in it. I didn’t test passwords with backslashes, but only with the username. As shown by my examples, it seems that FOG is not escaping correctly the backslash in the username.


  • Moderator

    Does your password have a backslash in it, or any other special characters? I have had issues in the past with using the $ character. Of course, a backslash in Linux means escape, but within single quotes it is not interpreted and just represents an ascii char.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.