iPXE error 4c126035 when booting



  • Hey, guys. Have an issue when iPXE booting, it says “connection timed out” with error 4c126035. iPXE configuring NIC in 1-3 attempts (error 040ee119), finally succeeds and after that gives an error above. Everything worked fine on separate network for fog (it is not convenient for me) , but ever since I moved it to an existing it is not. I ran out of ideas how to troubleshoot, seen old posts about similar problem, but solutions did not help. Using ubuntu 14.04, Fog Version 1.3.0-RC-8 and dnsmasq for integrating fog to an existing network. Thank You for your help!


  • Moderator

    @t1pt0p the problem is that stp IS enabled. You need to enable a fast stp protocol. The quick test is to put an unmanaged switch between your building switch and the target computer.

    If you have stp turned on, then look for port fast, fast stp, or rstp and turn it on on the target computer port.



  • @Wayne-Workman It did not work -( Tried two switches, also wireshark + tcpdump shows STP, so I guess it is enabled… Thank You for the help anyway


  • Moderator

    it sounds like spanning-tree / portfast is not enabled.

    Basic test is - put a non-managed (dumb) mini-switch between a computer and the building network, see if it works or not.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.