Lenovo Miix 700



  • Hi Team,
    I have 27 Lenovo miix 700 i can’t use fog to image them they start to pxe says download MIB then start to windows i did update to last version of fog is any way i can image them using fog Thank you


  • Moderator

    @arton Are you sure the HDD exit type isn’t just set wrong for this device? Try Grub.



  • yes we do gave hide menu enabled


  • Moderator

    @george1421 I think he has hide menu enabled.

    We have hide menu enabled, this is ours:

    #!ipxe
    set fog-ip 10.2.1.11
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    cpuid --ext 29 && set arch x86_64 || set arch i386
    iseq ${platform} efi && set key 0x1b || set key 0x01
    iseq ${platform} efi && set keyName ESC || set keyName CTRL + A
    prompt --key ${key} --timeout 4000 Booting... (Press ${keyName} to access the menu) && goto menuAccess || sanboot --no-describe --drive 0x80
    :menuAccess
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param platform ${platform}
    param username ${username}
    param password ${password}
    param menuaccess 1
    param debug 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :bootme
    chain -ar http://10.2.1.11/fog/service/ipxe/boot.php##params
    


  • both times i run a upgrade I’m creating a new server Ubuntu 16.04 and reinstall from scratch


  • Moderator

    @arton Just for clarity what were you trying to do when it created this menu? Were you trying to boot an unregistered device into the FOG iPXE menu or were you trying to deploy to this device?

    The reason why I ask is that this menu isn’t complete. It has more lines than I expected but it isn’t what I expected. We may need to have the developers look at this.

    I would have expected something like this based on the command I gave you

    #!ipxe
    set fog-ip 192.168.1.88
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    cpuid --ext 29 && set arch x86_64 || set arch i386
    goto get_console
    :console_set
    colour --rgb 0x00567a 1 ||
    colour --rgb 0x00567a 2 ||
    colour --rgb 0x00567a 4 ||
    cpair --foreground 7 --background 2 2 ||
    goto MENU
    :alt_console
    cpair --background 0 1 ||
    cpair --background 1 2 ||
    goto MENU
    :get_console
    console --picture http://192.168.1.88/fog/service/ipxe/bg.png --left 100 --right 80 && goto console_set || goto alt_console
    :MENU
    menu
    colour --rgb 0x00567a 0 ||
    cpair --foreground 1 1 ||
    cpair --foreground 0 3 ||
    cpair --foreground 4 4 ||
    item --gap Host is NOT registered!
    item --gap -- -------------------------------------
    item fog.local Boot from hard disk
    item fog.memtest Run Memtest86+
    item fog.reginput Perform Full Host Registration and Inventory
    item fog.reg Quick Registration and Inventory
    item fog.deployimage Deploy Image
    item fog.multijoin Join Multicast Session
    item fog.sysinfo Client System Information (Compatibility)
    item mdtlti.x86 MDT LiteTouch x86 Boot
    item winpe7a WinPE tester
    choose --default fog.local --timeout 3000 target && goto ${target}
    :fog.local
    sanboot --no-describe --drive 0x80 || goto MENU
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=192.168.1.88/fog/ consoleblank=0 rootfstype=ext4 loglevel=4
    imgfetch init_32.xz
    boot || goto MENU
    :fog.memtest
    kernel memdisk iso raw
    initrd memtest.bin
    boot || goto MENU
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=192.168.1.88/fog/ consoleblank=0 rootfstype=ext4 loglevel=4
    imgfetch init_32.xz
    boot || goto MENU
    :fog.reginput
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=192.168.1.88/fog/ consoleblank=0 rootfstype=ext4 loglevel=4 mode=manreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.reg
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=192.168.1.88/fog/ consoleblank=0 rootfstype=ext4 loglevel=4 mode=autoreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.deployimage
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param qihost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :fog.multijoin
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param sessionJoin 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :fog.sysinfo
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=192.168.1.88/fog/ consoleblank=0 rootfstype=ext4 loglevel=4 mode=sysinfo
    imgfetch init_32.xz
    boot || goto MENU
    :mdtlti.x86
    initrd http://192.168.1.88/fog/iso/LiteTouchPE_x86.iso
    chain memdisk iso raw
    :winpe7a
    initrd http://192.168.1.88/fog/iso/winpe_amd64.iso
    chain memdisk iso raw
    :bootme
    chain -ar http://192.168.1.88/fog/service/ipxe/boot.php##params ||
    goto MENU
    autoboot
    

    Since you are running ubuntu can you tail the apache error log. I think its called error.log.
    One last question, was this system upgraded or did you install it new?



  • #!ipxe
    set fog-ip 192.168.15.187
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    cpuid --ext 29 && set arch x86_64 || set arch i386
    iseq ${platform} efi && set key 0x1b || set key 0x01
    iseq ${platform} efi && set keyName ESC || set keyName CTRL + A
    prompt --key ${key} --timeout 3000 Booting… (Press ${keyName} to access the menu) && goto menuAccess || exit
    :menuAccess
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param platform ${platform}
    param username ${username}
    param password ${password}
    param menuaccess 1
    param debug 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :bootme
    chain -ar http://192.168.15.187/fog/service/ipxe/boot.php##params

    Server is Ubuntu 14.04 LTS


  • Moderator

    The calls look good in the last picture, is the firewall on for the fog server? What OS is it running?


  • Moderator

    @arton This last picture is what I might expect to see from pxe booting a bios (legacy) system with undionly.kpxe (not an uefi boot, it doesn’t matter but just trying to set the context). Is this the case? I’m still getting the impression that your install is broken.

    What I want you to do next is to (with a web browser) key in http://192.168.15.187/fog/service/ipxe/boot.php?mac=00:00:00:00:00:00 and post the results here. Ideally this should display the FOG ipxe boot menu in its entirety (> 20 lines of stuff). If you get 3 or 4 lines and that is it, then we will need you to post (tail) the apache error log because something is broken.



  • here is the error0_1472581488719_fogerror.PNG



  • yes i can put a mini switch between building network and pc i let y know the results


  • Moderator

    @arton Can you answer the other questions please?



  • i dont see any post about port fast on network


  • Moderator

    @arton What’s doing DHCP there? Did you follow the article I posted earlier? Do you hae PortFast enabled on your switch? Can you try to place a mini-switch between the computer and the building network?



  • yes it did finish completely


  • Moderator

    @arton Did the installer complete?



  • thank you i did run the install again now the tftpboot has all the files now i getting different error here is the picture 0_1472577570581_error.PNG


  • Moderator

    @arton that’s very strange why the tftpboot directory is that why. Your screen shot contains what I would expect in the /tftpboot dir

    Did the fog installer run to completion? Please run the installfog script again. If you are using a Debian based Linux you will need sudo then installfog.sh.



  • yes what i did fallow the command on the how to upgrade so they it sad to make a Dir under root name fog-project then run the download svn then i did run installfog.sh from that directory.
    Now when i look under fogproject/packages/tftp/ I see 0_1472573559982_fog.PNG


  • Moderator

    @arton Well that’s not right for 1.3.0-rcX series. Did you upgrade this install from a previous release? This looks a bit like a FOG 0.30 tftp directory.

    How did you install 1.3.0? I assume you downloaded the installer from git or svn, then did you run the installfog.sh script in the bin directory?



  • that all what i have on tftpboot directory 0_1472571535761_tftpboot.PNG


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.