"Add to group" dropdown broken on host search



  • Server
    • Version: 1.3.0-RC-8
    • OS: CentOS 7
    Client
    • Version: 0.11.5
    • OS: Windows 7
    Description

    The drop down box for “Add to group” appears to be non-functional and/or not populated when performing a “New Search” on “Host Management”. The drop down box isn’t populated with groups and is only a sliver wide (see screenshot). The box works properly if you instead use the top row search boxes from the “List All Hosts” screen. We only have a single group configured currently if that makes a difference. 0_1471967956327_FOG Search.JPG



  • @Wayne-Workman That’s something that I’d considered but what gets me is that the drop down loads appropriately on the “List All Hosts” page. I haven’t taken a look to be certain but I’d guess that the code is the same for both pages for that part so the fact that it works on one for me and not the other would seem to indicate a bug that I’m hitting due to some edge or corner case.



  • @Darrin-Enerson My advice would be to not use IE for FOG management.

    Tom can’t reproduce with IE, nor can I. So the issue is specific to your IE settings, your image, your group policy, whatever it is, it’s specific to you.



  • @Wayne-Workman Both Firefox 48.0.1 and Chrome 52.0.2743.116 m load the drop down appropriately on the same computer that is experiencing the issue in IE11.0.9600.18350. When I try the same page on a different computer running Windows 7 Enterprise with IE11.0.9600.18426 I get the same result with the drop down not appearing correctly. Seems to be an issue with IE11 on Windows 8.1 and 7 at the very least.



  • @Darrin-Enerson See if the GUI issue happens on a totally different computer. See if it happens when using Chrome in Incognito mode. Try with Firefox using Privacy Mode.



  • @Wayne-Workman The SQL commands produce this:

    [root@fogserver ~]# mysql
    Welcome to the MariaDB monitor.  Commands end with ; or \g.
    Your MariaDB connection id is 31
    Server version: 5.5.50-MariaDB MariaDB Server
    
    Copyright (c) 2000, 2016, Oracle, MariaDB Corporation Ab and others.
    
    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
    
    MariaDB [(none)]> use fog;
    Reading table information for completion of table and column names
    You can turn off this feature to get a quicker startup with -A
    
    Database changed
    MariaDB [fog]> select groupID,groupName from groups;
    Empty set (0.00 sec)
    

    I deleted /var/www/html/fog as directed and then reinstalled fog from my existing git pull. Created new group “Test”.0_1472047857195_FOG Groups - Test.JPG

    Searched for “Test-650G1-01” with the same result:0_1472047889760_FOG Search - Test-650G1-01 - Test Group.JPG

    Here is the result of the same SQL commands after this process:

    [root@fogserver bin]# mysql
    Welcome to the MariaDB monitor.  Commands end with ; or \g.
    Your MariaDB connection id is 14
    Server version: 5.5.50-MariaDB MariaDB Server
    
    Copyright (c) 2000, 2016, Oracle, MariaDB Corporation Ab and others.
    
    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
    
    MariaDB [(none)]> use fog;
    Reading table information for completion of table and column names
    You can turn off this feature to get a quicker startup with -A
    
    Database changed
    MariaDB [fog]> select groupID,groupName from groups;
    +---------+-----------+
    | groupID | groupName |
    +---------+-----------+
    |       2 | Test      |
    +---------+-----------+
    1 row in set (0.00 sec)
    
    


  • @Darrin-Enerson Well that makes no sense at all. You could delete the web directory and re-install fog RC-8 to guarantee your web files are good.

    rm -rf /var/www/html/fog
    Then, re-install fog 1.3.0 RC-8, do it as usual. it’ll rebuild the web directory. Then see if the issue is fixed.

    Also, I’m going to give you SQL to check your groups.

    mysql
    use fog;
    select groupID,groupName from groups;
    


  • @Wayne-Workman Group deleted:
    0_1472044941200_FOG Groups - Deleted.JPG

    New search for Test-650G1-01:
    0_1472044966376_FOG Search - Test-650G1-01 - Deleted Group.JPG



  • @Darrin-Enerson Next, please try to delete the one group you have, not the hosts in it, just the group. See how that affects it.



  • @Wayne-Workman Same result on both searches:
    0_1472044338259_FOG Search - Test-650G1-01.JPG 0_1472044351895_FOG Search - Image-Test.JPG



  • Do a search in host management - use the “New Search” thing, it’s the default page when you click Host Management.

    Search for Test-650G1-01 and see what happens.

    Then search for Image-Test and see what happens.


  • Senior Developer

    I’m running from IE11 on Windows 10 and I’m not seeing the issue. I don’t have any systems with Windows 8.1 though.



  • @Tom-Elliott Here’s a screenshot of our groups listing on that server. I should also note that I’m using IE11 on Windows 8.1.
    0_1471971475621_FOG Groups.JPG


  • Senior Developer

    Do you have a group name who’s only character is a space?

    I can’t reproduce.

    For example from working RC-9:

    0_1471971242475_upload-bcd9aa5d-2804-4c9a-8859-48fa6f023b66

    And from RC-8:

    0_1471971297344_upload-6af549e9-1715-47d6-a76b-12eab1224390


 

427
Online

41.6k
Users

12.1k
Topics

114.4k
Posts