IPXE boot issue - Realtek RTL8153 - DELL VENUE - Resolved



  • Hi all,

    Am trying to image a few Dell Venue 11’s using the official DELL USB Ethernet adaptor which is a Realtek RTL8153 model.

    When i first tried it, it hanged on iPXE initialising devices, after going through the forum i realised that i was to change my option 67 to undionly.kkpxe.

    I changed my option 67 and i got happy to soon and the system started to hang on
    http://my-ip-address//fog/service/ipxe/boot.php…90%…

    My project is on version 1.2.0 however for test purposes i made a clone vm and upgraded the fog 1.2.0 to the trunk version and this time the same thing happens but hangs on 36%

    Any ideas anyone, in whats wrong?

    Thank you.


  • Moderator



  • @george1421 thank you, yes we use win 2012 r2. I did set this up in the past partially never really got to testing it as all our machines within the organisation are on legacy mode. certainly will now try it.


  • Moderator

    @owlz89 If your dhcp server is a windows 2012 server then you have some options to make both bios (legacy) and uefi systems happy so you don’t need to mess with dhcp option 67 all the time: https://forums.fogproject.org/topic/4859/fog-bios-and-efi-coexistence



  • okay figured it out. it seems the DELL Venue Pro 11 does not like legacy mode. (well realtek RTL8153 doesn’t like legacy mode)

    What you have to do is change the boot option 67 to snponly.efi and boot via UEFI ipv4. I didnt test to see if it registered the host as i manually entered the mac address & host details on the web management service and set the task via the web management console.

    Thank you for your help @george1421 & @Sebastian-Roth

    UPDATE: I was using Fog 1.3.0-RC-8 & i had to reinstall OS from scratch after changing bios to UEFI as Fog looks for a gpt scheme on HDD (in the venue’s case a eMMC) or it will fail.



  • @george1421 yes, i only have one running at a time. Never really tried it lol would certain make the server confused. Joking a side, I already have option 67 on undionly.KKpxe not Kpxe but i will certain give ipxe.kpxe a go and see how it responds.

    No need to apologies mate am glad your someone who’s responding to my fault, so Thank you.


  • Moderator

    @owlz89 just to be clear when you say you have two vms (1.2.0, 1.3.0) you are only running one at a time?

    OK so the venue is in legacy mode and it is booting into the FOG iPXE menu. That tells me that iPXE is having an issue with that nic. As a test instead of using undionly.kpxe, test to see how undionly.kkpxe or ipxe.kpxe responds to the boot attempt? There is also a specific realtek kernel realtek.kpxe. Sorry I can’t give you a definitive answer, but your system should just work in legacy mode.



  • @george1421 I have two VM’s (one with fog 1.2.0 & another 1.3.0) and their both have the same ip address (10.0.21.0) I have checked the tftp config file and it’s pointing to the right IP.

    Option 67 is set to undionly.kkpxe, my venue bios is on legacy mode and my Fog trunk version is the latest 1.3.0-rc8.

    Technically there is nothing wrong with the fog server as i have re-imaged a laptop and uploaded a image (which has a built in NIC not a venue) and it worked fine on both servers (fog 1.2.0 & 1.3.0)

    It just right now the problem is when am on the boot menu and i try registering the host the venue either restarts or the screen stays blank. If i register the device before hand & then try set a task to lets say download (re-image) it freeze’s the moment it reads the kernal (bzImage)

    @Sebastian-Roth I checked most of the forum & wiki page bud & yes there is quite a lot of issue with this model (chip) i just assumed there might have been a fix now as this problem dated back to many years. Thank you for iPXE binaries.


  • Moderator

    For now lets only consider the version of fog you updated to trunk. What version of fog did you upgrade to. The trunk version is a moving target. Currently the trunk is 1.3.0-rc8. Once you did that did you remember to change dhcp options 66 and 67 to point to your new fog server?

    From there since you cloned your 1.2.0 vm, please confirm that the IP address in the file /tftpboot/defauly.ipxe points to your new FOG server. (It should but this is just a safety check. You an use the command cat /tftpboot/default.ipxe to view its content).

    What precisely do you have listed for dhcp option 67?

    Is your Venue setup for bios (legacy) mode or uefi?

    I can tell you those realtek nics are a PITA at times.


  • Developer

    @owlz89 Searching the forum for ‘RTL8153’ you will find many people having issues with NICs based on that chip. You can try downloading newer iPXE binaries from here and see if you can make it work with those. If the new iPXE binaries work you might want to look into upgrading to the latest version as there has been lots of improvements since FOG 1.2.0 was released.



  • how strange, when i pressed the enter button on the keyboard the percentage went from 90% to a 100% and went onto the next command line…http://my-ip-address/fog/service/ipxe/bg.png and then the same thing is occuring where i have to press the enter button after a few seconds to get the percentage up.

    Update: i can now get to the boot menu screen however it hangs on the bzimage…i just need a workaround so if there’s a method please me know.

    Note: am a beginner on linux so if there;s any specific config file change that i need to then could you please tell me via steps.

    Thank you


Log in to reply
 

395
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.