[1.3.0-RC-8] Issues with UEFI boot



  • Server
    • Version: 1.3.0-RC-8
    • OS: Debian Wheezy
    Description

    Issue 1 :
    I changed the “Boot Key Sequence” in FOG settings to “Ctrl + N”. When I net boot on legacy systems, I indeed need to press Ctrl + N to enter the boot menu, but when I net boot on UEFI systems, I still need to press ESC to enter the boot menu.

    Issue 2 :
    With the setting “Exit to Hard Drive Type(EFI)” set to “REFIND_EFI”, when net booting a UEFI system without any user intervention, I have the following rEFInd message :
    "NOTE: refind.conf’s scanfor line specifies scanning for one or more legacy (BIOS) boot options; […]
    Hit any key to continue"
    And the system is indeed waiting for user intervention, which I doesn’t want. I noticed that the rEFInd scanfor parameter is set to “scanfor internal,hdbios,external,biosexternal”. When I modify this parameter to “scanfor internal”, it just works flawlessly and boots right away to the internal disk. So two questions :

    • In UEFI mode, is it necessary to try next boot on legacy devices ?
    • Is it possible to have an option to handle UEFI with or without legacy support in FOG, option which could modify that file ?

    Thank you


  • Senior Developer

    Neither of these two things are bugs in the sense that FOG is not capable of fixing them.

    For UEFI boot, the escape key sequences aren’t built into iPXE. The only key sequence that is is the ESC key which is why it defaults to it.

    The rEFInd config is default from the source itself, and it’s designed to allow you to configure your own needs as needed. While I could create a better config, it’s still very dependent on your own environment.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.