Multicast issue



  • Hello,

    I have been trying to make multicast working fine for a while now, but i still get “Please wait…” forever on every screen. I tried to follow what has been told on the fog wiki about troubleshooting multicast ([url]http://fogproject.org/wiki/index.php?title=Troubleshooting_a_multicast[/url]), and everything worked fine, but multicast deployment still does not work when I start it using fog management page.

    I edited /var/www/fog/commons/config.php and /opt/fog/service/etc/config.php so that my password is the good one for both file.

    Here is what I already noticed that seems weird for my non_fog_expert eyes :

    • I have no multicast.log file and no file at all under /opt/fog/log/
    • When I start a multicast task, “ps aux | grep images” and “ps aux | grep udp” returns nothing
    • I installed phpmyadmin, and there is no “fog” user in my users tab

    Any help would be welcome :-)

    Thanks.



  • Hello,

    There is no /opt/fog/service/common/etc/config.php file, I supposed you meant /opt/fog/service/etc/config.php :)

    service FOGMulticastManager status does not work, only start|stop|restart, start fail at first, but stop work, then start work, and still no multicast working :(

    I forgot something else in the “What I have already done list” : ip igmp on all my HP switches, and no router between FOG server and any of my clients.

    update after some more tests: ps aux | grep udp returns something when I run “gunzip -c “/images/anyimagename” | /usr/local/sbin/udp-sender --min-receivers 2 --portbase 9000 --interface myInterface --half-duplex” manually from command line then connect with debug mode 2 clients, but still nothing when I start a new multicast task from fog management webpage.



  • Get the service config file [CODE]cat /opt/fog/service/common/etc/config.php[/CODE] and do [CODE]service FOGMulticastManager status[/CODE] to make sure the manager is actually running.


Log in to reply
 

803
Online

38953
Users

10706
Topics

101571
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.