Images Directory Permissions



  • Hello FOG Gang

    I upgraded the latest FOG Server (1.3) and now for some reason I can’t get to my “/images” folder. I followed this article
    https://wiki.fogproject.org/wiki/index.php?title=Images_Directory_Permissions

    My folder permissions looks like this:

    drwxrwxrwx 36 fog root 4096 Apr 13 12:44 images

    Worse thing is I can’t even get to it via ftp://

    Something definitely happened after the upgrade. I disabled firewall and selinux, I’ve reset the password and I’ve already checked the Storage Node settings but nothing.

    Do I have to change anything else?



  • @Wayne-Workman Thanks Wayne! I appreciate the help and patience! You’re the man!



  • I helped via team viewer.

    The location were images was being kept was changed from /images to /deploy but fields in Storage Management, /opt/fog/.fogsettings, and in /etc/exports were not updated. After doing that, everything was fine.



  • @anthony.delarosa I’m trying to message you, top right talk bubble.



  • @Wayne-Workman the permissions are correct, I just keep seeing this error:



  • @anthony.delarosa Did you set permissions on /images recursively? There are examples of this in the troubleshooting article I posted.



  • So I re-ran the installer and I do notice one thing this installer does. It changes the fog linux account to a different password which is in .fogsettings

    I had to change the local password using passwd fog and then change the .fogsettings to match that. However I still cannot ftp into my “images” folder from Windows Explorer. If I just type: ftp://fog.server.com it prompts me for a username and password and it works, when I change it to my “images” folder it saids I have no access. Something is definitely going on.



  • @anthony.delarosa said in Images Directory Permissions:

    FTP into that folder from Windows Explorer, it asks me for username and password?

    Can you look at the “Testing” section in here please?
    https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_FTP

    If you can’t FTP into the folder using the fog account and the password in the .fogsettings file, then something is goofed somewhere. The installer has a high chance of fixing the issue if you just re-run it.



  • @Wayne-Workman this is what my .fogsettings file looks like:

    Created by the FOG Installer

    Version: 1.3.0-RC-8

    Install time: Mon 15 Aug 2016 12:05:16 PM PDT

    ipaddress='192.168.170.128’
    interface='eth0’
    routeraddress='option routers 192.168.170.6;'
    plainrouter='192.168.170.6’
    dnsaddress='option domain-name-servers 192.168.170.11;'
    dnsbootimage=“192.168.170.11”;
    password=“5yB6j2M/N9B4GT5wtfkRnpCq73Z23OGLE1T2IPvIGCw=”

    I am not sure what that password is for but is that the one I have to change to match my “fog” username and password?
    I do have a user in the Linux Server called “fog” and I do have a folder under home. Also vsftpd is running just fine, I even restarted the service but the weird part is I can’t even FTP into that folder from Windows Explorer, it asks me for username and password but keeps telling I have no access.

    drwxrwxrwx 36 fog root 4096 Aug 10 15:40 images



  • @george1421 said in Images Directory Permissions:

    The FTP (fog) user is what typically gets confused on an upgrade.

    The latest trunk installer now fixes FTP credentials in the DB without any extra web credentials in .fogsettings - those extra credential requirements were removed entirely. Now, for an existing fog server, when the latest installer is ran, it sets the fog user to whatever is in the .fogsettings password field, and updates the Storage Node entry in the (remote or local) Database for the node the installer is running on. Things are now streamlined.

    Considering this and the OP’s errors - I’d question if vsftpd is even running, and if it is, I’d see if the fog user has a home folder inside /home


  • Moderator

    I would confirm that your fog (linux user) password matches what is defined in your fog gui configuration. If they do not match then copy the contents of the fog gui settings and update the /opt/fog/.fogsettings file then rerun the installer. This should get everything back in sync.

    The FTP (fog) user is what typically gets confused on an upgrade.


 

395
Online

41.5k
Users

12.0k
Topics

113.5k
Posts